My site is heavily using WPMUDEV plugins, is it safe to upgrade to 4.1?

Just want to ask the experts here if upgrading my WPMUDEV'ish multisite to 4.1 is safe.

The other day it broke my wp_sitemeta. I upgraded another site and it looks fine. Not sure whether that issue was due to the upgrade happening at the same time my Snapshot schedule ran.