My site is still not fast

My site is still not fast, please, enter my site, is there something I missed in your additions, is there anything that will increase the speed of my site.

Help please ..

Thank you,,

  • Nithin
    • Support Wizard

    Hi Mahmoud,

    I could notice the images are broken when I check the homepage. We would like to check the website dashboard to see the current configurations to have a better idea regarding what all improvements could be done further.

    Could you please grant support staff access so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access so that we could get this sorted. Have a nice day.

    Kind Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi Mahmoud,

    I could notice there’s an issue with Smush Lazyload enabled due to the “no-js” class in your theme side. Please add the following code as a mu-plugins:

    <?php

    function wpmu_change_js_class() {
    echo '<script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script>'. "n";
    }
    add_action( 'wp_head', 'wpmu_change_js_class', 1 );

    Please check the following article on how to add the above code as a mu-plugins:

    https://premium.wpmudev.org/manuals/wpmu-manual-2/using-mu-plugins/

    Once the code is added, please do enable Smush Lazyload feature. I have temporarily disabled Lazyload for now.

    I checked other aspects of the Hummingbird plugin settings, to improve the website load speed, you’ll have to enable Asset Optimization.

    Asset Optimization feature helps you with optimizing the website by minifying, compressing, and combining the assets. You can enable it in the plugin side, under Hummingbird Pro > Asset Optimization page.

    You can check the following article on how to move forward with Asset Optimization:

    https://premium.wpmudev.org/blog/eliminate-render-blocking-issues-hummingbird/

    https://premium.wpmudev.org/docs/wpmu-dev-plugins/hummingbird/#chapter-4

    Please do let us know how configuring the above settings goes. So that we could check further if needed.

    Kind Regards,

    Nithin

  • Ash
    • WordPress Hacker

    Hello Mahmoud

    The major two issues are Eliminate render-blocking resources and High TTFB.

    To lower the TTFB, you can do several things. The first one is to change the server if you are on shared hosting. You may consider having a dedicated hosting or VPS or managed hosting which should increase the speed. Besides, I can see you don’t have page cache enabled. So you better enable page caching from Dashboard > HummingBird Pro > Caching > Page Caching.

    Next, it may also happen due to lots of plugins. This is possible that one of your plugins have a query which takes lots of time to process, that will slow your site down too. So, in that case, you can run a conflict test. To run a conflict test please deactivate all plugins and check if the TTFB is lower. If so, then enable all plugins one by one and find which one is having conflict. You need to do the same with themes as well.

    You can find the flowchart here: https://premium.wpmudev.org/docs/getting-started/getting-support/#initial-troubleshooting

    About the Eliminate render-blocking resources, this is a bit tricky. First take a backup of your site. Then, go to Dashboard > HummingBird Pro > Asset Optimization > Activate. Then enable advanced mode. Now you will see 5 buttons for each file. The third one is “Move to footer”. But sometimes it breaks the site. You have to select 5 files at a time and update. Next, check the front end if anything breaks. If nothing breaks, add next 5 files for moving to footer. If it breaks, rever the last changes and move next 5 files.

    It should help you to make the website lot faster. Let us know how it goes.

    Cheers,

    Ash

  • Mahmoud
    • WPMU DEV Initiate

    Please, I have followed the steps to install Installing WordPress mu-plugins until step number 4 in the link you sent.

    Now I’m sorry I’m confused, at the step of installing the plugin, step “1- Download the plugin”, where do I download it, where is this plugin?

    help please,

    thank you,,

    • Nithin
      • Support Wizard

      Hi Mahmoud,

      Now I’m sorry I’m confused, at the step of installing the plugin, step “1- Download the plugin”, where do I download it, where is this plugin?

      There are two sections in the given article:

      https://premium.wpmudev.org/manuals/wpmu-manual-2/using-mu-plugins/

      1. Setting up your mu-plugins folder, and 2 Installing mu-plugins. I suppose you were checking the second section?

      Let me just brief up the steps overall:

      1) Using FTP or SFTP login, create a folder called “mu-plugins” inside /wp-content directory.

      2) In some host, the mu-plugins folder would have already been created by the host. If there is already a folder called mu-plugins, then the next steps would be to create a PHP file inside mu-plugins folder. You can give any unique name like for example, wpmu-custom-code.php etc for the PHP file, and save the above-given code.

      Once done, the given code should work on your website. I hope it’s clear now. Please do let us know how the rest of the suggestions given in the ticket goes.

      Regards,

      Nithin

  • Mahmoud
    • WPMU DEV Initiate

    well, i have added this code:

    <?php

    function wpmu_change_js_class() {

    echo ‘<script>document.documentElement.className = document.documentElement.className.replace(“no-js”,”js”:wink:;</script>’. “n”;

    }

    in side the wpmudev.php file inside wp-content folder

    Now I am still suffering from poor performance and slow site, where are your solutions please, what is the next step?

    Thank you,,

  • Nithin
    • Support Wizard

    Hi Mahmoud,

    Sorry for the delay in getting back to you. Please do note that we reply to tickets based on queue order, sending multiple replies in the ticket would bring the ticket down the queue hence a delay.

    It seems like support access to your website is no longer enabled, so I wasn’t able to check your website further.

    well, i have added this code:

    I checked your website via frontend but I don’t see any changes in the website side regarding the added code.

    Now I am still suffering from poor performance and slow site, where are your solutions please, what is the next step?

    Once the mentioned code is added. You could have enabled Asset Optimization as mentioned in my initial reply. However, I could notice anomalies in your website side and would like to further check the website in the server-side.

    Could you please send us your websites credentials, so that we could give a closer look.

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    – To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas

    -WordPress admin username

    -WordPress admin password

    -login URL

    -FTP credentials (host/username/password)

    -link back to this thread for reference

    -any other relevant URLs

    Please do follow up on the ticket once you have sent the above credentials. Have a nice day.

    Kind Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi Mahmoud,

    I further tested on your website and could notice the lazy loading feature in Smush Pro plugin side is causing a conflict with the existing theme. Had to keep it disabled for now, and have enabled Smush CDN.

    Could I know where your website is hosted? Is it on WP Engine? If yes, do you have Server side cache enabled in WP engine side? Please do purge if there are any cache enabled in WP Engine hosting side.

    Normally, there would be a menu in the WordPress dashboard related to WP Engine which isn't present in your WP dashboard side, so double-checking whether it's hosted on WP Engine or not.

    Also, it seems like you have connected your website with Cloudflare. Could you please make sure to connect Cloudflare, under Hummingbird Pro > Caching > Browser Caching so that browser caching could be controlled via the Hummingbird Pro plugin side.

    I have also enabled Asset Optimization, under Hummingbird Pro > Asset Optimization page, along with cache, and now the website seems to load fast.

    However, I also ran a pnigdom test on your website and could notice your server does take time to establish an initial connection:

    https://tools.pingdom.com/#5b40ac05ac400000

    Would recommend you to check with your hosting provider to see whether these could be improved in the server-side too.

    What Hummingbird could do is help with Application-level fixes, if the server, in general, is slow no amount of fixes in a plugin should would help as the server isn't loading as required.

    Please do let us know what your hosting provider has to say regarding these so that we could check further if needed.

    Regards,

    Nithin

  • Mahmoud
    • WPMU DEV Initiate

    hi,

    I have added CloudFlyare details in the exact place, and sent to wpengine support your message, this was his response:

    {

    Howdy Mahmoud,

    Thanks for your patience while I investigated this. I’m very sorry to hear the site is experiencing performance issues. But I’ll be glad to see if we can get to the bottom of that.

    I believe I’ve found the likely culprit of the issue and we would recommended dealing with this first, before troubleshooting further. It has to do with DB Autoloaded Data, and especially for the zasstore Install.

    In WordPress, the database holds many of your site’s settings. These settings can include a list of active plugins, your active theme, your site’s URL, theme settings, plugin settings, and more. The wp_options table in your database is where these settings are stored. Sometimes themes and plugins like to store extra items there, like Transients, long lists of redirect rules, and other lengthy settings. In this table there is a column labeled “autoload” which generally tells WordPress: does this setting need to be loaded on every page by default? If the answer is “yes” for some of these extremely lengthy settings, that’s extra data and bytes that WordPress has to load on your pages. Too much content set to “autoload” will lead to high Time to First Byte, and slow query performance in general.

    I ran report on the zasstore site, specifically regarding Autoloaded Data, and here are the findings. The maximum recommended number in bytes of autoloaded is 800,000 and of course, the lower the better. It seems your site is using 3,364,056 bytes, which is very high and unstable. Here is a break down of the top 20 options that load on every single page load and how many bytes they use up.

    +


    +


    +

    | LENGTH(option_value) | option_name |

    +


    +


    +

    | 969251 | rewrite_rules |

    | 350261 | wpseo_taxonomy_meta |

    | 219081 | _transient_wc_attribute_taxonomies |

    | 146594 | mw_adminimize |

    | 111144 | wp_installer_settings |

    | 108085 | wpseo_titles |

    | 82003 | _transient_fusion_fontawesome_en |

    | 81714 | wpml_translation_services |

    | 48994 | wp_user_roles |

    | 48578 | fusion_options |

    | 44594 | ad_inserter |

    | 44344 | widget_text |

    | 41401 | fusion_options_ar |

    | 39484 | wphb_scripts_collection |

    | 37642 | brainstrom_bundled_products |

    | 35254 | asp_updates |

    | 34508 | avada_theme_options |

    | 34482 | avada_theme_options_ar |

    | 32008 | icl_sitepress_settings |

    | 28941 | _ubermenu_menu_item_styles |

    +


    +


    +

    So it seems the “rewrite_rules”, “wpseo_taxonomy_meta”, “mw_adminimize” and “_transient_wc_attribute_taxonomies” systems seem to want to store too much data. It might be worth reaching out to the developers of those plugins/systems to see if all that data is really necessary to autoload or if there could be a bug in the system that they might be able to fix.

    But once you have that sorted out, just let us know and we can run another report to get a new bytes count. And if the number is under 800,000 and you’re still having performance issues, then we’ll be happy to dig into this deeper.

    I hope this information is clear and helpful. Please don’t hesitate to let me know if you have any questions or concerns about what I have said. We’ll be very happy to help you.

    Kind regards,

    Albert A. | Technical Support Specialist

    }

    I want the solution please, Solve the issue of slow my site please..

    thank you..

  • Mahmoud
    • WPMU DEV Initiate

    HI,

    Believe me I do not mean any insult, but I have passed on more than 5 hosting companies, and other service providers, and the authors of about 100 Plugin and Script, of which their program is worth only $ 15, but I did not find this bad and slow and lack of appreciation in support like you!!

    Thank you,,

  • Rupok
    • Support Ninja

    Hi Mahmoud,

    So sorry for the delay. Our forums section was going through scheduled maintenance so the forum was down for a couple of hours. However, the maintenance is done, so all good now. There should not be any more delays from our end. I hope you understand.

    Now, regarding the autoload data which WPEngine Support mentioned, what they said is an important point. To reduce autoload size, please check this blog article: https://presspickle.com/blog/tips-and-tricks/how-to-remove-autoloaded-data

    This article describes nicely what autoload data is and how those can be reduced. Please check that article and follow the instructions mentioned there. I believe that will help. If you find any of our plugin doing this, please let us know so we can forward this to our developers.

    And don’t forget to create a complete backup of your website files and database before doing any modification to your database.

    I believe this will help. Please let us know the result. I’m looking forward to hearing from you and resolving this issue as soon as possible.

    Regards,
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.