My site jumps down to a section with iframe codes

Hi,

When you go to my website the page jumps down to a section with iframe codes, how do I stop this from doing it?

Regards

Richard

  • Sajid

    Hi Richard,
    Hope you are doing good today :slight_smile:

    There must be a jQuery/Javascript code that is doing forcing to focus on iframe that is not part of any Upfront module.

    Could you please grant support staff access so I can take a closer look. To grant access go to WPMU DEV -> Support -> Support Access -> Grant Access or see this manual.

    Take care and have a nice day :slight_smile:
    Cheers, Sajid

  • Sajid

    Hi Richard,
    Hope you are doing good today :slight_smile:

    Thanks for granting support staff access but there is issue on your website that is preventing me to login on your website. I am getting a weird remove action hooks and some functions in plain text on admin-ajax.php page as seen in attached screenshot.

    It can be a plugin or script in mu-plugins folder that is generating these characters on the screen. Please disable the plugins and let me know how it goes. Or if you are hesitant to disable all plugins (which is understood) then you can send in the WordPress admin login details via our contact form in following format.

    Subject: "Attn: Sajid Javed"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls
    Select "I have a different question" for your topic (see screenshot) - this and the subject line ensure that it gets assigned to me :slight_smile:
    https://premium.wpmudev.org/contact/

    For other question, please start separate thread so we can assist further. That will help us manage each issue in its own ticket.

    Take care and have a nice day :slight_smile:
    Cheers, Sajid

  • Sajid

    Hi Richard,
    Hope you are doing good today :slight_smile:

    Thanks for granting support staff access. I found the culprit, its jumping because you have the URL with anchor that scroll to that section on load (#wrapper-1461220234857-1134 is the container).

    After replacing this URL:
    http://thewinnersslip.com/results/#wrapper-1461220234857-1134
    With:
    http://thewinnersslip.com/results/

    It stopped jumping to that section. I can understand why you have that anchor at the end. But instead of using an iframe why not you create that element again on home page ?

    Iframes are best when you want to load the content from external websites. When it comes to show the content from existing website then its better to recreate that section on other page.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:
    Kind Regards,
    Sajid

  • Sajid

    Hi Richard,
    Hope you are doing good today :slight_smile:

    For this purpose you use the Global Region of Upfront and feel the power.

    Just create a new region by clicking on Edit (Pencil icon) of existing region, click on Plus (+) icon to create a new region, type the name (make it rememberable as a label so you can find later easily) and check Make this a Global Region (see screenshot).

    Add the content that you want to make them accessible on other pages in this region by drag and drop.

    Save changes and exit. Now go to the page where you want to show that region as well. Follow the same steps to create a new region but instead of creating new select the region we created first from dropdown (see screenshot).

    You can load this region on other pages of your site as well. When you will make change on page it will reflect on other pages as well where this global region is being used.

    You can also manage the global regions from Upfront -> Theme Settings -> Edit Global Regions (see screenshot).

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Kind Regards,
    Sajid