My sites cannot update upgrades

I still have time left on my subscription.

I regularly update the plugins on the site and all non WPMU ones have updated without issue.

However, WPMU is saying download forbidden. Do you have a problem?

Eg for wheresmylunch.co.uk with coursepress…

Downloading update from https://premium.wpmudev.org/wdp-un.php?action=download&key=2e7ab4c8694919c37e914a8cd4defa22eae04de8&pid=913071…

Download failed. Forbidden

This is on all 4 of my sites spanning several servers for all WPMU plugins.

Please advise ASAP.

Thanks

Simon

  • Ivan
    • HummingBird

    Hello there Simon, I hope you’re well today!

    Are you able to to download plugins directly from our site?

    If you can download from the site, it is most probably problem with your api key.

    You can go to the to the WPMU Dev Dashboard > Manage > and click edit next to your API code. That will log you out and you will need to log in again and obtain new API key.

    Or perhaps your host in blocking access to external services somehow.

    Please let me know i f the above doesn’t help you.

    Thanks,

    Ivan

  • Ivan
    • HummingBird

    Hey Simon,

    Hope you are well today.

    I checked in our system, and seems like you have access until 8th of December.

    I am sorry I am repeating myself, but if you go to a plugin page, for example this one(please check the attached screenshot). Are you able to download the plugin manually?

    Many thanks,

    Ivan

  • Simon
    • Flash Drive

    Hi,

    I can confirm that I can download directly from your website as per email above.

    Back to the WordPress site – I followed your instructions and clicked ewdit next to the API code. This then forced me to login again.

    Unfortunately, I cannot do this and I got the error code

    DEV: “403 Forbidden” Please try again.

    If this problem continues, please contact your host and ask:

    “Is php on my server properly configured to be able to contact https://premium.wpmudev.org/wdp-un.php with a GET HTTP request via fsockopen or CURL?”

    I have also checked that PHP5-CURL is installed on the server, and restarted the server. Made no difference. Appears to be a connection issue between our servers. Any suggestions? Permissions (can you confirm what permissions and owners you recommend for the plugins directory).

    Although I have never needed to do this in the past, do I need to open up access to remote access to SQL from your servers? My guess is no but thought I would ask.

    Please advise ASAP.

    Regards

    Simon

  • Ivan
    • HummingBird

    Hey Simon,

    Hope you are well today.

    I asked to check if you can download the the plugins directly from our site, because this will tell for sure if there is problem with the membership. It seems no.

    Make sure you don’t have any auto-installers and security plugins active on those sites. And the file and folder permissions are correct. Then try again.

    If the above doesn’t help, there is two more options left here.

    1st. There is something wrong with your server.

    2nd Our CloudFlare is blocking your ip for whatever reason.

    Can you please give me your IP address, so I could check with our sysadmins if it was blocked?

    I think it might be this one – “144.76.1**.***”, but if I am wrong please send the real one.

    If you are not comfortable posting it here, you can send an email using our secure contact form on https://premium.wpmudev.org/contact/

    – Select “I have a different question” from the dropdown

    – On the subject enter “Attn: Ivan Denkov”.

    – Include the URL of this post in your message so that I may track this issue

    – Include a link to your website

    – Include you IP address

    Thanks,

    Ivan

  • Simon
    • Flash Drive

    Interestingly I posted a reply to this yesterday..

    So- I can download from site but not through my wordpress WPMU dashboard plugin. All non WPMU plugins update with no issues so I do not believe that this is now a permissions issue in the plugins directory.

    I have also tried turning everything but the WPMU dashboard off just in case of plugin conflict. No joy. Still getting an error

    DEV: “403 Forbidden” Please try again.

    If this problem continues, please contact your host and ask:

    “Is php on my server properly configured to be able to contact https://premium.wpmudev.org/wdp-un.php with a GET HTTP request via fsockopen or CURL?”

    When I try to login.

    I can confirm that Curl is running and that as I am getting other updates this is not an issue with my server (although if you have a script to check firewall to your IP I can check).

    Whats next please. I need to urgently fix this. If not, probably will not renew.

    S

  • Simon
    • Flash Drive

    Please see your thread https://premium.wpmudev.org/forums/topic/my-wpmudev-dashboard-will-not-update-plugins

    It appears that the issue is at your end. One of your techs has identified that this happens to several installations and appears to be an over zealous firewall.

    Solution was to add my IP address to your whitelist on your firewall.

    Now – can you get this sorted as a matter of urgency. I have a site to build tomorrow and I need access ASAP.

  • Ivan
    • HummingBird

    Hey Simon,

    Hope you are well and sorry for the inconvenience.

    Can you please send your IP, either post it here, or if you are not comfortable you can send it trough our contact form at https://premium.wpmudev.org/contact/

    – Select “I have a different question” from the dropdown

    – On the subject enter “Attn: Ivan Denkov”.

    – Include the URL of this post in your message so that I may track this issue

    – Include a link to your website

    – Include you IP address

    Thanks,

    Ivan

  • Ivan
    • HummingBird

    Hey Simon,

    I just noticed you responded trough our contact form, but it wasn’t included my name so I didn’t receive it.

    I will check that IP with our sysadmins and will let you know ASAP.

    Meanwhile can you try turning off wordfence and other security plugins?

    Thanks,

    Ivan

  • Simon
    • Flash Drive

    Hi Ivan,

    The inclusion onto the whitelist has worked. I wonder if it is because I run several WP installs from this server and I tend to update them all together. What your server would see is a lot of updates coming from one IP address, and may consider itself to be under attack.

    Re Poodle – really getting fedup with SSL and vulnerabiliities. I have disabled SSL3 now on the server so server is no longer vulnerable.

    As an improvement, I wonder if troubleshooting should check the blocked IP range first off???

    We got there in the end.

    Regards

    Simon

  • Ivan
    • HummingBird

    Hey Simon,

    Glad it is working now.

    I think this is in CloudFlare and sometimes few addresses from a range, get infected with some spam bots, and that may result in the whole range to be blocked and/or blacklisted.

    For example if you have 5 IP spaming from the range 192.168.1.1 – 192.168.1.255 it might decide to ban the whole pool.

    We usually asking for our members to check for or auto-installers, get new API key and server configuration, because most often that’s are the reasons to be unable to connect. Blocked IP happens pretty rare, but still happens like in your case.

    Have a great weekend,

    Ivan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.