"My Sites" links for editing the other sites fail (The webpage has a redirect loop.)

1- the "My Sites" link on the upper left portion beside the Wp-logo, fails except for the main site. When I click on them, the page will display: The webpage has a redirect loop.

2- Also, how do I add links to that portion ("My Sites") on the upper left part. I created a new site but it did not show up there. Is there anything that I need to do before I see the links for that site there?

  • PC
    • WPMU DEV Initiate

    Hello there Richi,

    Thanks for posting on the forums.

    the "My Sites" link on the upper left portion beside the Wp-logo, fails except for the main site. When I click on them, the page will display: The webpage has a redirect loop.

    Can you kindly update the WordPress version on your site ? You are using 3.6.1. Please update it to 3.9.1 and that should fix it.

    2- Also, how do I add links to that portion ("My Sites") on the upper left part. I created a new site but it did not show up there. Is there anything that I need to do before I see the links for that site there?

    That is populated automatically. If you create a new site and use your network admin email address, only then it will be added to that list. Otherwise you can also go to Mysites Dashboard menu and click on all sites to view all the sites on your network.

    I hope that helps. Please feel free to ask if you have more questions on the same.

    Cheers, PC

  • aristath
    • Recruit

    Hello again @richi,

    It sounds to me like a .htaccess error.
    Can you please make sure that you've properly set-upo your htaccess rules?
    You can get the ones you're supposed to use by going from your dashboard to Network Admin => Settings => Network Setup.

    Cheers,
    Ari.

  • richi
    • New Recruit

    Hi Aristath,

    I also found out https://premium.wpmudev.org/forums/topic/multi-site-cant-access-dashboards-or-new-sites
    how to get to that setting because it does not show upon normal circumstance in my dashboard.
    Instead of just appending the necessary code, what I did was to remove all the contents of htaccess and added the code stated in the location of the setting I am now directed to the wp-login of that page.
    So currently, I no longer get the redirect but instead goes to the wp log-in page of the subsite, is this correct or should I be directed right away to the site if my user is a Super Admin?

  • PC
    • WPMU DEV Initiate

    Hello there richi,

    Thanks for posting back.

    how to get to that setting because it does not show upon normal circumstance in my dashboard.

    You can put define( 'WP_ALLOW_MULTISITE', true ); in your wp-config.php

    Open up wp-config.php and add this line above where it says /* That's all, stop editing! Happy blogging. */.

    Then you should be able to see those options in the network admin under Tools >> Network Setup.

    Please advise if that works ?

    Cheers, PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.