My subdirectory install multisite dont work

Hey!

Im not sure why, but I cant create sites on my multisite installation. First I installed in subdomains, but I changed it to subdirectory instead. I cant visit the site that I created, not sure why. I appreciate if you could check whats wrong :slight_smile: Could also let you into FTP it you have to!

Great regards,
Marcus

  • MarcuSM

    Here is my config

    <?php
    /**
     * The base configurations of the WordPress.
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, and ABSPATH. You can find more information by visiting
     * {@link https://codex.wordpress.org/Editing_wp-config.php Editing wp-config.php}
     * Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation. You don't have to use the web site, you can just copy this file
     * to "wp-config.php" and fill in the values.
     *
     * @package WordPress
     */
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         '6{!3v<4bud+B}85-6pR+>QtLer;*N~;e8D5wdnf1z@KSkkJ{Kr@6M.LLcwI)NoPP');
    define('SECURE_AUTH_KEY',  'wFMPm~H6suA3@!O7o5,<4x3$We_XBUbF-(h ,:KoR+4|2dmJP43B+~@51(g, -w8');
    define('LOGGED_IN_KEY',    'SRl0PAKYSbg#Ck-PvlsO7K_9bR2x{di${MKosdIEA+kqvbP_Zv(o-Z,2[OoPI,p7');
    define('NONCE_KEY',        'R#<LN-LPVXS.ats?MGS[>:Wd&YkcWz1f/61#<Q^Q{w9/)xj%F+u_)fHk1HFL$?oH');
    define('AUTH_SALT',        'RoQ+Zs->VXzT+Pxi%gy7}, f$,)(6C1[KV>O+!{5BDrTHT%VJ81s4D#A;8<$jCQR');
    define('SECURE_AUTH_SALT', 'Nr3}&#bTN62(epH%+-[%8@9YhzUi)HqO!5]-}X0Z7s~^gD+AzYw4d5GJ@<H

    Q~QW');
    define('LOGGED_IN_SALT', 'BTT ,x&5OKD#IV/Dm!dyk2%O+9#$Rv.|&%lQG&5k@=|,!F-:M)}G8$d)DUo!{3|.');
    define('NONCE_SALT', '}yZg:<Jn%MhG!ct8B8z|ovSXQ&.p#i-%$vg)6P%^[k}s(C.U2.SqX|_#STvqeiPf');

    /**#@-*/

    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each a unique
    * prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = 'wp_mb543';

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define('WP_DEBUG', false);

    /* That's all, stop editing! Happy blogging. */
    /* Multisite */
    define( 'WP_ALLOW_MULTISITE', true );
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'marbergs.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Here is my htaccess, if there is anything wrong here.

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    `

    tnx

  • Predrag Dubajic

    Hey @MarcuSM,

    Hope you're doing well today :slight_smile:

    Make sure that you don't post any sensitive data when posting wp-config content, I had to remove your database username and password from above comment.

    I have tried creating new site on your network and can only see blank screen, there is probably an error there that is visible when you enable wp_debug in your wp-config.php

    Can you try enabling debug and tell me if error shows up when you open your sub-site?

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.