My webserver has

My webserver has an PHP 7 and 7.1 is now available!
I would like to know the compatibility of my site

  • Adam Czajczyk

    Hi Sudarshan

    I hope you're well today and thank you for your question!

    I'll state it short :slight_smile: As long as your WP is up to date and all the plugins are up to date, you should be fine. I can already tell that if you use a plugin like PHP Compatibility Checker, it will most likely report some issues that might look serious. However, this is in 99.9% of cases a false alarm because it reports pieces of code in the plugins/themes that are there actually for compatibility (with older PHP versions) reasons and is not able to recognize whether it's an entirely incompatible code or a dedicated part of the code kept there for compatibility.

    The bottom line is: don't hesitate, if you got newer one available, you can go for it to. If there's anything happening after the switch, you might need to contact theme/plugin developers but everything should be compatible.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.