Strange- no products showing up!

I went to visit my site today (artistsalley.net) and it wouldn't show up- there was an error message that referred to the Membership plugin.
Message:
Warning: require_once(/home/dspinner/public_html/wp-content/plugins/membership/lib/wpmu-lib/core.php): failed to open stream: No such file or directory in /home/dspinner/public_html/wp-content/plugins/membership/membership2.php on line 105

Fatal error: require_once(): Failed opening required '/home/dspinner/public_html/wp-content/plugins/membership/lib/wpmu-lib/core.php' (include_path='/home/dspinner/public_html/wp-content/plugins/wpmu-dev-plusone/lib/external/google:.:disappointed:usr/lib/php:disappointed:usr/local/lib/php') in /home/dspinner/public_html/wp-content/plugins/membership/membership2.php on line 105

I called godaddy and they disabled that plugin for me, so then I could see my site- BUT everything is wonky. No products show up, and if I visit one of the sites, their products are there but the prices are missing, etc.

If I go into one of the sites, and then click on an item, the price shows up but that's all. Here's the error message:

Fatal error: Error! MarketPress doesn't have a get_cart_contents method. in /home/dspinner/public_html/wp-content/plugins/marketpress/marketpress.php on line 906

Nothing shows up on the main page (it's supposed to have a random display of products).
I can't even search on a product.
When I go into one of the sub-site's dashboards, I get this error: Warning: in_array() expects parameter 2 to be array, null given in /home/dspinner/public_html/wp-content/plugins/ultimate-branding/ultimate-branding-files/modules/custom-admin-bar-files/inc/UB_Admin_Bar.php on line 612

I went onto each sub site and updated the network (there was a message to do this).