Name and Telephone Only, But Still Need Email Confirmation To Service Provider

Hi,

I only need my customer's name and telephone number (email isn't so important).

The appointment works OK, but no confirmation emails are (apparently) sent to the Service Provider if the client does not enter an email address.

Please can you suggest a way for me to still send a confirmation email to the Service Provider?

  • Jack Kitterhing
    • Code Norris

    Hi there @Dan

    I hope you are well today and thank you for your question.

    The service provider should be getting emails even if the client hasn't used an email address. Can you verify that emails are being sent, if an email is entered please?

    This will help us narrow down if this is an overall email issue or just in that specific case.

    Thank you!

    Kind Regards
    Jack.

  • Dan
    • Flash Drive

    Thanks for the fast answer.

    Yes, emails are sent if I request a customer email address.

    If there is no email address, emails do not get sent.

    I only change the checkbox for the "required" email field in Appointments+ Settings.

  • Jack Kitterhing
    • Code Norris

    Hi there @Dan

    Thanks for the additional information.

    I have just tested this and can indeed verify that no emails are sent to the service provider if the email is not required.

    I believe that this may be design, but I'm going to flag the lead developer on this to get some clarification and we'll see if we can come up with a work around for you :slight_smile:

    Thank you!

    Kind Regards
    Jack.

  • Vladislav
    • Dead Eye Dev

    Hello,

    Just to make sure we're looking at the same thing, there are a couple of implied rules that go along with notification emails sending (confirmation emails won't be sent to your users with no emails provided). A duplicated email won't be sent if your service provider is also an admin. Also, the "Allow service provider confirm own appointments" setting must be set to "Yes" to allow sending confirmation emails to your service providers on appointment creation.

  • Dan
    • Flash Drive

    Thanks....smart questions,but the problem remains.

    My SP is not an admin (although they are a dummy if that makes a difference)...I need the dummy functionality

    Allow SP To Confirm is set to Yes

    ...and just t be clear, Send Confirmation Email is set to Yes

    I checked the appointment in the list of appointments (it exists OK) and tried to "resend confirmation email", and that fails. Obviously there is no client email for that appointment.

    Any other thoughts?

  • pxwm
    • WP Core Meltdown

    Hi @Dan,

    Could you please confirm if the user is able to make an appointment without entering an email address in the appointment form, whether this be a valid email address or not.

    I ask because on my demo site it will not allow me to submit an appointment unless the 'Your email' field is filled in and I'm sure this is a mandatory field.

    Also you mention the SP is a 'dummy'.
    Are you referring to the fact that you have clicked the 'dummy' field check box in the A+ 'Service Providers' tab.

    If you have then have you assigned the 'dummy' SP to a 'real' SP in the A+ 'General' tab 'Assign dummy service providers to' field?

    If you have then all appointments made for the 'dummy' SP will be sent to the 'real' SP if the relevant settings are made in the A+ 'General' tab.

    If you have 'Auto Confirm' set to 'Yes' then the SP should receive a notification email based on the above.

    Regards
    SteveB

  • Dan
    • Flash Drive

    Thanks Steve (again :slight_smile: ),

    The user can make an appointment without an email address. You can choose the mandatory fields in Appointments+ Settings. The appointment gets created OK (I can see it in the list of appointments).

    ...and yes, by "dummy", I mean that I clicked that checkbox. I also assigned the dummy user in settings to a real user.

    Everything works fine if I have the mandatory email field......and the emails stop if I remove the users email field even though the appointment gets created OK.

  • pxwm
    • WP Core Meltdown

    Hi @Dan,

    Many thanks for the update and based on your feedback I'm assuming you have not checked the 'Email' field in the A+ 'General' tab 'Require these from the client:' field

    Therefore your appointment form doesn't show the 'Your email' field.

    Is that correct?

    If so I'll make some tests to confirm the results

    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi Dan,

    My results:

    I unchecked the 'Your email' field
    I left the 'Auto Confirm' set to 'Yes'
    I then tested using a browser in 'private browsing' as it was skewing my results as it seemed to be remembering my email address when I submitted the appointment form even though the 'Your email' field was not visible.

    I didn't receive a notification to either the SP or admin

    I then changed the settings to:
    'Auto Confirm' set to 'No'
    'Allow service provider confirm own appointments' to 'Yes'
    This worked fine but obviously it didn't automatically confirm the appointment

    I then changed the settings to:
    'Auto Confirm' set to 'Yes'
    and left 'Allow service provider confirm own appointments' to 'Yes'
    This worked fine

    If you want the appointment to be automatically confirmed could you try changing the settings to:
    'Auto Confirm' set to 'Yes'
    and left 'Allow service provider confirm own appointments' to 'Yes'

    Then make some test appointments.
    If this works you may or may not get two emails for admin and the SP

    Please let me know the results
    Regards
    SteveB

  • Dan
    • Flash Drive

    Steve,

    I found something. If I don't clear the browser cache after a successful send (with email), the customer email field is retained and the email gets sent. The confirmation field includes the customer email address, even though the new form does not have the customer email field.

    Please will you repeat your test and clear your browser cache after each test?

  • pxwm
    • WP Core Meltdown

    Hi @dan,

    Many thanks for the feedback.
    I experienced the same problem when testing as per my previous post and to bypass this problem I used a browser I had not used before and set to 'private browsing' as this doesn't cache the data. I also closed the browser each time I made an appointment so it cleared the cache.

    Just want to check if you have managed to carry out further tests as per my last post to confirm if you obtained the same results as I did or whether we need to consider other options?

    Regards
    SteveB

  • Dan
    • Flash Drive

    I see it now...... :slight_smile:

    These are my results.. with InPrivate Browsing....

    *****************************************
    First two tests without client email field...

    AutoConfirm = No
    Allow SP to confirm = Yes

    Result = failed, no email

    **********************

    AutoConfirm = Yes
    Allow SP to confirm = Yes

    Result = failed, no email

    *********************

    **************************************************************************
    ...and now with client email required for the next two tests.....

    AutoConfirm = No
    Allow SP to confirm = Yes

    Result = failed, no email

    *********************

    AutoConfirm = Yes
    Allow SP to confirm = Yes

    Result = success, email sent to SP and Admin

    *********************

    Again, I really appreciate help Steve. This is great support. Are you part of the official setup or do you do this for fun? :slight_smile:

  • pxwm
    • WP Core Meltdown

    Hi @Dan

    Just an active member with an aim to help out other fellow members

    Many thanks for your feedback.

    I've carried out some further testing and I think I have found a solution for you.

    Would you please try the following and test:-

    This is without client 'Your email' field set to visible - as per your requirement
    Then set all the following in the A+ 'General' tab
    'Auto confirm' to 'No'
    'Allow service provider confirm own appointments' to 'Yes'
    'Send Notification to admin if confirmation is required' to 'Yes' this is the important one as this seems to then allow emails to be sent to the SP and to Admin.

    However with these settings it does mean you will have to confirm each appointment for the appointment to be 'active'
    You would find the appointment in the A+ appointments 'pending appointments' tab

    I've checked and this worked for me.

    Please Note: With the 'Your email' field not checked/visible and the following settings then no email is sent:-

    'Auto confirm' set to 'Yes' no email sent
    'Send Notification to admin if confirmation is required' to 'No' no email sent to SP or Admin

    Please let me know if this works for you.

    Regards
    SteveB

  • Dan
    • Flash Drive

    Well....

    It "works" in that admin receives a notification email stating that an appointment requires confirmation. However the SP does not receive an email....and that's what I need.

    I need this to be automatic....potentially hundreds of appointments for multiple SPs.

    It seems a little strange that the system can't send an email to an SP without a client's email address.

    Hmmmmmm

  • pxwm
    • WP Core Meltdown

    Hi @Dan,

    I've rechecked and I definitely receive an email notification to the SP.

    Though I do appreciate this doesn't help you if you want the appointments to be 'auto-confirmed.

    Perhaps @Jack Kitterhing (wpmu staff) who is in the thread could flag to Vladislav the developer to make him aware that there appears to be an anomaly in the coding that when:-

    the 'Your email' field is not set
    'Auto-confirm' is set to 'Yes'
    'Send Confirmation email' is set to 'Yes'

    then the SP and Admin do not receive a confirmation email and the only way they can receive an email is if the following are set:-

    'Auto confirm' to 'No'
    'Allow service provider confirm own appointments' to 'Yes'
    'Send Notification to admin if confirmation is required' to 'Yes' this is the important one as this seems to then allow emails to be sent to the SP and to Admin.

    Hi @Jack Kitterhing - is it possible you could please progress with Vladislav so he can confirm if our findings are correct.

    To confirm I've never experienced this problem because I have always had the 'Your email' field activated.

    Regards
    SteveB

  • Jack Kitterhing
    • Code Norris

    Hi there @Dan and @pxwm (Steve).

    Thanks for all your assistance on this SteveB it's greatly appreciated.

    Ve (Vladislav), is aware of this and is looking into getting this working as I have also confirmed currently without the email field it isn't working currently,

    Thank you for your patience on this issue.

    Thank you both for being WPMU DEV members and have a great weekend!

    Kind Regards
    Jack.

  • Dan
    • Flash Drive

    Hi @Jack Kitterhing, and @Vladislav

    I was just wondering if there has been any progress?

    It would be very helpful to have this fixed. Is it something that is likely to be a quick(ish) fix, or is it likely to take a month or two?

    That will help my planning and possible workarounds.

    I appreciate your help, and thank you for your work.

  • Jack Kitterhing
    • Code Norris

    Hi there @Dan

    I hope you are well today, sorry for the delay on this.

    I'm afraid I also still can't get the email sent to the service provider, Ve (Vladislav), had a major power cut this weekend and has only just got back online today, I'll send him over a message now.

    Thank you for your continued patience.

    Kind Regards
    Jack.

  • Jack Kitterhing
    • Code Norris

    Hi there @Dan

    I hope you are well today and I'd like to apologize about the extreme delay on this.

    I spoke with Ve earlier this afternoon and he is working on the issue, and hoping to resolve it as quick as possible, though I didn't get a ETA, But I'm hopeful we're talking days :slight_smile:

    Thank you!

    Kind Regards
    Jack.

  • Jack Kitterhing
    • Code Norris

    Hi there @Dan,

    I hope you are well today, sorry for the delay with my reply.

    I have just spoken with Ve, and he's working on a fix that will come in V1.3 though we don't have an ETA at this time. As there is a bit left to do on it, then we'll test it internally and then if all goes well it'll be pushed out.

    Sorry for the delay.

    Thank you!

    Kind Regards
    Jack.

  • Dan
    • Flash Drive

    Any progress?...or even a release date for v1.3?

    I was recently billed for monthly payment. I understand the system, but it feels a bit strange to pay to wait. I don't want to keep paying every month if there is no progress.

  • Dan
    • Flash Drive

    Thanks Jack....got it.

    Do you know how I can update this plugin in a MultiSite installation?

    ...without losing any of my previous Appointments+ information/settings?

    I checked the installation manual but couldn't see the answer.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.