[Namo Theme] Issue with theme options

Hi, I hope that you are well. I have a wordpress installation running a theme called Namo. When I try and access the "Theme Options" I get a blank page. I have no idea how to fix it, whether it is a file size issue or a php issue. If you have any advice or a way to find out why it is not working, i would be very appreciative. Thank you Mark

  • Kris Tomczyk

    Hi Mark

    Hope you are doing good today.

    This issue could be a plugin conflict. Would you please run a conflict test? Please deactivate all plugins and check if the problem gone. If so, then enable all plugins one by one and find which one is having conflict.

    If this won't help can you add this code to your wp-config.php file:

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    also delete
    define('WP_DEBUG', false);

    The line should be placed above the "/* That's all, stop editing! Happy blogging. */"

    Then go to your "Theme Options" again and generate blank page.

    This will generate in the /wp-content/ folder a debug.log file. Thanks to this file we will understand what is causing the error. Please upload this file to google drive or dropbox and share a link here.

    Kind Regards,
    Kris

  • Mark

    Hi, Thank you for your advice. I did as you suggested and downloaded a Debug log file which I put on my google drive. Here is the link:
    I have the same issue with both
    http://www.agondawhitesand.com and http://www.agondacottages.com, I have granted you access through the dashboard. I can provide you with the c-panel login details if you wish. I would really appreciate if you could let me know how to fix it so that I can do it in the future as I often use this theme. Thank you.

  • Kris Tomczyk

    Hi Mark

    At first can you tell me did you make above plugin conflict? This will exclude any plugin conflict.

    If you're not able to do this on a live site, can you create a staging site and perform this test?

    From your debug you share here it is look like an issue with php version on your site.
    Over 1year ago one of the users "tinileb" on this Namo support page got exactly the same issue:
    https://themeforest.net/comments/15787358
    Author suggest there that this could be php version issue.

    I recommend to follow those steps:
    1. create a staging site (a copy of your site)
    2. preform plugin conflict test:
    - deactivate all plugins and check if the problem gone. If so, then enable all plugins one by one and find which one is having conflict.
    3. if plugin conflict test will give no positive results, please try via cPanel change php version (Note!: only for this staging site)

    If plugin conflict test and change the php version will give no positive results you will need to contact with Namo theme author and clarify this issue. As this is a third party paid software, I'm afraid, we don't know their coding and architecture and can't confirm why this is behaving such :slight_frown:

    Hope this guide you to right path of solving this issue.

    Kind Regards,
    Kris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.