NBT errors after upgrading to v1.9

Hello all,

I just upgraded NBT to the latest v1.9 on a WordPress 3.6 multisite and I keep getting the following errors under /wp-admin/network/error_log:

WordPress database error Table 'mydatabase_basic.wp_nbt_templates_categories' doesn't exist for query SELECT rel.cat_id ID, cat.name, cat.description, cat.is_default
FROM  <code>wp_nbt_templates_categories</code> cat
INNER JOIN wp_nbt_categories_relationships_table rel ON rel.cat_id = cat.ID
WHERE rel.template_id = 1 made by require_once('wp-admin/admin.php'), do_action('toplevel_page_blog_templates_main'), call_user_func_array, blog_templates_main_menu->admin_options_page, NBT_Templates_Table->prepare_items, blog_templates_model->get_template_categories

I do not even have to save the template. All I have to do is go and have a look at it's settings and there comes the error !!!!!
Any ideas why?
Thanks

PS: I attach a screenshot of my NBT settings