Need help, can someone log into my dashboard?

I have been trying to figure this out for ever.
I was able to create
3 Providers (3 rooms) and each provider has a service (room rental interval) that is 4 hrs
you can see what i did here:

But it doesnt matter what I do, for it to work I have to first click on the time then click again on the Provider (show available time) its a bit confusing, especially when I have to a 4 more rooms.
Is there a way to do it so I only have the service button at the top and that is works?
NOTE: I tried taking out the shortcode for providers, it does not work, because the times available only appear if I click both.

Can you please tell me how I can give you access to my Dashboard so you can take a look/

Thank you


  • Sajid

    Hello Azu,
    Hope you are doing good today :slight_smile:

    I am sorry but this is not possible out of the box. User must select both, service provider and service in order to display the available time.

    However, I am flagging second level support staff (developer) for their invaluable feedback on this matter. If it could be done easily then we will try our best to come up with a code based solution. But please note that, developer's staff response might be slower than normal support staff here so please be patient.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

  • Azu

    Hi Sajid

    Thank you so much for your help, if anyone can help me with this that would be amazing. Amother member was trying to help me and she has it in her site that only the services has to be selected and then you can pick a date and all the times appear, but the only thing she did was remove the provider shortcode, that did not work for me :slight_frown:

    You guys can see how she has it in the link below for comparison. The intervals of time are not the same in mine. I only need 3 time slots of 4 hours each with 30 min rest after each one. They are all done by the same provider.

    here is the link of how the girl that was trying to help me has it if you want to compare.

    Thank you again for any help you can give me, I hope you have a fantastic day


    If you need

  • Azu

    I got it back to working with visitor having to press the services and provider button.

    But as I said, th egilr the was helping me has only the service button in her site and it is working for her. She told me she only removed the [app_my_appointments] and [app_service_providers] from short codes, but when i do that it does not work.

    I will wait for help on this, on the mean time I will use it as it. Thank you

  • Sajid

    Hello Azu,
    Hope you are doing good today :slight_smile:

    I am sorry for delay and confusion going on here. In your last thread, you mentioned that you have different interval for each of your appointment.

    But right now, I saw that you have 4 hours of appointment duration with 30 minutes gap between each of those.

    This is some thing we can easily handle with Appointments + plugin. Without complexly messing with providers and services.

    I created a an exact schedule on my own test site and it worked for me. Here are the steps to setup it up.

    1. Delete all services, schedule and providers (important).

    2. Now create a service called West Room.

    3. Select its duration 240 mins (4 hours).

    4. Go to Appointments -> Settings -> Working Hours and set the working hours from 8:30 am to 9:30 pm.

    5. Now go to Appointments -> Settings -> Add-ons and activate Paddings addon (to cover the thiry minutes gap).

    6. No go to Appointments -> Settings -> Services and click on more info, select 30 minutes for after dropdown and save settings (see screenshot).

    7. Done!

    No go to appointments page and you should get similar to below screen (you don't need to select provider in order to display the time slots).

    This means that, first service will start from 8:30 am and ends on 12:30 pm. Then there will be 30 minutes gap and next will start from 1pm and ends on 5pm. Again there will be 30 minutes gap and last one will start from 5:30 and ends on 9:30 pm. Perfect!

    Hope that helps! Feel free to post a reply if you need further assistance and enable support staff access so I could set it up for you.

    To grant access go to Dashboard -> WPMU DEV -> Support -> Support Access -> Grant Support Access or see this manual for more details regarding how to enable support staff access.

    Best Regards,
    Sajid - WPMU DEV Support

  • Lindeni Mahlalela

    Hello Azu,

    I hope you are doing great today. I have noticed that it has been a long time since my colleague Sajid some suggestions for you to try and was wondering if you had the change to try those suggestions.

    Did you manage to try what Sajid recommended? If yes, did it work well for you or you? Please let us know if you still need help with this issue or not. We will be always happy to get this resolved and to help you in any way possible.

    If you still need help, please enable Support Access to your dashboard so that I can have a closer look at your configuration and try to find a solution for you. You can enable staff access by following this guide

    I hope you enjoy the rest of your day.