Need help. Unfiltered HTML not being permitted even though user has proper status.

Hi,

I'm incredibly frustrated and would greatly appreciate some help. I have pro sites plugin installed and I've enabled my upgraded users to have access to unfiltered HTML. However, a user who I manually extended to an upgraded status still cannot use unfiltered HTML and is receiving a message that unfiltered HTML is not permitted.

Any ideas why and how to fix this?

  • aecnu

    Greetings jruytenbeek,

    Upgrade teasers such as "Upgrade to (level 2) for X more space" still show to users who have been manually extended.

    Any thoughts on that?

    Thank you for giving this additional information - it certainly helps as additional symptom of probably the same issue.

    I must admit I cannot reproduce either of these issues on my production server so it makes it a much harder to pin down the possible issue causing this.

    We could go through the standard troubleshooting technique of disabling all the plugins etc. to see if this resolves the issue to include checking all the versions of what is running that they are current.

    However, we could possibly get to the bottom of this much quicker if you would please send the log in information and URL to me aecnu (at) incsub.com so that I may check out what we got going on in there. Also please include the user in question that was upgraded so I may check that out as well.

    Please advise.

    Cheers, Joe

  • aecnu

    Greetings jruytenbeek,

    Thank you for allowing me to take a peak into your sites admin area. I did not make any changes and of course I started going through the settings.

    By viewing the level settings I noticed that your concept of how the level hierarchy works is in reverse of the reality. It is an easy mistake to make but once we have it as it should be, I think that you will be well on your way to having things work as you expect, at least in this case and dealing with levels.

    To explain the levels a little more for a thorough understanding, the levels are as follows starting at free if enabled and each addition higher the the previous level:

    Free --> lowest level
    Level 1
    Level 2
    Level 3
    Level 4 --> highest level

    In the above example level 4 is the highest level.

    In your sites specific case level 1 is interpreted as higher then level 2. This should be reversed to work properly.

    Please adjust accordingly and we can go forward checking to see if you still have any issues relating to this ticket.

    Please advise.

    Cheers, Joe

  • aecnu

    Greetings jruytenbeek,

    Just checking if this issue was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thank you for being a WPMU Dev member!

    Cheers, Joe