Need help with multisite setup.

I have followed the instructions on how to enable multisite? but I am not sure it's actually done. and I am unable to create new site download plugins for multisite.

  • Ash

    Hello jonathan edwards

    I have tried to login at your site but looks like support access doesn't work. I have also connected in your FTP but I didn't see any website directory. Looks like the FTP points to the root user directory, not the www directory.

    Would you please send me your admin login and FTP details (make sure it points to correct directory)?

    You can send me privately in the following format:
    1. Please go to https://premium.wpmudev.org/contact/#i-have-a-different-question
    2. Select "I have a different question" if not selected
    3. In subject line put "Attn-Ash" (this will ensure that the email is assigned to me)
    4. Provide the wanted details.
    5. Add the thread link in the message so that I can track.

    Have a nice day!

    Cheers,
    Ash

  • jonathan edwards

    Hello all
    Here is a better explanation of the issue with some of the things I have tried.

    Server configuration
    - Linode 2gb with NGINX PHP7 MariaDB and nginx pagespeed running centos7.
    - I have disabled all plugins and reset the database a few times.

    disabled plugins
    I place define( 'WP_ALLOW_MULTISITE', true );
    login and select network setup and select directory structure
    then add from the network setup to the wp-config.php
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'ws1.edwardstechnical.net');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    This is where I get stuck, The only thing that happens is when returning to the network setup I get
    *****Warning: An existing WordPress network was detected.

    I have added and followed along with https://premium.wpmudev.org/blog/wordpress-multisite-wordpress-nginx/ and have modded the nginx file accordingly. adding all of the suggestions
    # WordPress multisite subdirectory rules.
    # Designed to be included in any server {} block.
    index index.php;
    # This order might seem weird - this is attempted to match last if rules below fail.
    # http://wiki.nginx.org/HttpCoreModule
    location / {
    try_files $uri $uri/ /index.php?$args;
    }
    # Add trailing slash to */wp-admin requests.
    rewrite /wp-admin$ $scheme://$host$uri/ permanent;
    # Pass all .php files onto a php-fpm/php-fcgi server.
    location ~ \.php$ {
    # Zero-day exploit defense.
    # http://forum.nginx.org/read.php?2,88845,page=3
    # Won't work properly (404 error) if the file is not stored on this server, which is entirely possible with php-fpm/php-fcgi.
    # Comment the 'try_files' line out if you set up php-fpm/php-fcgi on another machine. And then cross your fingers that you won't get hacked.
    try_files $uri =404;
    # fastcgi_split_path_info ^(.+\.php)(/.+)$;
    #NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini
    include fastcgi_params;
    fastcgi_index index.php;
    # fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    # fastcgi_intercept_errors on;
    fastcgi_pass php5-fpm;
    }
    location ~ ^/files/(.*)$ {
    try_files /wp-content/blogs.dir/$blogid/$uri /wp-includes/ms-files.php?file=$1 ;
    # access_log on; log_not_found on; expires max;
    }
    #avoid php readfile()
    location ^~ /blogs.dir {
    internal;
    alias /var/www/wordpress/wp-content/blogs.dir ;
    access_log off; log_not_found off; expires max;
    }
    # Directives to send expires headers and turn off 404 error logging.
    location ~* ^.+\.(xml|ogg|ogv|svg|svgz|eot|otf|woff|mp4|ttf|css|rss|atom|js|jpg|jpeg|gif|png|ico|zip|tgz|gz|rar|bz2|doc|xls|exe|ppt|tar|mid|midi|wav|bmp|rtf)$ {
    access_log off; log_not_found off; expires max;
    }
    I have looked at my php http://www.config file and found nothing to edit that should effect this.

    This is all the editing I have done in wp-config.php

    /* Multisite */
    define( 'WP_ALLOW_MULTISITE', true );
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'ws1.edwardstechnical.net');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    /* That's all, stop editing! Happy blogging. */

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.