Need help with WPMU to 3.5.1 upgrade

I have a website that was created in WPMU before it was included in version 3. We tried upgrading to 3.5.1 through the back office and we get an error message that says it failed but the files look to have been updated. The server we are on is running in DSO mode, so all updates prompt us to enter FTP credentials which is interfering with our ability to upgrade plugins.

We want to migrate this site over to our other server which is running suPHP and on which other WP sites are doing just fine. Can anyone help us to do the following:

1) Get WP updated without error messages and confirm a clean install (update);
2) Migrate us over to the other server and make sure all plugins are updated and operational.

Anybody able to help? What would you charge to do this?