NEED IMMEDIATE HELP! Preg replace warning Unknown modifier "G"

OMG Huge error all over my site right now and all it took was for me to add a "text change" to my site using Ultimate branding module sitewide text change

I chose to replace "Jabber / Google Talk" with something else and as soon as I did I got the following error everywhere:

Warning: preg_replace() [function.preg-replace]: Unknown modifier 'G' in /home/nakedfr/public_html/wp-content/plugins/ultimate-branding/ultimate-branding-files/modules/site-wide-text-change.php on line 377

I tried using text editor and found line 377 which is this: $transtext = preg_replace( $toprocess, $toreplace, $transtext );

I see no "G" in there that would be throwing this error. The best idea I have is that the text change didn't like me calling the "/" in the Jabber google talk phrase. How do I fix this?! I can't even go to the dashboard module for this plugin to remove this text change.

  • Paul Barthmaier
    • Code Wrangler

    I see. Based on my perceived urgency of your message, I thought it was affecting users, but if it's in your Admin, that's probably better, although it probably doesn't feel that way to you!

    Why don't you FTP in to your site and change the name of the plugin, maybe just add some numbers into the middle of the plugin's folder, which will break the link and deactivate the plugin.

    OK?

    Hope this helps! Let us know how it goes.

    Cheers,
    Paul

    JUST DO IT. ~Famous Nike Ad Slogan.

  • Mike Price
    • The Incredible Code Injector

    WTF..are you kidding me? am I paying $80 a month for support that tells me "hey its not a big deal like you THINK it is" just deactivate the plugin?! I want to use the $#$#$$ plugin so why in the world would I want it deactivated? I could easily just freaking delete the plugin using FTP without having to even edit the name of it for gods sake. I don't want to do that ..i want the Plugin to work because that is what I pay $80 a month for. Now please tell me what in the code i need to change to make YOUR plugin work. thanks

  • Paul Barthmaier
    • Code Wrangler

    Hey Mike,

    This is great! I love that you're just testing me. Did you think I was finished with you? You'll notice that the box below isn't marked as Resolved. My suggestion was to isolate for sure that it was this plugin causing the error. Once that has been established, then we'll look at what to do about it.

    Cheers,
    Paul

    Don't like native styling of Comments Plus? No prob: http://marker.to/YQ7EuI

  • Mike Price
    • The Incredible Code Injector

    Alright I found the bug myself even though im a not a coder. it was indeed line 377 which is this:

    $transtext = preg_replace( $toprocess, $toreplace, $transtext );

    for some reason this function/action doesn't like the fact that im trying to change "Jabber / Google Talk" to something else, in this case "Age"

    However, what I had to do was remove this piece of code which erased the error but also removed my other text changes. Then I removed the jabber text change and re-inserted this into the code : $transtext = preg_replace( $toprocess, $toreplace, $transtext );

    Now its working fine all text changes are back HOWEVER the bug still exists (tried again) that it doesn't allow me to change "Jabber / Google Talk" in the User profile and my guess is that it has to do with the special character "/"

    The bug now would be simply to find a way to allow me to change this without an error. Thanks for your help

  • Paul Barthmaier
    • Code Wrangler

    Mike,

    You may also notice I'm addressing you by your first name, which you haven't used yet in this thread. I'm sure you would consider that to be good customer service, even in the Bay area.

    I love customer service, I love WP, and I especially love WPMU DEV! And for me, when I say WPMU DEV, I'm referring to the people in this community, especially my fellow contributors with positive attitudes. I'm happy to provide the best service that I can. Even though I know some things about you, mostly because of an issue you inflamed last week, I don't know your level of competence with WP.

    Perhaps I could have been more explicit with my intentions. I'll thank you for the suggestion.

    Cheers,
    Paul

    Need multiple downloads for MarketPress products? No worries!: http://goo.gl/vrdWx

  • Mike Price
    • The Incredible Code Injector

    Paul,

    I am the customer so I am not the one needing to say your first name. I have had nothing but trouble in this forum since I been a paying member. People here seem to always give others a run around or explanation that could easily be found in google search. We are here because we paying for premium support.

    Believe me, I am a very nice person and I apologize if I have come off as rude. I am just seriously annoyed by services not working as they should especially when I pay so much each month. I am not the only upset customer on this forum I see posts all the time from others who are just as stressed out with this forum as I am.

    Again, its not personal but I think WPMUdev really need to focus more on helping people and doing it quickly because the longer this bug exists the longer my site must remain in maintenance mode. And that means money lost for some people.

  • Paul Barthmaier
    • Code Wrangler

    Mike,

    Let's first talk about your issue. Where are we on that? Plugin disabled?

    Then I'd like to double back on the other larger issue you raise. And I can honestly say that I understand your perspective. That's a big reason why I'm here. I want to be an agent of change. I just think it's cute that you started your message all blustery. For some folks, getting caught up in the emotions is an easy thing to do, and if it were someone else reading your request, they may take immediate offense. But given your history, and my interest in the study of interpersonal communication, I am amused by it.

    More later, but back to your plugin issue.

    Cheers,
    Paul

    Enable theme for a single site in Multisite? Try: http://marker.to/a94mht

  • Mike Price
    • The Incredible Code Injector

    Paul,

    Plugin is installed and activated and is working fine now as I was able to rid myself of the error. However, the issue at hand is that it won't allow me to change "Jabber / Google Talk" to "Age" When attempting to do so, the error returns.

    So for now, I fixed it so no more errors but I need to find a resolution on how to make this trivial text change without encountering this horrible error message. Thanks

  • Paul Barthmaier
    • Code Wrangler

    I see. You know, it very well could be that / (forward slash). I know that when writing echo statements, if you want to write an 's you need to use a backslash. Otherwise your statement will end before it even sees the s. You know, you need to write something like \'s. For more reference, you might look at http://marker.to/2t9AtA .

    Honestly, I"m not sure that's the issue here, though. If that doesn't work, can you get around it by writing two statemens? That is, one for Jabber and one for Google Talk?

    Cheers,
    Paul

    Enable theme for a single site in Multisite? Try: http://marker.to/a94mht

  • Mike Price
    • The Incredible Code Injector

    Hey

    Thanks for the suggestions. However, the issue is that the "/" is part of the text that I want changed and is not a part of what I want the text to actually be changed to. Currently WP by default shows this in user profile "Jabber / Google Talk"

    I want to remove the "/" and change it something else so including a different type of slash or the word "or" would not help because that is not part of the text I need to change. Hope that makes more sense.

    The only option I can see now is to just do a separate text change for Jabber and one for Google and have to deal with the "/" still be there. I can't find a way to remove that from the text.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.