Need some help with wp multisite issues?

I just set up a wordpress multisite…I’m not sure if my setup was done properly…Here’s the issue…I do the sign up process….When I receive the email to activate the blog – I click on the activate link provided but it doesn’t seem to work properly? It’s giving me an error. The browser is not loading it properly? Has anyone encountered this problem? Need your help thanks!

  • Kimberly
    • Champion of Loops

    Hello there!

    Welcome to the Community!

    Have you set up your hosting to allow for multisite?

    Are you trying to use subdomains or subdirectories?

    When you say:

    It’s giving me an error. The browser is not loading it properly?

    What is the error?

    Can you share the link?

    Any more information would be helpful :slight_smile:

    Best,

    Kimberly

  • Simplebutcreative Media
    • Site Builder, Child of Zeus

    @kimberlyl

    Hi Kimberly,

    Yes I’ve done the setup through my hosting already.

    I chose to go with subdomains…

    Once you register to get your own blog, the front-end user receives an activation email right….The link within the activation email seems to be broken?

    I’ve tested a couple times already and It’s not working at all…You would expect some kind of a message saying your blog is now activated right?

    I always get a message saying page didn’t load properly or page not loaded.

    You can see for yourself here:

    http://lipstikdiva.com/wp-signup.php

    Let me know if you get the same results as I do…

    Thanks for responding!

    Kevin

  • Kimberly
    • Champion of Loops

    I can edit the post if I see anything compromising.

    If you are creating the sites then they should show in your backend, even before they get activated, especially if you create it via the backend “New Site” and use your network admin email as the new admin email.

    And you say you have setup a Wildcard Domain with your host?

  • Simplebutcreative Media
    • Site Builder, Child of Zeus

    Kimberly,

    I’m testing the site as if I was a front end customer…Like you said the sites will show in the backend if I do it from the admin area…But my concern applies to my customers on the front end.

    Yes I have a wildcard dns already setup…I even had them double check to see if I did it properly…They say everything looks great.

    Here’s the .htaccess – This was the code provided once I activated the network…I replaced everything with the code below…just like the instructions says?

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*.php)$ $1 [L]
    RewriteRule . index.php [L]

  • Simplebutcreative Media
    • Site Builder, Child of Zeus

    Yeah I followed the instructions provided by you guys…I pasted part of the code below where I did the editing…

    /**
    * WordPress Localized Language, defaults to English.
    *
    * Change this to localize WordPress. A corresponding MO file for the chosen
    * language must be installed to wp-content/languages. For example, install
    * de_DE.mo to wp-content/languages and set WPLANG to 'de_DE' to enable German
    * language support.
    */
    define('WPLANG', '');

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define('WP_DEBUG', false);

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'lipstikdiva.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    /* That's all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

  • Kimberly
    • Champion of Loops

    Think I see the problem!

    define('MULTISITE', true);

    Your Multisite Define is incorrect:

    From the manual:

    https://premium.wpmudev.org/manuals/wpmu-manual-2/creating-a-network-to-enable-wordpress-multisite/

    4. Add the following line to your wp-config.php file:

    define(‘WP_ALLOW_MULTISITE’, true);

    above where it says /* That’s all, stop editing! Happy blogging. */:

    A common problem that can occur is if you copy and paste the define(‘WP_ALLOW_MULTISITE’, true); directly from a website into the wp-config.php file in EditPlus 3 or other text editing software. Instead of pasting quotes as straight single ticks it pastes them in as curly quotes.

    When this happens WordPress won’t recognise the edits you have made. The best way to avoid this is to simply type in manually define(‘WP_ALLOW_MULTISITE’, true); instead of relying on copy and paste. If you have edits that don’t seem to take when you add them to a test editing software, then try this simple fix.

  • Simplebutcreative Media
    • Site Builder, Child of Zeus

    Kimberly,

    The instruction says to delete that line once I activated the network. Did I read that wrong?

    So I should add this:

    define(‘WP_ALLOW_MULTISITE’, true);

    With this code:

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'lipstikdiva.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.