Need to change MAIN multisite "http" to "httpS" - How?

I have been having issues with SSL and finally have it mostly fixed. I was able to change the http to httpS in the additional multi-sites, but I can't do it in the main one. How do I do it? See screen shots for comparison (main is greyed out).

  • Milan

    Hello @Amanda,

    I hope you are having a good day and thanks for asking us. :slight_smile:

    I can see that siteurl editing option is disabled only for main site in Network Admin > Sites > Main Site > Edit > Settings, which shows me that you can't actually works with HTTPS on your main site without some tricky behavior. So Are you ready for this ? I am sure you are. :slight_smile:

    We can make your main site loads on https by hacking database a little bit. Don't worry its very simple process but still backup of your whole database is first suggestion before you take this process.

    You’ll need access to phpMyAdmin from your host or the Adminer plugin for WordPress. in your "wp_options" table, you need to look for the "siteurl" and "home" options. Both of those will have "http://" addresses and you just need to change the "http" to "https". Then, go into the wp_sitemeta table and change the "siteurl" to "https" there. Again, MAKE SURE YOU BACKUP YOUR DATABASE BEFORE YOU DO THIS! If you used the Adminer plugin to edit your database, delete it once you’re done. There’s no reason to keep it around.

    For full backup of you site I suggest you give our Snapshot Pro a try.

    I hope this helps you.

    Please let me know if there is anything else I can help you with.

    Cheers,
    Milan Savaliya.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.