Need to disable browser caching

I need browser caching to be disabled for my site on your host. There is no way to do that from Hummingbird Admin page. Please help me disable this.

  • Mhamdi Youssef
    • Flash Drive

    Hi Susan

    I hope you are doing well today!

    After a long discussion about disabling caching browser for you with our devs.
    The first thing that came to their minds is why you would want to disable the browser caching ?.
    So in your next reply, please tell us more information about why you would want to disable this feature?.

    Please Note : Browser caching stores temporary data on your visitors’ devices so that they won’t download assets twice if they don’t have to. This results in a much faster second time around page load speed.

    Also, there are an Expiry Settings – Where you can decide how long you would like to keep your cache stored before it’s reset. By default, 8 days is selected, but you can increase or decrease this as needed.

    If you don't want this feature to keep your cache stored too long you can decrease it even to hours, you just go to Hummingbird Pro > Caching > Browser caching -> scroll down to Expiry Time and set it there.
    Screenshot:

    Also please be aware that our devs mentioned that they setup static file browser caching to max (10 years) and that can't be changeable.

    If you still want to disable Browser caching, I'm afraid we can't do that using Hummingbird plugin because browser caching is enabled on the server level in NGINX.

    So please concern in telling us more information about why you want to do this, and I'm sure our devs will concern on giving you some great solutions better than disabling Browser Caching.

    I hope this was helpful, waiting for your feedback!
    Have a nice day :slight_smile:

    Best regards,
    Youssef

  • Mhamdi Youssef
    • Flash Drive

    Hi Susan
    I hope you are doing well today!

    I forwarded your answer about why you want to disable browser caching and shared your previous ticket to our Devs investigate your issue a bit and they noticed that the issue is not coming from the browser caching but from page caching also members can't change or clear NGINX expiry headers (browser caching).

    I see that you already disabled the page caching, so for the browser caching I'm afraid you can't disable it, so please set the stored temporary data on the browser at least to 1 hour if you don't want to make stored data for a long period of time.

    Also, you asked in the other ticket that

    Please let me know that is there any hook for clearing cache like there is for generating report?

    Please check the replay there since my friend Nebu John replayed to you there, also it can be helpful for this issue as well.

    Hope you have a great day :slight_smile:

    Best regards,
    Youssef

  • Mhamdi Youssef
    • Flash Drive

    Hi Susan
    I hope you are doing well today!

    I re-asked the dev about disabling browser caching for you and he said that we use the same NGINX code for all our hosting server and they cannot downgrade performance for just one member.

    So, I'm afraid you can't disable it. All you can do for now is to set the stored temporary data on the browser to 1 hour if you don't want to make stored data for a long period of time.

    Hope you have a great day :slight_smile:

    Best regards,
    Youssef

  • Mhamdi Youssef
    • Flash Drive

    Hello Susan

    I hope you are doing well today!
    I'm really happy to help you anytime you need help.

    I re-checked everything I can do for you, but still, we cannot nor disable Browser Caching nor change its expiry time, and as I already mentioned before, the Browser Caching stores temporary data on your visitors’ devices to 8 days by default so that they won’t download assets twice if they don’t have to.

    These temporary data are very helpful to your site and it will make your site much faster the second time around page load speed, and if the problem that you have is really caused by the temporary data, you will still be able to lower the expiration time for those temporary data to 1 hour.

    When I re-asked the developer about the browser caching, he said this:

    Reason behind this - We used same nginx code for all our hosting server (3500+) and just for one member we can't downgrade performance)

    I'm really trying to help you with everything I can, but still, we cannot change anything related to NGINX browser caching except its temporary data.

    Here is the Hummingbird Pro documentation that may help you : https://premium.wpmudev.org/docs/wpmu-dev-plugins/hummingbird/#caching

    Hope this helps, Have a great day ahead!

    Kind regards;
    Youssef

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.