Need to switch from PHP 5.6 to 7.1 without getting errors

I'm switching my websites to PHP 7.1 (they are currently on PHP5.6), as my host recommended the switch for safety reasons. But after doing the switch to 7.1, my website doesn't work anymore.

I just get the error message:
"Parse error: syntax error, unexpected 'new' (T_NEW) in /home/clients/f6723f7063f4bf7f5d5317407a4af156/web/dushanjancik.com/wp-content/plugins/audio-player/audio-player.php on line 903"
After getting this error I reverted back to PHP 5.6 and now it's working again.

So question is, how can I upgrade to PHP 7.1 without having that problem?

  • Majid
    • Recruit

    Hello there,

    I suggest that you talk to the audio player developer about this, they will be more helpful though, but if the developer can't be reached for some reason, You can send me the plugin files using this form here: http://premium.wpmudev.org/contact/ and select I have another question, also make sure that the subject is
    Subject: "Attn: Majid Hamdani"

    And you will need to upload your plugins to somewhere like DropBox or similar.

    Regards,
    Majid

  • DJExp
    • The Incredible Code Injector

    Hello Majid,

    Thanks for the answer, sorry I'm responding so late, I didn't get any notification this time.

    Since that plugin wasn't useful anymore on my website, I simply deactivated it (because now Wordpress is able to natively play mp3 files).

    Thanks a lot for the help !

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.