"Network Admin" menu links broken upon 3.5 subdomain multisite install (subfolder WP insta

Has anyone else experienced this?

I have just setup a fresh WP 3.5.1 installation, inside a “ssl” folder, with subdomain multisite network enabled.

In the wp-admin the “My Sites” menu items for the primary site are working (eg. “[domain]/ssl/wp-admin/post-new.php”:wink: however the “Network Admin” menu items are all missing the “/ssl” folder in the links and give a 404 error (eg. “[domain]/wp-admin/network/sites.php”:wink:

By manually adding the /ssl in the address bar I can access the network admin pages, however buttons/forms within the network admin pages still seem to leave out the /ssl subfolder.

eg. “Add New” plugin button or “network activating/deactivating” any plugins.

No problems with a root install multisite, only with a subfolder install (which is supposed to work in 3.5?)

Here are the steps I followed:

1) http://codex.wordpress.org/Installing_WordPress#Famous_5-Minute_Install

2) http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory#Using_a_pre-existing_subdirectory_install

3) http://codex.wordpress.org/Create_A_Network

Help help/advice is appreciated.

Regards, Kent

  • KJA
    • Design Lord, Child of Thor

    Here’s the .htaccess and wp-config (which is the exact code that WordPress provided upon enabling the network)…

    Note: the domain name of the site has been replaced with “[domain]”, as this is a top-secret project! It’s the same .com I referenced in my original post :wink:

    .htaccess:

    RewriteEngine On

    RewriteBase /

    RewriteRule ^index.php$ – [L]

    # add a trailing slash to /wp-admin

    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]

    RewriteCond %{REQUEST_FILENAME} -d

    RewriteRule ^ – [L]

    RewriteRule ^(wp-(content|admin|includes).*) E:disappointed:inetpub/vs239247/ssl/$1 [L]

    RewriteRule ^(.*.php)$ E:disappointed:inetpub/vs239247/ssl/$1 [L]

    RewriteRule . index.php [L]

    wp-config:

    <?php

    /**

    * The base configurations of the WordPress.

    *

    * This file has the following configurations: MySQL settings, Table Prefix,

    * Secret Keys, WordPress Language, and ABSPATH. You can find more information

    * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing

    * wp-config.php} Codex page. You can get the MySQL settings from your web host.

    *

    * This file is used by the wp-config.php creation script during the

    * installation. You don’t have to use the web site, you can just copy this file

    * to “wp-config.php” and fill in the values.

    *

    * @package WordPress

    */

    // ** MySQL settings – You can get this info from your web host ** //

    /** The name of the database for WordPress */

    define(‘DB_NAME’, ‘####’:wink:;

    /** MySQL database username */

    define(‘DB_USER’, ‘####’:wink:;

    /** MySQL database password */

    define(‘DB_PASSWORD’, ‘####’:wink:;

    /** MySQL hostname */

    define(‘DB_HOST’, ‘####’:wink:;

    /** Database Charset to use in creating database tables. */

    define(‘DB_CHARSET’, ‘utf8’:wink:;

    /** The Database Collate type. Don’t change this if in doubt. */

    define(‘DB_COLLATE’, ”:wink:;

    /**#@+

    * Authentication Unique Keys and Salts.

    *

    * Change these to different unique phrases!

    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}

    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.

    *

    * @since 2.6.0

    */

    define(‘AUTH_KEY’, ‘####’:wink:;

    define(‘SECURE_AUTH_KEY’, ‘####’:wink:;

    define(‘LOGGED_IN_KEY’, ‘####’:wink:;

    define(‘NONCE_KEY’, ‘####’:wink:;

    define(‘AUTH_SALT’, ‘####’:wink:;

    define(‘SECURE_AUTH_SALT’, ‘####’:wink:;

    define(‘LOGGED_IN_SALT’, ‘####’:wink:;

    define(‘NONCE_SALT’, ‘####’:wink:;

    /**#@-*/

    /**

    * WordPress Database Table prefix.

    *

    * You can have multiple installations in one database if you give each a unique

    * prefix. Only numbers, letters, and underscores please!

    */

    $table_prefix = ‘wp_’;

    /**

    * WordPress Localized Language, defaults to English.

    *

    * Change this to localize WordPress. A corresponding MO file for the chosen

    * language must be installed to wp-content/languages. For example, install

    * de_DE.mo to wp-content/languages and set WPLANG to ‘de_DE’ to enable German

    * language support.

    */

    define(‘WPLANG’, ”:wink:;

    /**

    * For developers: WordPress debugging mode.

    *

    * Change this to true to enable the display of notices during development.

    * It is strongly recommended that plugin and theme developers use WP_DEBUG

    * in their development environments.

    */

    define(‘WP_DEBUG’, false);

    /* Multisite */

    define(‘WP_ALLOW_MULTISITE’, true);

    define(‘MULTISITE’, true);

    define(‘SUBDOMAIN_INSTALL’, true);

    define(‘DOMAIN_CURRENT_SITE’, ‘[domain]’:wink:;

    define(‘PATH_CURRENT_SITE’, ‘/’:wink:;

    define(‘SITE_ID_CURRENT_SITE’, 1);

    define(‘BLOG_ID_CURRENT_SITE’, 1);

    /* That’s all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */

    if ( !defined(‘ABSPATH’:wink: )

    define(‘ABSPATH’, dirname(__FILE__) . ‘/’:wink:;

    /** Sets up WordPress vars and included files. */

    require_once(ABSPATH . ‘wp-settings.php’:wink:;

    Changing the RewriteBase line to “RewriteBase /ssl/” has no effect either, still the same incorrect Network Admin link

    Thanks.

  • Timothy
    • Chief Pigeon

    Hey again.

    Note: the domain name of the site has been replaced with “[domain]”, as this is a top-secret project! It’s the same .com I referenced in my original post :wink:

    They always are. :wink:

    Try changing:

    define( 'PATH_CURRENT_SITE', '/' );

    to:

    define( 'PATH_CURRENT_SITE', '/ssl/' );

    Let me know. If that doesn’t work then I’ll take a closer look.

    Thanks.

  • KJA
    • Design Lord, Child of Thor

    @timothy Bowers

    I discovered yesterday that this is a known bug in the WP core. Here is the bug report link:

    http://core.trac.wordpress.org/ticket/23221

    I asked on the WP support forums this same question and one helpful user got back to me with a temporary fix/hack to the /wp-includes/link-template.php file.

    Editing the line below solved the issue for me, but it’s only a temporary fix until the next wordpress update overwrites it or they indeed fix the bug:

    $url = network_site_url(‘wp-admin/network/’, $scheme);

    change to

    $url = network_site_url(‘yourfolder/wp-admin/network/’, $scheme);

    Here’s the WP support forum link for reference:

    http://wordpress.org/support/topic/network-admin-menu-links-broken-on-35-subdomain-multisite-install-subfolder

    Thanks for your help thus far :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.