Network Disabled but sites still see the plugin

I installed Membership Pro 2, network enabled.. tried it on sites..

Then I had to Network Disabled it but the plugin is still appearing at sites and are allowed to be activated by the users.

Is this normal?

  • Kevin Chan
    • Design Lord, Child of Thor

    Also, what does Network Enable do for themes? I installed some theme and even without turning on Network Enable, the sites are still able to see it as long as I enable it for the individual site.

    I thought Network Enable (in the Network Admin area) are a global setting to “show/ hide” the themes totally?

  • Tyler Postle
    • CGO

    Hi there Kevin,

    Yes, that’s normal behaviour in a multisite. When a plugin is Network disabled then it can be activated site by site. If it’s Network Enabled then it must remain active on all sites until network deactivated.

    With that said, there are some plugins to manage the plugins if you want to restrict access to them for certain sites.

    Our Pro Sites plugin allows you create a premium network with different levels so your users can pay you to access more features/plugins/themes etc. https://premium.wpmudev.org/project/pro-sites/

    If you don’t want to charge your users for access and instead just restrict certain plugins, you can use this plugin: https://wordpress.org/plugins/multisite-plugin-manager/

    It’s developed by the same person as Pro Sites – he’s our head developer here :slight_smile:

    Hope that helps! If you have further questions just let us know.

    Cheers,

    Tyler

  • Tyler Postle
    • CGO

    Hey Kevin,

    Oh I see what you mean. Yes with the themes, if they aren’t network enabled then they shouldn’t be accessible to any of the individual sites. Unless you as an admin edit the site and enable that theme specifically for that site.

    Could you grant support access so I can have a closer look?

    You can grant support access via WPMU DEV > Support > Support Access > Grant Access.

    Look forward to hearing back!

    All the best,

    Tyler

  • Tyler Postle
    • CGO

    Hey Kevin,

    So it looks like your main site has all the themes activated for it specifically, which is why you see them all there. I've attached a screenshot to illustrate.

    As for the other sites, I'm only seeing 2015 theme active and that's because it's the default theme and there must be at least 1 theme on the site :slight_smile:

    If you have any further questions on this just let me know!

    Cheers,

    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.