Network Max Upload Size must have a limit set

I have added..
upload_max_filesize = 15000M; to a file in root user.ini
I have added
ini_set('upload_max_filesize', '15000M'); to wp-config
I have added upload_max_filesize = 15000M; to php.ini file in my root..
I have check server php.ini settings.. I have reset the upload size.. on every site successfully no problem..
But in network settings...there is a override.. set on that.. that I don't know how to fix..
I set https://nimbus.everhelper.me/client/notes/share/788322/n06o1f3r01nuxx0akiae
to 0.. and it works and the media uploader says, Max is 0kb..
But no matter how high I set that setting.. it never goes over 64MB.. can somebody please help.. thanks

  • James Morris
    • WordPress Enthusiast

    Hello Craig,

    I hope you are well today.

    Going into WPMU DEV -> Support -> System Info, I'm seeing the following PHP values:

    upload_max_filesize	64M
    post_max_size	64M

    This indicates that, regardless of what you've set your php.ini and user.ini settings to, your hosting provider is capping you at a maximum of 64MB as the maximum value.

    This is a very common practice with providers like GoDaddy. You may want to search for upload_max_filesize in your hosting provider's knowledge base (FAQs) to see if there is a hard limit set. If there is, I'm afraid there's nothing you can do to overcome this except change providers.

    I hope this clarifies a bit.

    Best regards,

    James Morris

  • Ash
    • WordPress Hacker

    Hello Craig

    Did you configure the server yourself? I am asking because it seems the server respects the settings from somewhere else. Do you have any other htaccess or ini file anywhere you can remember?

    Also, would you please check your wp-config.php if there is any define for WP_MAX_UPLOAD_LIMIT and or WP_UPLOAD_LIMIT?

    Let us know about these please.

    Have a good day!

    Cheers
    Ash

  • Ash
    • WordPress Hacker

    Hello Craig

    In that case, I believe the issue is what James said.

    regardless of what you've set your php.ini and user.ini settings to, your hosting provider is capping you at a maximum of 64MB as the maximum value

    You are seeing 1000M in phpinfo because it reads the php.ini file.

    And in our dashboard plugin, we used ini_get() function to get the value which php fetch. Would you please talk to your host about this issue? They will be able to help and troubleshoot in their server end.

    Please let us know how it goes.

    Have a good day!

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.