NETWORK SET UP REVIEW REQUEST INCLUDING ON MY SITE AND MY HOST

I have until now only installed single Wordpress sites and this is my first Network Site. I followed instructions to the best of my abilities. I have been downloading and activating plugins most of the day. I haven\\'t downloaded any themes as of yet.
MY ISSUE: I have not yet launched my network publicly as I am only now building it, however I tried to locate my site\\'s under construction page and I get a time out error. Also when signing into my site it seems to take an excessive amount of time to sign me in. Can someone please review my Network set up including site URL and Site Address settings to make sure that I am structured correctly before I venture too far and before I eventually launch.
NOTE: I use Bluehost who allows for Wildcard domains. I set that up. I also did not have an .htaccess access file showing so I created on and used FTP to upload it.
Not sure why site temporary page is not online?
During the Network Setup my WP prompted me to change the domain address from http://www.jirehsolutions.org to simply jirehsolutions.org I did that on the Settings Page. This may be the issue? I need to make sure it was done on the Network Settings I suppose and not the first temp site settings. Please review and correct any Network set up issues.

I'm getting a message saying that the internet is not able to connect with my site when I type in http://www.jirehsolutions.org

I have enabled access to my site to support yesterday 4 days remain to directly access it on that permission.

If you need to access my hosting account go to to my site directly and there is a note on the Dashboard with these details and the access to my host account.

Please review how it is set up there under jirehsolutions and also if you can double check my wildcard domain settings.

Thank you. I don\'t want to press way into this to find out I have something set up wrong that may cause my network to not function.

Thus far I have downloaded many of the plugins and activated most of them across the network but I have not begun to set them up.

Thank you again.

  • Adam Czajczyk

    Hello @Pastor Jedidiah,

    I hope you're well today and thank you for your question!

    Could you please first double-check the issues I listed below?

    1. Check your site's "wp-config.php" file against these lines:

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'jirehsolutions.org');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    In case there was any difference, please make it exactly the way I posted above.

    2. Make sure that your .htaccess file content is like this:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    3. Go to the "My Sites -> Network Admin -> Sites" page and then
    - click on "Edit" link for your main site
    - clikc on "Settings" tabl
    - check if now Siteurl and Home options show "http://jirehsolutions.org"

    Let me know please if it helped.

    Best regards,
    Adam

  • Pastor Jedidiah

    Hello Adam,

    I did all of that and now my site is offline and I cannot access it. I provided dashboard access and access on my host so that you could do this for me instead of telling me how to do it. Please access my dashboard site and my host and get me back in order so that I can proceed with the install.

    Also yesterday all of the plug ins were showing up on my site. Today they were all gone. I can see them on the CPanel but they were not showing up on my site, neither was my Dashboard Plugin. My dashboard plugin would not reinstall either.

    Let's not waste more time getting me set up with a multi-site that works properly. I need to move ahead and with a Premium account it I would be grateful if you jumped on this and set it up for me.

    All of the access info is in the original ticket.

    Thank you. Let me know when you have it squared away or if you need more information.

  • Adam Czajczyk

    Hello @Pastor Jedidiah,

    Thank you for your response!

    This is in fact a bit weird as what I shared with you were the most basic and default WordPress Multisite settings. I'm not sure what could have happen here.

    I'll be glad to take a closer look but (most likely due to the issue described in your initial post) I wasn't able to access your dashboard and I'm not able to do this now. A support access also do not allow me to check files directly on server (such as for example wp-config.php).

    That said, could you please send in:

    Subject: "Attn: Adam Czajczyk"

    - your site's WordPress admin login URL
    - admin login and password (may be a temporary account)
    - FTP credentials (hostname, username, password, port number if needed)
    - phpMyAdmin URL
    - any other relevant URLs and information
    - link back to this thread

    Please use our contact form here https://premium.wpmudev.org/contact/.
    Select "I have a different question" from the drop-down list.

    Please be sure to make a full backup of your entire site first!

    Best regards,
    Adam

  • Pastor Jedidiah

    To give you a heads up on what I am trying to create. I work with a growing number of native pastors, ministers and missionaries, as well as people in general who need networking, communications platforms, crowdfunding, websites, etc. I am attempting to build a network to service their needs where each one can sign up, develop their own site and communications, and crowdfunding efforts. In general I want our guys to sign up for free, use the services all for free and then tithe a 10% back to the organization for administrative cost etc. as a Sending Agency normally does. People who are not directly in partnerships with us may use the services in a different way, perhaps a fee based per services or we may just opt to go with a 10% of any funds raised fee across the board. Our guys have all of their support for ministry, project, funds, etc routed through out PayPal account as a Non Profit and we disperse to them overseas once a month and deduct any cost and fees remanding their balances to them. Not sure how we would do that for random users who would choose to use the site or services unless we forced somehow our PayPal credentials into the plug in coding and distributed to them any funds raised in the same way that we would to those who are connected to and working with us in alliance partnerships. But essentially that is where I am trying to take this project into a Network Platform that can deliver many of the plug in capabilities all across the network. Hope that helps you get a bit of a picture of what I am aiming to do. We may even sell domain names and site hosting as a way to help cover admin cost and maybe even products. All of which are reasons that I went with WPMUDEV to get it all squared away with your themes and plugins. Just fighting the learning curve right now as we start up. Thanks for your help an patience.
    Pastor Jedidiah

  • Pastor Jedidiah

    I was able to install and activate themes across the network, but I am getting a few errors that I need corrected.

    #1). I cannot install the wpmudev Dashboard plugin through the Plug Ins Dashboard. I had it installed and operating at one point before the issues surfaced. I reinstalled a fresh copy on my host side but it does not appear where I can activate it. When I try to upload a fresh copy on the Plug Ins Panel I get this error message:

    Installing Plugin from uploaded file: 387540_wpmu-dev-dashboard-4.0.4(4).zip
    Unpacking the package…Installing the plugin…
    "Could not create directory. /home1/jesushig/public_html/jirehsolutions/wp-content/plugins/wpmudev-updates/ Plugin install failed.
    Return to Plugins page"

    #2). I had uploaded all of the themes and nearly all of the plug ins from wpumdev and I see them on my host side, but cannot access them on the website side.

    #3). I am getting a consistent error when trying to view my initial site saying:

    "The page isn't redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete."
    I get this when I try to view my initial site which is addressed as: jirehsolutions.org

    4). Help me understand these points also:

    Will my Network Administration Site that I am calling JIREH SOLUTIONS NETWORK be a live site able to be seen on the public internet or is it only an internal administrative site?

    Is the first site that is automatically created (I.E. JIREHSOLUTIONS.ORG) supposed to be the main public site of the network that I am creating? (It is not view-able and I can't add plugs to it due to the plug in issue that I mentioned before.

    Please let me know when you have completed your work on the ticket that I sent in via Premium Support. Thanks.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.