New 3.0 MultiSite install URL issue

I've just installed wordpress 3.0, set up the multi site according to all the instructions and have it working with subdomains however when I create a new blog its putting the site name on the back of the url

The blog is http://youheardthatnetworks.com

When I created a new site the url it creates is http://indie.youheardthatnetworks.comyouheardthatnetworks_com/

Obviously this doesn't work, when I manually remove the xtra url on the end (which is the db username by the way) it shows the blog but no theme or css comes up.

What have i done wrong? The server is through DreamHost Private Server, they set up the wildcard DNS and made sure everything in the DNS is set correctly.

  • maladymg

    Sure here is the htaccess

    <br />
    RewriteEngine On<br />
    RewriteBase /<br />
    RewriteRule ^index\.php$ - [L]</p>
    <p># uploaded files<br />
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]</p>
    <p># add a trailing slash to /wp-admin<br />
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]</p>
    <p>RewriteCond %{REQUEST_FILENAME} -f [OR]<br />
    RewriteCond %{REQUEST_FILENAME} -d<br />
    RewriteRule ^ - [L]<br />
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]<br />
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]<br />
    RewriteRule . index.php [L]<br />

    and the config
    <?php
    /** WordPress's config file **/
    /** http://wordpress.org/ **/

    // ** MySQL settings ** //
    define('DB_NAME', 'youheardthatnetworks_com'); // The name of the database
    define('DB_USER', 'youheardthatnetw'); // Your MySQL username
    define('DB_PASSWORD', 'XXXXXXX'); // ...and password
    define('DB_HOST', 'mysql.youheardthatnetworks.com'); // ...and the server MySQL is running on

    // Change the prefix if you want to have multiple blogs in a single database.

    $table_prefix = 'wp_fdq7f7_'; // example: 'wp_' or 'b2' or 'mylogin_'

    // Turning off Post Revisions. Comment this line out if you would like them to be on.

    define('WP_POST_REVISIONS', false );

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = 'youheardthatnetworks.com';
    define( 'DOMAIN_CURRENT_SITE', 'youheardthatnetworks.com' );
    define( 'PATH_CURRENT_SITE', 'www.youheardthatnetworks.com' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    define( 'AUTH_KEY', '<!*GEXeopRsH}Dvy:yWpTD~k~:siMyf*d)UEv!]>z6`Khk0x! yk{a&^*KnbL@On' );
    define( 'SECURE_AUTH_KEY', '@3 RGH`C|!0JeWj617|<(>tHv0?8&7Q]{X3Wpt_TI.iQQ7Vc]6y)b6AI!K.:VLQr' );
    define( 'LOGGED_IN_KEY', 'e(m%&*>R/;ct0uza3>~x`/V#xXG6[=#;ZRZdu1b7^Ys1oL_D9ckL{cC>ZOADgU6a' );
    define( 'NONCE_KEY', 'Om*PO4~*oDP[w!cLb|vDi{5XkQK;2uMqdY6;bw1-&)nZ!BHdme?Q~5TZI24^M&U3' );
    define( 'AUTH_SALT', 'S/<{s9s@1(LaFr5GSLl`W.w=wORS~&xhiR p_jkHz:&CfpI1/1s,cg{_Z*:J8$;|' );
    define( 'SECURE_AUTH_SALT', 'UnpQxxtyg@ppd1]las3V+@K[DRc)ehoTG|c2){N -vOL%e_@~f.jMwP)(y;10:?l' );
    define( 'LOGGED_IN_SALT', 'x|T[qQ!7,. Lii8j,c+z~~f;LLZc7&=Ov/`jyBG-YhiX$_cCs}T31Cq^Yk6PNDoH' );
    define( 'NONCE_SALT', '+@:3|eSeUf<{6LcPNNen6gI-iN8%/u03.F9^K2?$~Z^p@y*p$3/Cei%4l-R2]#rC' );
    /* Stop editing */

    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;

    define('ABSPATH', dirname(__FILE__).'/');

    // Get everything else
    require_once(ABSPATH.'wp-settings.php');
    ?></code>
    `

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.