New account not active after successfully registering and subscribing – Paypal

First off EVERYTHING else has been setup perfectly. Everything works exactly as it should, and for that I’m grateful! After searching on here, I’ve seen very similar issues to my only one, but they are all open ended or got off topic to some other problem. Here’s the situation:

Totally logged out and visiting the site as a user would for the first time, I went through the subscription process.

1. I first created a new account then clicked the register button.

2. I then clicked on the subscription option Unlimited Access (subscription as successfully created by me) which has the Paypal logo (gateway is setup for recurring).

3. I go through the Paypal checkout process.

4. I successfully paid the membership amount (as confirmed with receipt to both Paypal accounts for the recurring monthly agreement).

5. I am redirected back to the home page of my site in a logged out state.

6. I go to login and receive the error “Sorry, this account is not active.” (I saw someone mention an activation email being sent to new users, but one was not received and I don’t see an option to toggle this feature from an Admin perspective.)

7. When logged in as admin, I can see the newly created member, but it is inactive with no subscription level.

Obviously, I could manually activate as an Admin, but that defeats several purposes of using this plugin. I have made a User and activated the Unlimited Access subscription through Admin, so I know User and Member Levels work properly once activated. I will attach a screenshot of every Membership Setting. Membership version is 2.0.7. WordPress Version is 3.3.1. I really am hoping I can get this fixed very soon so that I can launch the site ASAP. Thanks in advance!

  • DavidM
    • DEV MAN’s Mascot

    Hi willlurie and first off, welcome to WPMU DEV!

    Sorry you’re experiencing some trouble with that. Membership’s now up to version 2.1.4 though, is there any possibility you could update to that version?

    That may just resolve this as you’re a number of versions behind currently.

    Apart from that, could you have a look at Membership > Payment Gateways and see what the transactions for the gateway read there?



  • willlurie
    • New Recruit

    Thank you for the response! I installed the newest Membership plugin (2.1.4), double checked that the settings were retained, then went to create a new account. Steps 1-5 from my original post are exactly the same. So far, so good. THIS time when I go to login, it IS successful in logging me in, but the member level/subscription level is still set to the stranger level. I went and checked the Payment Gateway transactions as you suggested and it only says “No Transactions have been found, patience is a virtue.” What do I try next? Thanks again!

  • willlurie
    • New Recruit

    I have an update! Paypal sent me an email saying the following:


    Please check your server that handles PayPal Instant Payment Notifications (IPN). IPNs sent to the following URL(s) are failing:

    If you do not recognize this URL, you may be using a service provider that is using IPN on your behalf. Please contact your service provider with the above information. If this problem continues, IPNs may be disabled for your account.

    Thank you for your prompt attention to this issue.



    I still DESPERATELY need your help in solving this issue, as it is holding up launching the site. Thanks!

  • willlurie
    • New Recruit

    I don’t understand what I have to do to receive support until my issues are resolved. Why is almost $80/mo not enough? I don’t want to be an affiliate, I don’t care if I download premium plugins ever again, I pay for support and I’m not getting it. I’m very disappointed.

  • DavidM
    • DEV MAN’s Mascot

    Hi willlurie,

    My sincere apologies for having missed following up with this. I’ve flagged the core developer for this to have a look here as I really can’t see why the transaction wouldn’t go through myself.

    Could you both please check though, in Membership > All Members, there are a few columns, the Payment Gateway being one of them. Could you let us know what that column reads for the specific members in question?



  • willlurie
    • New Recruit

    As Ryanott said, they are all empty is this scenario.

    Out of desperation I tried deactivating all of the plugins and starting over with all of the settings. Nothing. After fiddling with several other settings at random, I changed Permalinks to default and then back to a “Pretty” option. That lead me to start seeing errors everywhere, including in the admin.

    Here’s the order of steps that seems to have fixed it for me.

    1. I went back and deactivated all plugins

    2. I changed Permalinks back to default and saved

    3. I changed Permalinks back to Pretty

    4. I reactivated each plugin double checking for errors.

    5. After they all became active again I ran an IPN from Paypal. It worked.

    6. I actually went through the whole checkout process and it worked. I canceled the recurring payment and it updated in membership to show cancellation at the end of the month.

    So everything is working for now. This is still a problem, however. Because without knowing what went wrong I don’t know if I can bank on it (pun intended) to be the backbone of my new site. If only I could pay $80/mo and have “world class support” to insure I’ll be able to keep everything running smooth.

    I forgive you, DavidM. How about 1000 points to make it up to me? :slight_smile:

    @ryanott the only things I am sure of, that I had to learn for myself, are that Permalinks must be set to something other than default (mine is set to Post Name), you should set up a Paypal Sandbox account so that you can easily hit the IPN after making changes without using money (if you’ve never done this I can walk you through it), and that it seems to somehow be possible that other plugins can affect the IPN response so deactivate everything while getting it to work.

  • ryanott
    • WPMU DEV Initiate

    Thanks Willlurie. Unfortunately, I’ve been through the steps you listed to no avail several times …

    I’ll need to coordinate with the client to setup and test in the sandbox again. Unfortunately, they’re about as frustrated as I am with this issue and leery about more headaches.

    I’m with you in thinking that this might not be the solution we need. Unfortunately, I’ve paid up well in advance for what I thought sounded like the best option, in part for the “world class support”.

    I’m going to sandbox (and likely go through the plugin activation scenario a few more times) while I wait to hear what the solution might be to this issue.

    Some Rep points coming your way @willlurie – thanks again!

  • aecnu
    • WP Unicorn

    Greetings :slight_smile:

    though at this moment I do not remember where here on WPMU Dev its says to have Permalinks set to anything but default.

    At this point and from the information provided it appears that the problem is surrounding the IPN or the return of the IPN properly to your website thereof.

    What you folks did not mention is what is the Instant Payment Notifications URL is set to?

    Within PayPal under History–>IPN History can give clues as to what is happening with the IPN.

    Trying to help you folks figure out with what appears to be an IPN problem :slight_smile:

    Joe :slight_smile:

  • willlurie
    • New Recruit

    @aecnu Actually I did in my third comment:


    Please check your server that handles PayPal Instant Payment Notifications (IPN). IPNs sent to the following URL(s) are failing:

    If you do not recognize this URL, you may be using a service provider that is using IPN on your behalf. Please contact your service provider with the above information. If this problem continues, IPNs may be disabled for your account.

    Thank you for your prompt attention to this issue.



    That’s the URL it’s using (with mysiteurl being the respective url obviously). Paypal IPN history simply lists the transaction attempts with the status Failed. It is undoubtedly the return of the IPN because everything works smoothly until the membership level is unaffected.


  • aecnu
    • WP Unicorn

    Greetings willlurie :slight_smile:

    not all is well because you are getting failed IPN’s – so PayPal is trying to send the IPN’s –> so it is after this point that something is obviously going wrong –> on the receiving of the IPN end.

    The url path you gave above I do not see in my installation, however, I am not nor have I in the past used this particular plugin.

    Actually our IPN return is set to a non wordpress script ….. lol ….. and Pro Sites and Marketpress are performing well.

    However, until I have personally dealt with this plugin and can then investigate the path, I shall shut my mouth and shall go sit in the virtual corner ….. lol

    Joe :slight_smile:

  • Barry
    • DEV MAN’s Mascot

    @willurie – can you post up a screenshot of a couple of the IPN history logs from PayPal and we may be able to spot something – also the actual url of your site would help a lot as then we can test the IPN url from here.

    Can you also activate and run the Membership verify and repair add on and let us know what it reports

  • Timothy
    • Chief Pigeon

    Hey there! :slight_smile:

    Just checking in to see how things are going with this one and if you need any further help. :slight_smile:

    We haven’t heard from you on this thread for a while, perhaps you got help over email. I’m going to presume your all fixed up now and don’t need any further assistance.

    However if you have more questions or need some more help then please feel free to respond in this thread or create a new one and we will be more than happy to offer assistance. :slight_smile:

    Take care.

  • hashim
    • New Recruit

    hi there,

    I got the same problem, i tried to understand the steps Willlurie did, i got lost half way through.

    I’ve set up a recurring payment in Paypal, it says successful, however in my admin, i received an email for a different username and password, and it says account is not active.

    Basically, when i went through the registration process, i’ve used lkjhgldf as my username and some gibberish email.

    After successful paypal payment, i received an email, the same email i used for my paypal with my name as the username and 123456 as the password, i don’t remember using my name as the username and 123456 as the password.

    And when i try to access it, it says account not active.

    But when I logged into the admin and i can see lkjhgldf account as active?

  • willlurie
    • New Recruit


    Let’s double check your Paypal settings for IPNs:

    1. Log in to the Paypal account that you have setup for your site to use Paypal Express.

    2. Go to My Account>Profile>My Selling Tools>Instant Payment Notifications

    3. Make sure you have a Notification URL. With Membership it seems the address should be “http://*yourwordpressinstallroot*.com/paymentreturn/paypalexpress”. Replace with your WordPress install root obviously.

    4. Make sure you have Message Delivery “Enabled”. Save changes.

    Now let’s test it:

    1. Do you have a Paypal Sandbox account (a testing only account)? If not, make sure you set one up here.

    2. Once you have a Paypal Sandbox account, log in. Then go here (you must be logged in).

    3. Put the Notification URL from above “http://*yourwordpressinstallroot*.com/paymentreturn/paypalexpress” as the IPN handler URL.

    4. Set the Transaction Type to Express Checkout

    5. You can ultimately tweak the settings that pop up but the goal for now is to get “IPN Successfully Sent” after you click “Send IPN”.

    If you do get “IPN Successfully Sent”, then you should be good to go! If you do not get “IPN Successfully Sent”, and you do have the correct Notification URL, then it’s time to double-check WordPress settings.

    Double check WordPress settings:

    1. Once logged in as an admin on your WordPress install go to Settings>Permalinks.

    2. Under Common Settings make sure “default” is NOT selected. I used Post Name successfully.

    3. Save changes then go back to the sandbox and try running the IPN test again.

    If it’s still not working, try each of these until you get “IPN Successfully Sent” when you run it in the Sandbox:

    1. Double check that you have the latest version of WordPress (3.3.1) AND Membership (2.1.4)

    2. Deactivate all plugins except Membership. If you get “IPN Successfully Sent”, then add back plugins one at a time (double checking the IPN in between each). If it IS working UNTIL you activate a certain plugin, then that plugin is the culprit.

    Let me know your results after all of this and we’ll go from there!

  • aecnu
    • WP Unicorn

    Greetings willlurie,

    Aecnu, How will this affect those who successfully have Membership running finally? Will it be a seamless upgrade, or something different? Thanks!

    I truly have no idea though due to it was built from the ground up, though I am sure it will take into consideration the folks that are already successfully using the plugin.

    In addition – some rep points for you for your efforts to try to help out hashim

    @hashim – Please let us know if this does not resolve your problem by reopening this ticket below marking it as not resolved. Also please indicate if there are any new symptoms or errors.

    Thank you both for being a WPMU Dev members!

    Cheers, Joe :slight_smile:

  • hashim
    • New Recruit

    Thank you so much Willlurie! It works now! But I’ve got another funny problem, now that I’m a paid member, it redirects me to a page where i set in the options setting.

    “Protected content page

    If a post / page / content is not available to a user, this is the page that they user will be directed to.

    This page will only be displayed if the user has tried to access the post / page / content directly or via a link.

    Protected content page: some page”

    I protect the content by using the More tag. Before i’m a paid member, i could see a bit of the content and a note after the more tag that says you need to be our subscribers. But as a paid member, i can’t even read the teaser post, it automatically redirects me to the protected content page.

  • chriskiss
    • New Recruit

    Hi… I am having this problem as well!! Relieved to see I am not alone. PLEASE HELP.

    When a new member goes through the PayPal (sandbox test) and “pays” , they are returned to our “welcome” page. This works. BUT!!! THEY CAN’T LOGIN and the new user account exists but is NOT ACTIVE. As well, the columns are empty for the level of subscription and I have to login manually as admin to simply MAKE ACTIVE the account, Then everything works perfectly.

    Is there ANY way to automatically ACTIVATE the account, set the subscription level and send the user an email when payment is complete??

    SO CLOSE…. but yet so far.

    A thousand thanks.

  • aecnu
    • WP Unicorn

    Greetings chriskiss,

    Thank you for your questions but it is a mistake to open a 6 month old ticket that addresses the plugin version that is many times over obsolete and has replies and monitoring from people that are not active.

    Please open your own ticket and feel free to copy and paste any relative information from this ticket to the new one.

    Thank you for your understanding and for being a WPMU Dev Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.