new account -plugin not working

Hi,

This is a new trial account and it seems I’m required to install your plugin. I’ve done that and trying to login but get an error that the domain has previously been registered. How can I get this to work on my localhost mamp server?

Thank you,

Bartek

  • Rupok
    • Support Ninja

    Hi Bartek

    Hope you had a wonderful day.

    Trials are limited to one time per WordPress site. I’m afraid you can’t register localhost because someone might have registered his localhost before. You can get more idea about trial membership here: https://premium.wpmudev.org/manuals/using-wpmu-dev/how-free-trials-work/

    You can easily remove this barrier by upgrading your membership to our regular membership plans. Please let us know if you have any confusion, we will be glad to help.

    Have a nice day. Cheers!

  • Bartek
    • WPMU DEV Initiate

    Thanks Kasia. That’s a great idea, but a little beyond me at the moment. I tried but couldn’t get it to work as my knowledge is limited. I tried configuring the http.conf as well with

    <VirtualHost *:80>

    ServerName bartek.test

    DocumentRoot /Applications/MAMP/htdocs/bartek

    </VirtualHost>

    but that didn’t help either. Maybe it’s that I’m not certain which IP address to apend to /etc/hosts. Thanks anyway as it’s a great idea.

  • Rupok
    • Support Ninja

    Hi Bartek

    Hope you had a wonderful day.

    From your given code, I see you are using MAMP. In that case, we can create a virtual host without writing a single line of code. Open MAMP, click on the "Hosts" tab. Now click on the (+) sign at bottom left. Give a domain name as you want (better if it's a unique one, I've used "rupok.wpmu" in my example screenshot) in the Server Name box. Click on the IP Address dropdown, and select the IP you see there (Normally you will see only one IP there – your local IP). Then select the folder you want to use as root directory from the "Document Root" section, and you are done. Please check the attached screenshot for reference.

    If everything is done properly, hit with your unique domain in your browser and you will see a page like this:

    Please let us know if you still have any confusion. We will be glad to help.

    Have a nice day. Cheers!

  • Bartek
    • WPMU DEV Initiate

    Actually, now I can’t install anything from WordPress.org as I get this message:

    An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums.

    I can still manually install plugins. I imagine something else needs configuring? wp-config.php seems ok.. and can’t find anything in the themes or my child theme’s functions.php.

    Both localhost and my created globalmindenglish.local are sharing the same IP and WordPress install. I’m not sure if I need to make a new WP install, but that’s a bit overkill to need to migrate it from one directory to another …

    :slight_smile:

  • Kasia Swiderska
    • Support nomad

    Hello Bartek,

    This might be issue with permissions – check if directory wp-content is set to 755 (because this is your local enviroment try also 777 – on live server this is not recommended but on local will do no harm) .

    Is there prompt asking you for FTP credentials when you try to install plugins from WordPress.org repository maybe?

    Also – check if your site and home url in WordPress settings are entered and are the same.

    kind regards,

    Kasia

  • Bartek
    • WPMU DEV Initiate

    I tried both 755 and then 777 on all folders from the WP install folder and subdirectories. There’s no FTP login…no…and the site addresses are entered correctly. It’s not a big problem, I just have to manually install plugins for now. Hopefully it won’t transfer over when I migrate. Thanks for trying to help!

  • Ash
    • WordPress Hacker

    Hello Bartek

    An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums.

    This is not a big issue, this happens due to misconnection between your site and wordpress.org server.

    When you will upload your site to a real domain, this won’t happen. Even in localhost, most of time you won’t face this :slight_smile:

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers

    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.