New Appointments Update does not use Default Service

You can go to http://www.massagetx.com/brass to see that my the time is defaulting to 10 min. instead of what I selected in my appointments settings as the 20 min default service.
Any ideas why? I have granted access.
thanks,
matt

  • Sajid

    Hi @Mattbkelly

    Hope you are doing good today :slight_smile:

    Thanks for granting support staff access. I can see you have selected 15 minutes duration for 10 Minutes Treatment service and same for 20 Minutes Treatment service, its duration is 25 minutes.

    According to this setting its working fine to me. If you want to make it to be booked for 10 minutes and 20 minutes for each of your service then change the duration here.

    I have changed the time duration for 10 minutes treatment service to to 10 and its working fine for me. Yes, I have reverted it back to where it was.

    So the name and duration is different you must select the correct duration from duration dropdown as seen in attached screenshot.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:
    Cheers, Sajid

  • Mattbkelly

    I see what is happening. The thing I changed is adding a worker="12" to the service shortcode and that causes it to revert to the first service time. Any fixes you know for this. I also find it strange that I need to add worker="12" to the monthly shortcode to reveal that providers appointments. I need to add it to the service shortcode because it shows only that providers services instead of all the services. I am not shure if that is a new feature - I don't remember having that option before. Anyway, it looks like a bug. Let me know if you have any questions and especially fixes.
    thanks,
    matt

  • Sajid

    Hi @Mattbkelly,

    Hope you are doing good today :slight_smile:

    I could not reproduce this issue on my end. When I specify worker ID in [app_services] shortcode it automatically set the working hours I set for that specific worker from Appointments > Settings > Working Hours > list for "selected provider" and yes, it also update monthly schedule and service provider dropdown.

    So if its changing the time slots then make sure you have selected the correct timings for that specific worker.

    To add the default service you can use following mu-plugin.

    add_action('wp_footer', 'add_default_value_services', 99);
    
    function add_default_value_services(){ ?>
    
    	<script type="text/javascript">
    		jQuery(document).ready(function($){
    
    			$('.app_select_services').prepend('"<option value=''>pick a service duration</option>"').val('');
    
    		})
    	</script>
    
    <?php }

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:
    Cheers, Sajid

  • Mattbkelly

    Thank you for the mu plugin. Are you putting the same worker in both the shortcode like this page:
    http://www.massagetx.com/brass

    [app_services worker="4" description="none" select="Please select treatment time from DROP DOWN MENU below:" autorefresh="1"]
    [app_confirmation]
    [app_monthly_schedule worker="4" logged="Click a Green Day(available), then choose a Green Start Time. Please note there is additional time added to each treatment time:"]

    ........

  • Sajid

    Hi @Mattbkelly,

    Hope you are doing good today :slight_smile:

    I am sorry for delay in my response to this ticket. I could replicate this issue on my own website finally with with the default service selection when we specify worker ID in the shortcodes.

    Therefore, I am marking it as confirmed bug and notifying the developer so it can be patched up in coming version of the plugin. I am sorry but we are unable to provide an ETA of exactly when it will be fixed.

    Please keep an eye on this thread for updates or you will also get notification right in your dashboard if you are using WPMU DEV Dashboard plugin.

    Thanks for your patience and bringing in our attention, sending some points your way for appreciation.

    Take care and have a nice day :slight_smile:
    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.