New Blog Templates doesn't copy plugin data


I'm using New Blog Templates with Pro Sites, and want the Google Maps and Formidable plugins to be auto-activated for Pro sites only.

My problem is that when I clone a site which has a map and a form set up (eg, the plugins are activated as expected, but the map and form are not copied over to the new site.

When I Network activate the plugins, the map and form are copied over, but obviously that doesn't allow me to limit the plugins to Pro sites only.

Any thoughts?

  • Tom Eagles

    Hi Julia,

    One thing to check did you also select the correct additional tables under Advanced options.

    How i got this working was to make sure the plugin wasn't network activated, assigned google maps to the correct prosites level under premium plugins.

    Created my template site for testing purposes i just added a simple page and added a map to it, and then saved the page.

    Now i then created a template from this site, making sure that the copy pages posts etc etc were all set to be copied and also under advanced i selected which tables i also wanted copying over clicked save.

    Now go back to wp-admin and lets create a test site and select the template we just created. go to sites select manage and add the appropriate pro sites level to it and select make permanent. (doing this is the same way that prosites does it automatically)

    Now go to the site we just created and to that test page with the map on and it should appear :slight_smile:

    No need for network activation and the maps etc copied across. So basically in a nutshell make sure you also copy across the tables that contain the plugin data as well.


  • julia312

    Hi Tom - sorry about the Adrian thing! I think that came from another email...

    Anyway, the steps I've taken are:

    1. Plugins: Pro Sites, New Blog Templates, Google Maps and Formidable installed. Google Maps and Formidable are not Network activated.
    2. Pro Sites set to give Pro access to all new sites for 5 days.
    3. Pro Sites set to auto-activate Google Maps and Formidable for the Pro level.
    4. Templates: New blog template created from an existing site, which has a map and a contact form set up. All fields under "Advanced options" were checked.
    5. New site created from the blog template.

    The new site and the blog template now have no map or contact form.



  • julia312

    Hi Jack,

    Sorry, I'd forgotten this thread was still open. I eventually tracked down the issue yesterday, and it had nothing to do with Anti-Splog - I guess I must have changed other settings at the same time.

    The issue was that I had activated the map and contact form plugins when I made the blog template, and had also set Pro Sites to auto-activate the plugins for the Pro level. The user is give 5 days' Pro access initially, so I guess Pro Sites must have been trying to activate plugins that are already activated? I'm not sure how this works. Anyway, this setup resulted in the map and contact form disappearing.

    The solution was to uncheck "auto-activate" for those plugins in Pro Sites. I guess it would also have worked to have de-activated the plugins before creating the blog template, and set Pro Sites to auto-activate the plugins? I haven't tried that yet...

    Anyway, it's definitely working now! Thanks for investigating.

    Kind regards,


  • Jack Kitterhing

    Hi there Julia,

    I hope your well today.

    No problem at all, I'm glad to hear that it's all working for you now :slight_smile:

    That would cause a conflict with Blog templates trying to auto activate and Pro Sites, and it also would have worked like you say to deactivate the plugins before creating the blog template.

    Glad to hear it's all working! If we can be of any further assistance please don't hesitate to ask.

    Kind Regards

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.