New Blog Templates, NextGen conflict, error

Hey, I just discovered an issue with the NextGen and New Blog Templates that I *really* need some help with.

Set up is: 3.01 MU/BuddyPress

NextGen is installed but set up so it is activated on blog-by-blog basis (too complex for all users, issues with MU). Have been creating blogs and using it fine.

I just created apx 20 blogs using the New Blog Template with NextGen as an active plug-in. These will be portfolio blogs, so NextGen is an important plug-in.

Big Problem. The template seems to have hard-wired the BlogID to the blog used to create the template. It does not correspond to the blog one is in.

So, in my case: xxx/wp-content/blogs.dir/9/files/sample
(Blog number 9 was used as the template)

Deactivating and re-activating the plug-in doesn't seem to get rid of this hard link.

Doing a "reset" of the plug-in seems to have made it worse...

I have a message in to the developer, too. He is aware that there are issues with MU

Any advice how to troubleshoot this? I may have to try deleting all these blogs and recreating them without the plug-in installed (new blogs from the default twentyten work fine.)