new blog templates only copying properly for superadmins

Got some strange things happening with new blog templates.

Firstly when creating a new site when logged in as an account with super admin rights then all the files from the template site are being copied across properly to the new site. This is confirmed by checking the directory contents of the new site in the blogs.dir folder.

However, if I create a site under a new account, or create a new site under an existing account which isn’t a super admin then a number of things aren’t being copied to the new blog. Images are one thing not being copied in this case, The media library on the new site has the images listed so that part works, its the actual copying of the files which is failing – checking in filezilla these haven’t been created like they are when a super admin creates the site. This is also affecting some of my third party plugins, which again only seem to work properly if a superadmin creates the new site.

Other things like posts, nav menus, installed themes and plugins seem to be copying fine regardless of the user level.

Its taken me about 20 hours to finally track down why some things on my site weren’t working quite right and why on other ones (where they were superadmin created) things were fine. Now i’ve located the issue i’m unsure of how to fix it.

I’ve tried checking permissions (I’m using WP-Engine so these are all set to 775 and 664) but that wouldn’t explain why super admin sites are created properly and others aren’t.

I’ve also tried selectively deactivating plugins on the site to check for conflicts there and not been able to find anything causing this issue.