New Blog Templates showing on all gravity forms

Hi-
Multisite with root at xxxhost.edu/staff/
Subdirectory Multisite...
WP 4.7.2, latest GF (2.1.3.5) with latest GF User Registration (3.7)
New Blog Templates (2.8.5)
We really like how New Blog Templates works with Gravity Forms for user signup/site creation.
Our problem: We have a 2nd form on the root site (Contact form). It is also showing the New Blog Templates section that is needed on the signup/site creationg form.
How can we tell New Blog Templates to only display its template selector section on gravity form id=1 (the user signup/site creation form) and not to display on form id=2 (Contact form)?

  • Sajid

    Hello webappsupport,
    Hope you are doing good today :slight_smile:

    I have latest version of Gravity Forms, Gravity Forms User Registration, New Blog Templates and WordPress on my test site but I am unable to replicate this issue.

    Could you please enable support staff access so I could take a closer look at setup and further investigate this issue.

    To grant access go to Dashboard -> WPMU DEV -> Support -> Support Access -> Grant Support Access or see this manual for more details regarding how to enable support staff access.

    Also, please mention the steps how you created those forms on your site.

    Take care and look forward towards your response :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

  • webappsupport

    Hi Sajid-
    I apologize for the delay. The server is behind our institution firewall, so I cannot provide access to it for you. However, I tested the issue on another internal server - this time making the 'support request form' have formID=1 and the create user/website form have formID=2.
    FormID 1 has no user registration feed set up for it.
    FormID 2 has a user registration feed and the box selected to show the New Blog Templates selector.
    The NBT selector is only showing on formID=1, even though there is no user registration feed set up for this form.
    The NBT template selector is not showing on formID=2 - the website signup where we want it to show up.
    Any thoughts?

  • Sajid

    Hi webappsupport :slight_smile:

    Welcome back. I have latest Gravity form with User Registration add-on installed on my own site along with New Blog Templates but id does not display the templates on gravity forms. Not even with the form that is used to create a user and website.

    It appears that you have modified the New Blog Templates plugin or using some custom hooks to render the templates on gravity forms.

    In order to further debug this issue, I would require to login to your site via FTP and WordPress admin credentials. You can send in these details via our private and secure contact form in following format.

    You can send the requested details via our secure contact form in following format.

    Subject: "Attn: Sajid Javed”
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference

    If you can't send details either, then make sure you are using un modified New Blog Templates, not using any hooks (mostly in theme functions.php file or in mu-plugin).

    In case, you are not using hooks or did not modified NBT, then please give me exact steps of how you have it configured so I could try to reproduce this issue on my own setup and make further suggestions.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.