New marketpress subsite store items not displaying on main site

I can’t seem to get my new sub-store items in a multi-site installation to show on the main store page – the only ones that display are from the “template blog” store. I am using the Global Product List widget.

I wondered if it could be a caching issue – erased WP Super Cache, tried installing W3 Total Cache, no love – so I erased that one, too. Looks like there’s nothing in the “Cache” folder in my WP-Content area on my host, so assuming that’s not the problem?

Any ideas? Pretty worthless if I can’t get this to work…

Help! Thanks much.

  • aristath
    • Recruit

    Hello there @jim, I hope you’re well today!

    Both WP Super Cache and W3TC add rewrite rules to your .htaccess file and add an advanced-cache.php file in your wp-content folder. Sometimes when you uninstall them these stay there and the site is still cached.

    Could you please make sure that this is not the case?

    Is the site private, or are you allowing it to be indexed by search engines?

    From your Dashboard go to Settings => Reading and make sure that the “Discourage search engines from indexing this site” field is NOT checked.

    Please advise,

    Ari.

  • Jim
    • Design Lord, Child of Thor

    Hi @aristath

    I actually did have that “Discourage search engines from indexing this site” box checked, so I unchecked that. No evident change…

    There’s also no advanced-cache.php anywhere on my server, but may be still a rewrite rule added – how would I know what it is and erase it? I’m not experienced with this and really don’t want to mess my .htaccess file up.

    Thanks for your help on this!

  • Jim
    • Design Lord, Child of Thor

    Currently, my .htaccess file has the following in it:

    # For security reasons, Option followsymlinks cannot be overridden.

    #Options FollowSymlinks

    Options SymLinksIfOwnerMatch

    RewriteEngine On

    RewriteBase /

    RewriteRule ^index.php$ – [L]

    # uploaded files

    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin

    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]

    RewriteCond %{REQUEST_FILENAME} -d

    RewriteRule ^ – [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]

    RewriteRule . index.php [L]

    See anything there that should be changed?

  • aristath
    • Recruit

    your .htaccess file seems fine…

    But the “Discourage search engines from indexing this site” box is what might have caused this issue.

    Could you please grant me access to your backend so that I may see exactly what is happening?

    To do so, from your dashboard go to WPMUDEV => Support => Support Access and click on the “Grant access” button.

    Cheers,

    Ari.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.