New membership site - home page is going to the forum, not the designated page

I've set up a new blog through multisite, and installed membership on it, and also the forum plugin, I've set up one forum and created a page with the forum code on it.

I've set the home page as a page caleld "members Only". I've set up the stranger level (called non-members).

When I browse to the site, the forum is the page that loads. If I deactivate the forum then the default page is a 404.

How can I get Membership to recognise my welcome page as the default?

the url is http://www.bodyblisscentral.com/members.

(all plugins, Wp etc are latest versions)

All help greatly appreciated!

  • bookewla
    • Flash Drive

    Hi Phil, it's taken me a while to get back to here - but here I am :slight_smile:
    I've upgraded to the newest version today.
    I've set up a subscription with 7 levels that drip out (following Siobhan's excellent post).
    I've activated the subscription, the levels, the posts that are the information for each level, and set the stranger level.
    I've set up a test user and added them to the subscription.
    When I browse to the /members/ page I get the option to subscribe or login, and I login - and then immediately get pushed to the same members forum page.
    I trashed that page (as I am using forums differently now, though they're not working as expected either, have logged a support request elsewhere) and now get taken to a 404...
    I can see three menu items, which is all I have set up:
    join
    welcome
    account info
    The first two give a 404 when logged in, the third takes me to the account info page and allows me to see and change etc.
    I'm at a loss - and hopeful that we can resolve this?
    Sandy

  • DavidM
    • DEV MAN’s Mascot

    Hiya Sandy!

    Was just reading your comments on Siobhans's post (I rather love that post myself) and noticed you'd posted here in the forums as well. Hope ya don't mind my jumping into that discussion on the blog, though perhaps we can just delve into that here! :slight_smile:

    Regarding your current 404 issue, could you let us know if your Protected Page is set as the same page as your Registration Page?

    If so, could you try and change the Protected Page to something else and see if that 404 error still shows?

    I'd just like to make sure that's not where the issue resides to start with.

    Thanks,
    David

  • DavidM
    • DEV MAN’s Mascot

    Hi Sandy,

    That is peculiar. I'll try out something similar on a test site to see if I can find where the trouble's occurring there. In the meantime, could you try the front page setting to the default to see if it still throws the 404 error?

    Thanks,
    David

  • bookewla
    • Flash Drive

    Hey David - Okay I've set reading back to 'latest posts' - still the same error.
    As you see from the top of the thread, I've had this same error since I joined and started using the plugin at the beginning of April. I really hope we can resolve it soon. Would it be useful for you to login to my site, maybe?

    Sandy

  • DavidM
    • DEV MAN’s Mascot

    Hi Sandy, I believe that would help to get it resolved more quickly as I really can't see why that would occur given your description of the setup.

    If you're fine with that, you could send account details through our contact form marked attention to David, preferably with a link to this thread for easy reference.
    https://premium.wpmudev.org/contact/

    The account will have to be able to see/edit the Membership settings and there's an option for that in the editing page for the user account; it's at the very bottom of the page of options.

    Cheers,
    David

  • DavidM
    • DEV MAN’s Mascot

    Hi bookewla,

    I believe we got this much resolved through that email exchange and these areas were able to be protected. I think it just comes down to a matter of setup, something which we're looking to make clearer with more tutorials as well as more in depth instructions, as this is one complex plugin.

    For now though, we'll be glad to deal with your inquiries on an individual basis if you'll go ahead and create a new thread for each.

    As we've got the homepage direction issue resolved, I'll go ahead and mark this particular thread resolved and we'll take a look at any more specific queries you have in separate threads.

    Thanks,
    David

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.