New Network, settings tab has no children

Hi Guys

Wondering if anyone can help, I did a new network like Ive done about6 times before following the biginners manual.

This time under the network admin area, the settings tab has no children have tried to attach a picture to illustrate whats happened but it wont let me.

Normally there should be settings and Network setup but they are not there this time.

thanks for the help in advance.

Regards
Dave

  • worldweb
    • Flash Drive

    OK fixed it myself thought I would write here what happened in case anyone else runs into this problem if your following the tutorial located here:

    https://premium.wpmudev.org/wpmu-manual/creating-a-network-to-enable-wordpress-multisite/

    about 2 thirds of the way down you will find this:

    1. Add the supplied code for your wp-config.php file from the ‘Enabling the Network’ page above the line reading /* That’s all, stop editing! Happy blogging. */: and remove the earlier added define(WP_ALLOW_MULTISITE, true); line.

    If you remove define(WP_ALLOW_MULTISITE, true);

    then the settings tab will have no children and will not look like the screenshot at the bottom of the screen.

    The settings will not have an opening panel.

    Regards
    Dave

  • Patagonia
    • Design Lord, Child of Thor

    I just got the same issue. I am not sure if I am understanding your solution right:
    did you add "define(WP_ALLOW_MULTISITE, true);" to WP-config and then it worked?

    If so, it did not work for me, I still have no 'children' of the settings tab in Network Admin.

    Could you or anybody else copy their WP config (not the db and passwords parts!) here as a reference as I miss several things that are mentioned in the install guide and am not sure what is required.
    Maybe because I am coming from an old WPMU installation instead of a fresh install?

    Thanks in advance

  • worldweb
    • Flash Drive

    This is what I have in mine:

    define('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', '*********' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    define( 'SUNRISE', 'on' );
    define('EMPTY_TRASH_DAYS', 5 );
    define('WP_MEMORY_LIMIT', '96M');
    define('WP_POST_REVISIONS', 5);
    define('AUTOSAVE_INTERVAL', 600);

    I found if the first line is missing then there is no settings tab

    Regards
    Dave

  • Patagonia
    • Design Lord, Child of Thor

    Thanks Dave.
    It is very strange. I have another install, that started as a 3.0 install, and I enabled network.
    It has this:

    define('WP_CACHE', true);
    define('WP_ALLOW_REPAIR', true);

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';

    define( 'DOMAIN_CURRENT_SITE', 'domain.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    It has a Network Admin settings page, even without allowing WP_ALLOW_MULTISITE; (but no Set up network tab or similar)

    Then I have 2 network installs that came from good old WPMU.
    If I use the same settings in wp-config, I get a network, but no settings menu and all links (url/category/posttitle) go 404, even new posts just created. Even when re-saving the permalink structure. So somehow there is a difference somewhere in the dbase between 'new' 3.0 networks and those coming from WPMU?

    When I use VHOST instead of MULTISITE (Using them together gives 500 error), so:

    // define('VHOST', 'yes');
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'testsite.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    Gives: "One or more database tables are unavailable. The database may need to be repaired."

    When also commenting define( 'MULTISITE' out:

    // define('VHOST', 'yes');
    // define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'testsite.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    then the site works, but permalinks don't (even after re-changing), I still have my network, but still no Network settings tab that expands, even when activating a plugin that should have a menu there like Global Site Search from WPMUDEV. Note that I have no other plugins active as this is a test install.

    I could likely re-install from scratch, but have however a live install with the same set-up as the second (test)site, but do not want to mess with that before solving this as it is, well, live :slight_smile:

    I am lost, but want to fix this as I want to prevent further problems down the road (permalinks that do not work, plugins without settings etc).
    Does anybody have any insights?

    Cheers

  • worldweb
    • Flash Drive

    I started using networks on 3.1 so Im not the best person to help you with this as Im still learning myself.

    Im sure if you post a new thread the guys here will be more than able to help or you could contact masonjames or one of the others here.

    Im a bit scared to try and offer any kind of solution as its all new ground for me.

    Sorry
    Regards
    Dave

  • Patagonia
    • Design Lord, Child of Thor

    No worries Worldweb, thanks for the reaction. It is just getting clear that the infamous 'merge' between WPMU & WP was never completed as they use different dbase tables, wpconfig etc.

    So I guess that all multisite posters shoudl indicate if it is an old WPMU install or a >3 new install.

    Anybody else with the old WPMU install without the settings tab?

    Cheers

  • jerrydefoe
    • New Recruit

    I'm having the identical issue on one of my sites. It is on a dedicated server, is the root domain (not vhost). Also, BuddyPress shows in the site admin panel. My wp-config.php and .htaccess is identical to many other sites not experiencing this issue.

  • jerrydefoe
    • New Recruit

    here's what fixed it for me: there are two different tilde's ' and ` i must have copied
    define( `WP_ALLOW_MULTISITE', true); from somewhere where the posting author used the wrong one and i simply edited them using the proper ones and voilà! Network Setup appears as a child in the Network Admin > Settings panel. Hope this does the same for you Patagonia.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.