New posts or comments not appearing in global post and comment widgets

Just spun up BuddyPress and posted a few test messages and comments to one of the bespoke sites.

I already had post-indexer and comment-indexer installed and the widgets in place before I made this posts.

Back on the main site, I don't get posts or comments in the widgets and global site search isn't working either. Check the attached screenshot showing the posts and comments on the main site's Activity page but the same info not showing up in the widgets.

I saw an earlier thread which mentioned privacy settings...this is a closed network where everybody has to log in and I've made the privacy settings, "[o] I would like my blog to be visible only to registered users of [sitename] Sites for the main blog and the bespoke blog. I have NOT made the settings limited to admins or to specifically named users.

Your help much appreciated as I'm spinning this up for a colleague of my wife's and I'd love to be done by this weekend. Everything else is working GREAT (thanks to your great plugins and docs).


  • Philip John
    • DEV MAN’s Apprentice


    Unfortunately it's your privacy settings that are stopping the plugins from doing their job.

    Unless the site is public, the plugins aren't able to properly index the posts and comments and as such they won't be available in the widgets.


    • WPMU DEV Initiate

    Hmm... that's confusing because I built this site to be a near perfect clone of one I built for my wife. That one is running WP 3.2.1 and bp 1.2.9 and the widgets work perfectly. Both sites also are running More Privacy Options. The working (older) site is running More Privacy Options Version and the new (no widget population) site is running More Privacy Options Version

    Any idea how I'm "getting through" to the widgets on my wife's blog but not on this near clone I'm building for her colleague?

    • WPMU DEV Initiate

    One thought: I see that the wp_site_posts table has a column blog_public that shows -1 for the posts. That makes me wonder if I can tweak the plugin or create a trigger or something to just not make that a -1 and thus have it not be "private" -- would that do the trick?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.