New SSL installed – permalinks not working anymore

I followed the 2 blog posts on this site about setting up SSL and then adding the Domain Mapping, but now my permalinks are not working on both the main site or the multisite(s). I changed them to “plain/default” and they worked, but then I get an error message saying Membership2 won’t work like that. …plus who wants to use those ugly permalinks? Not I!

What am I missing? What can I do to fix this?

  • Kasia Swiderska
    • Support nomad

    Hello Amanda,

    Can you try adding this in your htaccess file

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://www.yoursite.com/$1 [R,L]
    </IfModule>

    ?

    And please replace yoursite.com with your site URL. Let me know if this works for you.

    kind regards,

    Kasia

  • Kasia Swiderska
    • Support nomad

    Hello Amanda,

    Would you mind granting support access to your site so I could have a look there? You can grant support access via WPMU DEV > Support > Support Access > Grant Access.

    I wasn’t sure what blog posts are you referring without links, so I didn’t know you already had this in your htaccess.

    kind regards,

    Kasia

  • Rupok
    • Support Ninja

    Hi Amanda

    I hope you had a wonderful day.

    I just logged in with Support Access in your site and found the error in action. For fixing this, can you please tell us if you are using a Shared SSL or Private SSL? And moreover, a possible reason behind this can be “AllowOverride None” in your virtual host configuration. Changing it to “AllowOverride All” will most probably fix the issue. As you are using BlueHost, I’ll suggest you to ask them to change AllowOverride parameter value in SSL Virtual Host Configuration file and this will most probably fix the issue.

    Please let us know what they say to you. I’m looking forward to hear from you and solve it as soon as possible.

    Have a nice day. Cheers!

    Rupok

  • Amanda
    • Flash Drive

    Yes. I’m using Bluehost’s SHARED hosting. Is that “override” something I can fix? Is it in the htaccess? I tried this as well it didn’t work (subdomain changed to mine):

    # BlueHost.com

    #.htaccess WildCard SSL

    RewriteEngine On

    RewriteCond %{HTTP_HOST} ^subdomain.example.com$

    RewriteCond %{REQUEST_URI} !^/subfolder/

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule ^(.*)$ /subfolder/$1

    RewriteCond %{HTTP_HOST} ^subdomain.example.com$

    RewriteRule ^(/)?$ subfolder/index.php [L]

  • Amanda
    • Flash Drive

    Ok, Bluehost just threw me to the side and said they won’t help me at all. They gave me this long speech about just because I by something with them doesn’t mean they will give me tech support. Unreal.

    One thing they DID tell me that it is a PRIVATE SSL. At least I learned something from them.

    They sent me to this blog post (https://my.bluehost.com/cgi/help/766#wordpress ) and told me to do what it said, I did. Now the MAIN site’s permalinks are working (although there are new issues that I’ll have to sort out with the menu layout).

    But, the multisite domain is not working AT ALL now.

    I created a folder in SparkologyLab called “ignite” (nothing in the folder though cause the instructions they gave didn’t tell me any of that…terrible).

    And, my .htaccess says only this now:


    # Custom subdomain .htaccess SSL + WordPress

    RewriteEngine On

    RewriteCond %{HTTP_HOST} ^ignite.sparkologylab.com$

    RewriteCond %{REQUEST_URI} !^/ignite/

    RewriteRule ^(.*)$ /ignite/$1

    RewriteCond %{HTTP_HOST} ^ignite.sparkologylab.com$

    RewriteRule ^(/)?$ ignite/index.php [L]

    # End custom subdomain .htaccess

    # Custom maindomain .htaccess WordPress

    RewriteEngine On

    RewriteBase /

    RewriteCond %{HTTP_HOST} ^(www.)?sparkologylab.com$

    RewriteRule ^index.php$ – [L]

    RewriteCond %{HTTP_HOST} ^(www.)?sparkologylab.com$

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . /index.php [L]

    # End custom maindomain .htaccess


    Please. If you can help me at all, I will be over the moon.

    ….I need to go and drink large amounts of wine now.

  • Kasia Swiderska
    • Support nomad

    Hello Amanda,

    I’m extremely sorry for the delay. Did BlueHost said they are not willing to made changes in the Apache config for you or this is not possible to made that changes, as this is shared hosting?

    Are you sure you have Wildcard SSL certificate and not Standard (this is apart of the shared/private) one?

    Please enable again support access to your site.

    kind regards,

    Kasia

  • Amanda
    • Flash Drive

    Yes, I just checked my receipt. I purchased a “PositiveSSL Wildcard Certificate”. Bluehost said that I needed to follow their blog post first and then once I did they said they couldn’t help me anymore with tech support. Crazy?! If it is the Apache server, then I’ll get on them like a dog in heat to get it switched.

    Site access enabled!

    Thank you.

  • Rupok
    • Support Ninja

    Hi Amanda

    I hope you had a wonderful day.

    I really do apologize for the delay in solving this specific issue, but from now on, I’ll give high priority on this and will try to help you fixing it as soon as possible.

    I need to check the current SSL Configuration and other things on your server. I’ve found the Support Access active. So is it possible to send me message with cPanel access credentials through our secure contact form here: https://premium.wpmudev.org/contact/

    Subject: “Attn: Rupok”

    – WordPress admin Username

    – WordPress admin Password

    – Login URL

    – Link back to this thread for reference

    – Any other relevant URLs

    Select “I have a different question” for your topic – this and the subject line ensure that it gets assigned to me.

    Have a nice day. Cheers!

    Rupok

  • Rupok
    • Support Ninja

    Hi Amanda

    I hope you had a wonderful day.

    I know it’s already delayed and I do apologize for that but please keep in mind, this is a live site and the situation is already complex here, as you have customized .htaccess file already and you don’t have any access on the server level. So we had to be very very careful while working on it and had to cross check every time we wanted to make any test and change.

    That’s why it was taking a bit longer than usual. I’ve logged in with cPanel credentials you sent me, and after analyzing the whole environment, fixed the custom permalink issue on the main site and subsites. SSL is working for the main site and subsites. And now custom permalinks are also working for both main site and subsites. I’ve just created a test subdomain there (https://wpmudev.sparkologylab.com) and changed the permalink to a custom one and it’s working fine.

    Can you please check and confirm?

    Have a nice day. Cheers!

    Rupok

  • Amanda
    • Flash Drive

    Yay for that! I was so excited until I saw that you deactivated plugin, MarketPress (your plugin). I reactivated it as I clearly need it and BAM! Server error! I deleted and reinstalled and again! Server error! UNREAL! It was working fine before all of this. I’m so sad. Another day lost!

  • Rupok
    • Support Ninja

    Hi Amanda

    I hope you had a wonderful day.

    This should not happen. I’m checking right away. And I’ll try to make sure that you get your solutions in the shortest possible time.

    I just logged in with Support Access but didn’t see MarketPress installed on your site. You said “I deleted and reinstalled” but I don’t find it.

    So is it ok if I install it on your site, check if it gets broken, then work on this and try to fix it ASAP?

    Another important thing, I can see your server is using Version 5.2.17 of PHP. As this is a very old version of PHP, can you please ask your host to update the PHP version to at least 5.4 ? I believe they will agree to help this time and it might solve your problem. Even not, that doesn’t harm.

    Actually I’ll suggest you to open a new thread regarding the MarketPress error you are mentioning as this seems to be critical. And a new thread means more attention to our support staffs and it also helps you to track the solutions for each problem.

    Have a nice day. Cheers!

    Rupok

  • Amanda
    • Flash Drive

    STOP THE PRESSES! I updated my PHP to 5.4 and tada! Marketpress is working again! OH MY GOODNESS! HAPPY JIG!

    Everything is right in the world! Thank you thank you thank you for your help and guidance. You all went over and above to help me get this sorted (even if it did take longer than I would have liked). You did awesome!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.