new subdomain sites - corruption

this is probably hard to diagnose problem .. hopefully not ... it is probably associated with Domain Mapping... and Multi-Domains... but maybe not

I have a WP 3.5 multisite subdomain network with multi-domains and domain mapping, all plugins updated. so far it seemed to work reasonably well... but...

I added a new subdomain site to one of the multidomains... seemed okay... but for some mysterious reason that site thinks it is another site... this is even hard to explain: has a multidomain
so I add new site to
looks like it was added okay... but when go to dashboard or visit site, goes to

BIGGEST CLUE... is a site that used to have domain mapping -, but I deleted the domain mapping to just use

I tried adding another test site with deactivated. nope, same problem -- thinks it is

CLUE: with "deactivated" - visiting the site, it displays and is not deactivated. both dashboard and live site - it is not deactivate

I added a new multidomain ... added another test site... still goes to

CLUE I added a new test site to = and it resolves correctly. so it is the multi-domain sites with the problems adding new subdomain sites.

Maybe not a clue, but.. when creating the site I noticed that templates were not offered - and New Blog Template settings have been deleted somehow during updates. but ultimately I don't think the blog templates have anything to do with it.

in order to test Domain Mapping as the culprit I went back to the original and reestablished it. it resolves correctly - even with the site "disabled".

BIGGEST CLUE2... but guess what... with Domain Mapping restablished for --- adding a new site to a Different site that had recently had domain mapping changed is now chosen as the identity

the new test site now thinks it is

but the sites created before was reverted, they still think their dashboard and site is

I know this one is a brain bender, but my network is now handicapped... and I'm pretty sure Domain Mapping combined with Multidomains is to blame... but could be wrong of course

help and advice greatly appreciated.

BTW: I really can't see disabling domain mapping to test this... my network would be down.

  • Zyniker
    • WordPress Warrior

    Do you currently have a lot of domains mapped? If not, clearing out Domain Mapping's database table and re-creating the records has solved a lot of problems for me in the past. If so, have you had a look at what records are currently in that database table? If something looks out of place, it may help to delete that record.

    Also, do you have both the wp_domain_map and the wp_domain_mapping tables in your database? Was this install working at some point and the issue started recently (e.g., with your update to 3.5)? or is it a new install? If the latter, which host?

    Do you have single sign-on enabled in Multi-Domains?

  • tripvendor
    • The Bug Hunter

    thanks for your interest:

    1) way too many sites to start over with domain mapping
    2) domain mapping table... nothing looks out of place (domains related to problem are not listed there anymore)
    3) wp_domain_map is not in the DB
    4) I can't pinpoint when problem came up - don't know what update caused it WP, multi-domains or domain mapping plugins. but definitely related to changing sites from having domain mapping to not having domain mapping
    5) not a new install
    6) problem persists with either single sign-on enabled or disabled

    new symptom.... Admin is 10x slower now.... which just kills me

  • aecnu
    • WP Unicorn

    Greetings tripvendor,

    Thank you for bringing this issue to our attention, sorry to see that your WordPress installation is having this issue, and it is my thoughts to be similar to Zyniker's that the Domain Mapping database entries are indeed corrupt and if cleaning them up is out of the question then the next best step would be to restore the last functioning correctly database backup or at minimum restoring the wp_domain_mapping table.

    Please advise.

    Cheers, Joe

  • tripvendor
    • The Bug Hunter

    the recent domain mapping update had so many issues, I would really appreciate hearing from the developer before I take the time - and that means DOWNTIME - dealing with the simple mapping table hoping it might fix this. seems to me that table is pretty simple to be the cause of this -

    but I'm open to recommendations based on something firm. doesn't it just tie a Blog ID to a domain ? or did I not see something in the table...

    it appears to be some sort of conflict between multi-domains and domain mapping scripts, not DB (at least in wp_domain_mapping)

  • aecnu
    • WP Unicorn

    Greetings tripvendor,

    You may indeed be on to something in regards to Domain Mapping versus Multi Domain though I am not qualified to make that determination and indeed Domain Mapping has had several updates come out and I am wondering if the sunrise.php from Multi Domains has an issue of some sort with the newer Domain Mapping.

    But this is something the lead developer would have to repair in any event.

    Though this may take a bit longer then a normal ticket, I will try to get him in here asap.

    Cheers, Joe

  • tripvendor
    • The Bug Hunter

    Thanks Joe

    I know it isn't trivial to diagnose. quicky recap if someone had a test network to play with

    1) WP multisite subdomain network with multi-domain/domain mapping with a bunch of subdomain sites with domain mapping

    2) delete the domain mapping on a couple of sites and keep the sites as

    3) then try to add a subsite to another separate multi-domain site

    (my problem is it identifies the new site as one of the deleted domain mapping and not a new site)

    AND deactivation of the site isn't working

    (I changed the from a parked to an add-on domain and used htaccess to point to to get some SEO before the domain expires -- which shouldn't be related but just to give a complete picture)


  • tripvendor
    • The Bug Hunter

    I have discovered the same or similar problem on all my networks, except one that has not been updated to WP3.5 and the plugins have not been updated.

    This problem persists even with ALL plugins disabled.

    I'm in for many hours of testing and will be creating a couple of new networks just to try to figure it out.

    But I am flabbergasted that more reports of this have not come up.

  • aecnu
    • WP Unicorn

    Greetings tripvendor,

    Though still waiting for the lead developer to offer his input and assuming you are using Domain Mapping version 3.1.7, what version of php is your host using?

    Or indeed was it the version of Domain Mapping you are/were using?

    Please advise.

    Cheers, Joe

  • tripvendor
    • The Bug Hunter

    Hi Joe --

    I believe this problem goes beyond what I thought and focused on in this thread. It only became apparent under the circumstances described.

    I think it has something to do with WP3.5 update and server settings. I'm having problems on sites that don't have domain mapping or multi-domain.

    I will do more research and create a new support thread and/or reply here if I find a solution.


  • aecnu
    • WP Unicorn

    Greetings tripvendor,

    Aha! Another hosting issue un-foiled that only required an update probably needed php 5.3 to fix it all up.

    I seen a few folks on here still running php 5.2.17 and they are having issues of sorts as well. Something to keep an eye out for.

    Thank you for letting us know and for posting how you managed to fix it as well.

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.