new subscriptions to pro-site with paypal fails

Hey

The last week we have had issues with new subscriptions to pro-site using paypal as gateway. I get to the confirm page on paypal, and then it returns to the blog after the payment process, but the area that confirms the payment is not there. If i stay on the page and wait for about 20 seconds and refreshes then sometimes it registers the payment.

Subscription payment works fine, and we get IPN callbacks. We have talked to paypal that so far cannot see any isues in their end.

Do you have any suggestions ?

  • Patrick
    • Support Monkey

    Hi @bloggersdelight

    The last week we have had issues... Subscription payment works fine, and we get IPN callbacks.

    Those are the 2 key elements in the issue you have described.

    Allow me to paraphrase: the process works just fine behind the scenes, but confirmation on the front-end has been sluggish in the last week.

    This would tend to indicate that you have installed a new plugin, or changed the settings of an existing one, that affects the display of confirmation on the front-end.

    If you really cannot remember what you may have changed (and that can happen often when developing a site), go for basic troubleshooting protocol as follows.

    Revert to the default Twenty-Eleven theme and deactivate all other plugins. Is the problem still there? If yes, then something may be wonky in the plugin install :slight_smile:

    If the issue is no longer present, reactivate your theme. Does the issue re-appear? If yes, likely theme conflict.

    If the issue still does not re-appear, re-activate plugins one by one until it does and you find the conflicting plugin.

    Once we've zeroed in on whatever may be the cause of your issue, we'll be better equipped to deal with it.

  • bloggersdelight
    • Site Builder, Child of Zeus

    hmm i never wrote "the process works just fine behind the scenes, but confirmation on the front-end has been sluggish in the last week." in my ticket ?

    att: JosephLee1179

    Which plugin did you deactive to solve the issue ? The theme we have has not changed.

    - Tonny

  • bloggersdelight
    • Site Builder, Child of Zeus

    we have now tried to switch to twenty eleven theme and disable almost all the plugins (the lasts ones cannot be disabled as this will break the site). Still we se issues with subscriptions now going though.

    When initial payment is success full the page looks like this:

    http://cl.ly/image/2U42263P362X

    When it fails, the page looks like this:

    http://cl.ly/image/3E0x022Y070t

    When we test the initial payments i look in the log. And the IPN callback to our apache comes up to 1 minutte later than the actual payment... If this IPN callback is to confirm the payment in the return page then in not surprised it does not work. Seems thoose Instant Payment Notifications, are not really that instant :stuck_out_tongue:

  • Patrick
    • Support Monkey

    Hi @bloggersdelight

    I'm doing a bit of housekeeping by going through some older threads, and I noticed this one is still open.

    Just to get it out of our active ticket system, I'm going to mark it resolved.

    But if you still need assistance on this issue, please don't hesitate to re-open it by checking the "Mark as not resolved" box below.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.