New themes not displaying correctly

When attempting to use the new beta themes I'm getting display errors that seem to break the site, and the theme editing features don't seem to work. I have a more secure than normal hosting setup and I'm wondering if that's the problem, and what I need to do to fix it.

Also, installing these themes seems to have added a bunch of pages I need to delete now, perhaps a user prompt in the install process to toggle whether or not you want these pages added to your site.

  • Vinod Dalvi

    Hi @xInd ,

    I hope you are well today and thanks for posting on the forum.

    When attempting to use the new beta themes I'm getting display errors that seem to break the site, and the theme editing features don't seem to work. I have a more secure than normal hosting setup and I'm wondering if that's the problem, and what I need to do to fix it.

    I have tested the latest version of Scribe theme on my test site and it worked fine without any issue.

    Do you have WP_DEBUG set to true in your wp-config.php file?

    If you do then please set it to false.
    This will hide the error messages and you will be able to use your site normally.

    Try temporary deactivating all the plugins on your development site as displayed in the following flowchart to know which plugin is conflicting if any.

    https://premium.wpmudev.org/manuals/getting-support/

    Would you mind if I logged in to your site and did some troubleshooting? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings as described on the following page and reply on this thread after granting it?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Also, installing these themes seems to have added a bunch of pages I need to delete now, perhaps a user prompt in the install process to toggle whether or not you want these pages added to your site.

    I have notified the theme developer about it.

    Is there not supposed to be a theme options page on the dashboard menu after installing the theme?

    No there isn't the theme options, you can access the theme settings from the customize menu as displayed in the attached screenshot.

    Best Regards,
    Vinod Dalvi

  • xInd

    The customize link for these themes does not work on my websites. It just shows edit=true or similar in the URL and displays the front end with no options or anything to customize. It must be something with the hosting settings, permissions, or otherwise as it's the same on all my sites.
    I went to grant access for you but the wpmudev dashboard doesn't display on my sites' dashboards. What is the standard URL for the wpmudev dashboard? %siteUrl%/What-goes-here/ ?

  • Vinod Dalvi

    Hi @xInd ,

    Thank you for your reply.

    It must be something with the hosting settings, permissions, or otherwise as it's the same on all my sites.

    Have you tested it for plugin conflict by temporary deactivating the plugins as described in my previous reply?

    I went to grant access for you but the wpmudev dashboard doesn't display on my sites' dashboards. What is the standard URL for the wpmudev dashboard? %siteUrl%/What-goes-here/ ?

    The direct URLs for the WPMU DEV Dashboard Support Staff Access screen is as following.

    For WordPress single site:
    http://yoursite.com/wp-admin/admin.php?page=wpmudev-support&tab=access

    For WordPress multisite:
    http://yoursite.com/wp-admin/network/admin.php?page=wpmudev-support&tab=access

    After activating WPMU DEV Dashboard if the above URL is not accessible for you then you can simply put either of these constants in your wp-config.php file:

    define('WPMUDEV_LIMIT_TO_USER', '1');  // Replace the 1 in this code with your user ID

    Place either of these just above the following line:

    /* That's all, stop editing! Happy blogging. */

    Note: If you include additional users in the above define, they may need to activate the plugin to trigger the new permissions. To do so, they can simply log in, deactivate then immediately reactivate the plugin.

    Find more information about it on the following page.

    https://premium.wpmudev.org/project/wpmu-dev-dashboard/#usage

    Regards,
    Vinod Dalvi

  • Victor Ivanov

    Hi @xInd,

    I wanted to follow up to make sure you got this sorted after Vinod's last response to you.

    Are you still having problems? Have you tried clicking 'Upfront' button in your to admin bar? I think you might be running an older version of Upfront, when we haven't quite covered the 'Customize' route. The newer version of Upfront can be triggered by either of the 2 customize links or by clicking 'Upfront' in top bar.

    Thanks, Victor

  • xInd

    Thanks Victor!

    After fixing the hosting settings most things are working as intended. Still having a few minor issues now posted in other threads, and the odd blip where upfront just doesn't load properly. I also had to do a manual remove and reinstall of upfront via ftp due to the automated aspect not working. Pretty sure I missed one of the hosting settings so will fix that before I need to do another update.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.