New to Multisite..please help

I want to create a multisite to manage different demo sites. I have allowed multi sites and have created a test site. The problem is, the test site is pointing to my main site. Also, when I attempt to change theme by site, the main site theme changes as well. Multisite was installed on a fresh wordpress. I am not sure what to check for next.

  • Kasia Swiderska
    • Support nomad

    Hello LaToya Powell,

    What type of Multisite it is? Subdomain or subdirectories? I’m guessing its subdomains and redirect is because WildCards are not configured properly or you haven’t add right entries to your htaccess file.

    Wildcards https://codex.wordpress.org/Configuring_Wildcard_Subdomains (you might need to contact your hosting provider to check that)

    Right htaccess entries https://codex.wordpress.org/htaccess#Multisite

    Also, when I attempt to change theme by site, the main site theme changes as well.

    How do you change theme when test site is not working? You can change theme for subsite when its working and you can switch theme on its dashboard.

    kind regards,

    Kasia

  • LaToya
    • Flash Drive

    Subdirectory.

    Also, when I change the theme by site, I change it from the subsite. I noticed that when I attempt to access the test site dashboard, at the top next to the house icon, that doesn’t change to the test site. It will change to either the network admin or the primary site. Would it be easier if I used the subdomain route? I am missing a step somewhere.

    Here’s my configuration:

    wp-config.php

    /* Multisite */

    define( ‘WP_ALLOW_MULTISITE’, true );

    define(‘MULTISITE’, true);

    define(‘SUBDOMAIN_INSTALL’, false);

    define(‘DOMAIN_CURRENT_SITE’, ‘designedbydeni.com’:wink:;

    define(‘PATH_CURRENT_SITE’, ‘/’:wink:;

    define(‘SITE_ID_CURRENT_SITE’, 1);

    define(‘BLOG_ID_CURRENT_SITE’, 1);

    .htaccess

    RewriteOptions inherit

    RewriteEngine On

    RewriteBase /

    RewriteRule ^index.php$ – [L]

    # add a trailing slash to /wp-admin

    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]

    RewriteCond %{REQUEST_FILENAME} -d

    RewriteRule ^ – [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]

    RewriteRule . index.php [L]

  • Kasia Swiderska
    • Support nomad

    Hello LaToya,

    This is very weird that you can’t add that link :slight_frown: – lets do this differently. Could you please send in the following via our secure contact form https://premium.wpmudev.org/contact/ :

    – Mark to my attention, the subject line should contain only: ATTN: Kasia Swiderska

    – Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.

    – Link back to this thread

    – Include WordPress network admin access details (login address, username & password)

    – Include FTP log-in details (hostname, username & password)

    – Include any relevant URLs for your site

    IMPORTANT: Please make sure you select “I have a different question” for your topic, so it doesn’t go back to the forums – this and the subject line ensure that it gets assigned to me.

    Please confirm in thread that credentials were send

    kind regards,

    Kasia

  • Kasia Swiderska
    • Support nomad

    Hello LaToya,

    Everything was configured correctly on your site – you can now see that test sites I created wpmudev1, wpmudev2 and wpmudev3 are working fine.

    Issue was with mu plugins, I renamed that folder and crating sites started to working correctly. That folder contains some GoDaddy plugins so I would report that to your hosting provider that they prevent subsites from being created correctly.

    For now I’m leaving this as disabled so you can work on your multisite.

    kind regards,

    Kasia

  • LaToya
    • Flash Drive

    Thank you for correcting the issue for me.

    Now, when I create a new site or add myself to the sites you created, I am logged out and unable to log back into the main site using my password. I have reset the password a dozen times and still unable to access them. The email that comes when the site is being created provides the main username but the password is N/A.

  • LaToya
    • Flash Drive

    Something happened. I am no longer able to access new subsite dashboard again. I have disabled all plugins and themes to see if that resolved the issue but it did not. The only thing I have changed was mapping domains to specific subsites. Not sure what else I need to check for. The other subsites previously added are working as normal.

  • Kasia Swiderska
    • Support nomad

    Hello LaToya,

    You are not able to go to dashboard of new subsites because plugins from GoDaddy are activate again and they are breaking process of creating subsites.

    As I mentioned in my previous post that has to be reported to GoDaddy, that their cache plugin is breaking Multisite https://premium.wpmudev.org/forums/topic/new-to-multisiteplease-help#post-1203550

    To you would need again login to FTP and go to wp-content and there reaname the mu-plugins directory to disable that plugin

    that how it looks when its enabled

    only then you will be able to create proper subsites.

    kind regards,

    Kasia

  • LaToya
    • Flash Drive

    Thank you. I renamed it and spoke with Godaddy representative who stated that that plugin isn’t one of their plugins although it says Godaddy and comes from them smh. I know what to look for whenever I run into this issue again. Thank you so much for your help.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.