New to Upfront - Themes and Flash question

Hello,

I'm new to WordPress and just signed up for Upfront recently. I have some questions regarding the Upfront Builder.

1. Is there a way for delete/uninstall an Upfront theme from the dashboard? I installed a pre-made theme and would like to get rid of it so I can make one from scratch.
2. Can I create a theme on Upfront and download/upload it to another one of our sites without having to setup Upfront on it?
3. Is there a way to change how the menu looks like? Not just in terms of color or text. I would like to get rid of the small triangle pointer on those that have sub-menus.
4. Can I create a template page from Upfront builder? So I don't have to modify every single page on the site to have the same layout.
5. I have some flash files that I would like to upload and use on our site but it doesn't seem to load on Google Chrome, just Internet Explorer. But on our current website, it seems to be working perfectly on both browsers. Would you happen to know why that's the case? And is there a way to get it to work?

Thanks very much. Looking forward to hearing back from you.

  • Denitsa

    Hello Naz,
    I hope you are having an amazing day!

    1. Is there a way for delete/uninstall an Upfront theme from the dashboard? I installed a pre-made theme and would like to get rid of it so I can make one from scratch.

    You can build Upfront themes from scratch with the Upfront Builder. You need to go to Upfront -> Builder, type a name for your new theme and hit the Start Building button.

    2. Can I create a theme on Upfront and download/upload it to another one of our sites without having to setup Upfront on it?

    You don't need to install the Upfront Builder, however, Upfront is required for the themes made with it to work properly, as they function like child themes to a parent Upfront theme.

    That's why when you choose a theme from the WPMU DEV Dashboard -> Themes (like Fixer, or example) and install it on a fresh site, there's an Upfront menu added automatically to the WP Dashboard.

    3. Is there a way to change how the menu looks like? Not just in terms of color or text. I would like to get rid of the small triangle pointer on those that have sub-menus.

    Yes, this should be doable by adding some custom CSS to your theme. If you want to do that in Builder for your theme in general, then you need to choose Settings for your menu, open Appearance and choose Edit Preset CSS, then enter your CSS rules in the text area that appears at bottom part of the screen.

    If you're unsure about what CSS to use, can you provide a link with the menu in question, so I'd be able to give you the exact snippet that does what you'd like?

    4. I have some flash files that I would like to upload and use on our site but it doesn't seem to load on Google Chrome, just Internet Explorer. But on our current website, it seems to be working perfectly on both browsers. Would you happen to know why that's the case? And is there a way to get it to work?

    Can you please provide a link where I could see the issue in action and make some tests? What do you use to put those on the page and do you see any error when trying to load that in Chrome?

    Looking forward to hearing back!

    Warm regards,
    Denitsa

  • Denitsa

    Just forgot to mention here, when you download your newly made theme from the Upfront -> Builder like here

    and you want to deploy that on another website that does not have the Upfront installed, you will get the following screen, prompting you to install Upfront:

    When you click on the Install Upfront (Required) link, you'll get a screen like this one and Upfront will be installed on the new site.

    Cheers,
    Denitsa

  • Naz

    Hi Denitsa,

    Thanks very much for your help and sorry for the late response. I wanted to add a little more content to the site to see how the theme looks with it. Your suggestions helped resolve most of my questions! About the flash files, I used the Anywhere Flash Embed plugin. The link to the page that I'm working on is http://test.sterlingamericanproperty.com/. And the current site is http://sterlingamerican.com. The idea was to re-create the current site to a WordPress website so I'm trying to copy as much of the format as I can.

    On another matter, I seem to have 3 new issues now.

    1. All photos are not showing up on the sites. I've tried different browsers and even on mobile, but no luck. I can see the photos on the Upfront Builder and have even tried re-adding them several times.
    2. I also noticed that the site is loading a lot slower than normal. Compared to our current site, this one takes 5-10 seconds more to load per page. And that's without the photos showing. Is it normal for Upfront Themes to take long to load? I've even added the WP Super Cache plugin to see if it will fix it but even thought it did make it slightly better, it still feels slower than normal.
    3. I'm trying to add a sidebar menu that corresponds to the main menu it falls under. Like for instance, if someone clicks on the Company Overview, they would see the whole Company menu on the left side of the screen. I have the pages categorized so I can put a condition on what menu shows depending on what page the user is on, but none of that is showing on the page.

    Thanks again! Have a good day.

  • Denitsa

    Hey there Naz,

    Sadly, your links won't load for me, so I can't see the site or the flash :slight_frown: Are you experiencing some downtime currently?

    1. All photos are not showing up on the sites. I've tried different browsers and even on mobile, but no luck. I can see the photos on the Upfront Builder and have even tried re-adding them several times.

    That seems rather strange. Can you try adding photos to posts the usual way (Posts -> Add new -> Add Media and then select an image and Insert Into Post) and see if this works?

    You might also try adding image via the Upfront Editor - that's accessible either by the Upfront menu item in the top admin bar or by going to Appearance -> Customize.

    2. I also noticed that the site is loading a lot slower than normal. Compared to our current site, this one takes 5-10 seconds more to load per page. And that's without the photos showing. Is it normal for Upfront Themes to take long to load? I've even added the WP Super Cache plugin to see if it will fix it but even thought it did make it slightly better, it still feels slower than normal.

    Unfortunately, it's normal to experience some slowing down when using Upfront or any other visual page editor for WordPress - it's much like trading some performance for the convenience of using its various features. Upfront in particular loads the header, footer and entire content of the page directly from the database, which makes it a bit heavier on the system. You can also try our Hummingbird plugin along with the WP Smush Pro in order to further optimize your site.

    I'll be able to help you with your other questions as soon as I can see the site live! If you are experiencing some unknown server issues, contacting your host might be the fastest solution.

    Keep us posted!

    Regards,
    Denitsa

  • Naz

    Hi again!

    That's odd. The site is up, although slow to load. Would you mind trying it again? Link is http://031557a.netsolhost.com/sterlingamerican/company/elements-of-success/ and the current on is http://sterlingamerican.com/company.php?id=57.

    I got the photos working again. I had to update the page template with the new header/footer image and that seemed to have fixed it. I'll give Smush Pro and Hummingbird a try, thanks for the advice!

  • Sajid

    Hello Naz :slight_smile:

    Your site is now loading for me. The flash is working on your old site. But it seems you have replaced flash with an image on your Upfront site.

    I am talking about this page to be specific:
    http://031557a.netsolhost.com/sterlingamerican/company/elements-of-success/

    Do you still need help with flash issue ? If yes then on what page of Upfront powered site you are using it ?

    Please enable support staff access so I could take a closer look.

    To grant access go to Dashboard -> WPMU DEV -> Support -> Support Access -> Grant Support Access or see this manual for more details regarding how to enable support staff access.

    Also in future, for fast and efficient support experience, please create separate support ticket for each question according to our forum posting rules. This will be a lot easier for staff to manage the tickets and chime into an existing thread. This also helps other members of community find an answer quickly without digging the whole thread with other irrelevant questions.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

  • Naz

    Hi Sajid

    I placed a temporary image on the page while I was working on the flash just to have something in place. After playing around with it this morning, I think I finally did it! At least, I got one out of the two flash pages figured out. The second one is a little more complicated because it has a script. I added uploaded the swf file and I think I did the parameters correctly...however it's not loading at all. If you could take a look and let me know what I did wrong/missed, I'd really appreciate it. I enabled the Support Access on WPMU Dev. :slight_smile:

    The url is https://031557a.netsolhost.com/sterlingamerican/acquisitions/assets-by-state/. The current one is http://sterlingamerican.com/acquisitions.php?id=61.

    On another matter, I think I may need help on creating a responsive menu as well. But I'll create a separate support ticket when I cross that bridge.

    Thanks for all your help!

  • Nastia

    Hello Naz , hope you are doing well!

    Would you please compress and upload here the flash script with all the files it needs to lead so we could have a closer look at it?

    On another matter, I think I may need help on creating a responsive menu as well. But I'll create a separate support ticket when I cross that bridge.

    By default, the menu added in Upfront is already responsive. The Menu's settings can be changed, in Upfront Responsive view.

    Click on "Responsive" button, in Upfront Edit mode:

    Open the menu's settings and play with the Appearance options:

    Hope this helps!

    Cheers,
    Nastia

  • Naz

    Hi Nastia,

    Sure, no problem. I've attached the flash file and script...At least I think this all there is. I wasn't the original developer of our current site so I'm not sure if there's more to the script than the xml file. To be honest, I'm pretty much a novice in web designing. My experience in it is limited to what I learned in college 10 years ago. :sweat_smile: Just thought I'd give it a try to convert out current site to a WordPress since we've been told by our host to update it.

    On another matter, I think I may need help on creating a responsive menu as well. But I'll create a separate support ticket when I cross that bridge.

    I'm sorry I should have been more specific...what I meant by "responsive menu" was the fact that the navigation menu seems to move depending on the resolution of the screen. For example, at my work desktop, I'm using 1280x1024 and the menu aligns nicely. But my laptop is set to 1920x1080, and the menu is riding slightly higher than what it should be and the logo looks too stretched on the higher resolutions. Here are some screenshots of how it looks.


    Is there a way to make it more "universal"? I'm using the padding properties to align it. I'm guessing I'm either missing or doing something wrong.

    Thanks for all your help!

    Edit: I can't seem to upload a zip file here. I could upload it elsewhere but not sure if that's allowed here. I also have Support Access enabled on my site, if that helps.

  • Denitsa

    Hello Naz,

    It's absolutely fine to upload your files somewhere else (like Dropbox, etc) and provide us with the link here, please do so :slight_smile:

    As for the menu, setting different padding for different screen sizes should do the trick, however it's behaving in a very strange way for me, menu items are moving along with the page, do you have any code or plugin perhaps that's targeting that on purpose? You can see what I mean in this screencast.

    Cheers,
    Denitsa

  • Naz

    Hi again @slavchevadenitsap!

    Here's the link to the flash files and script: https://www.dropbox.com/s/683uc8lupqevrc3/MapGui.zip?dl=0. I'm not 100% sure if that's everything but please feel free to let me know if you need further info.

    As for the menu, that's odd how it moved like that...I've never seen it act like that before. Not sure if it helps but here's the CSS code I have for the menu.

    [data-style='horizontal'] ul.menu, div[data-style='vertical'] ul.menu {
        padding-top: 7%;
        text-transform: uppercase;
    }
    [data-style='horizontal'] ul.sub-menu > li.menu-item > a, div[data-style='vertical'] ul.sub-menu > li.menu-item > a {
        background: #123771;
        text-align: left;
        width: 150px;
    }

    Aside from that, the only other CSS code I have on the site is for the footer, so there would be no white space at the bottom regardless of the page content. Here's the code.

    .upfront-region-container-footer {
        position: absolute;
        bottom: 0;
        left: 0;
        right: 0;
    }

    As for the menu, setting different padding for different screen sizes should do the trick

    Unfortunately I'm not sure how to do this...Would you be able to show me what I need to code in CSS to create different paddings for different screen sizes?

    Thanks again!

  • Sajid

    Hello Naz,
    Hope you are doing good today :slight_smile:

    Thanks for sharing the swf flash files but unfortunately none of those worked for me. I tested a sample one and it worked for me by adding following code in code element of Upfront.

    So there are two options for you to embed a flash file on a WordPress and Upfront site. One using the Code element of Upfront and another using the plugin.

    Upfront Code element:
    1. Launch Upfront editor.

    2. Drag the code element on page where you want this to be displayed.

    3. Click on Write Custom Code.

    4. Select HTML tab in settings panel.

    5. Add following code in it by replacing the existing paragraph.

    <object id="flashcontent" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="550px" height="400px">
      <param name="movie" value="http://www.swftools.org/flash/Matrix.swf">
    
      <!--[if !IE]>-->
      <object type="application/x-shockwave-flash" data="http://www.swftools.org/flash/Matrix.swf" width="550px" height="400px">
      <!--<![endif]-->
    
        <p>
          Fallback or 'alternate' content goes here.
          This content will only be visible if the SWF fails to load.
        </p>
    
      <!--[if !IE]>-->
      </object>
      <!--<![endif]-->
    
    </object>

    6. Upload your SWF file from WP Dashboard -> Media -> Add New.

    7. Copy the full link to this file (edit this item and look for File URL:slight_smile:.

    8. Replace http://www.swftools.org/flash/Matrix.swf with your own file in the code provided in step 4 (two instances).

    9. Save changes and you are done!

    Alternatively, you can also use the Kimili Flash Embed plugin to embed flash. You can use the shortcode any where on Upfront page using Text element.

    I tested with both methods and it worked fine for me.

    Unfortunately I'm not sure how to do this...Would you be able to show me what I need to code in CSS to create different paddings for different screen sizes?

    You don't need to code in order to adjust layout and items for different screen sizes (yeah - its Upfront :smiley:slight_smile:.

    To do this follow the steps below:

    1. Of course launch Upfront editor.

    2. Click on Responsive button in left Upfront control panel.

    3. Select breakpoint/screen size.

    4. Select the item you need adjust padding of.

    5. Click on Adjust Padding icon beside cog/settings icon and adjust the paddings here.

    I also recorded the screencast for you that you can see below (please click to enlarge and see the animation).

    For future reference, please always create a separate support ticket according to our forum posting rules and a fast support experience. This also helps us manage and respond on each issue easily and quickly.

    Best Regards,
    Sajid - WPMU DEV Support

  • Naz

    Hi Sajid

    My apologies for not responding sooner. It's been a hectic week at the office so I had to pause this little side project for awhile. I just tried the 2 methods you mentioned and both didn't seem to work. :slight_frown: I also tried using the Anywhere Flash Embed, with no luck.

    This is the code I used on the Upfront code element

    <object id="flashcontent" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="550px" height="400px">
      <param name="movie" value="http://031557a.netsolhost.com/sterlingamerican/wp-content/swf/MapGUI_Lite_v1.3_USA_sans.swf">
    
      <!--[if !IE]>-->
      <object type="application/x-shockwave-flash" data="http://031557a.netsolhost.com/sterlingamerican/wp-content/swf/MapGUI_Lite_v1.3_USA_sans.swf" width="550px" height="400px">
      <!--<![endif]-->
    
        <p>
          Fallback or 'alternate' content goes here.
          This content will only be visible if the SWF fails to load.
        </p>
    
      <!--[if !IE]>-->
      </object>
      <!--<![endif]-->
    
    </object>

    All it displayed was the message "Fallback or 'alternate' content goes here." Would you mind at all if you could check out the page when you are free? I don't mean to impose. I feel like I'm just doing something wrong, especially if you were able to get it to work on your end. I can enable the Support Access again whenever you have time.

    As for the layout on different screen sizes, I've checked out the Responsive layout and all I could see was the Default, Tablet and Mobile. I haven't even really ventured on how it would look on mobile devices yet. My current issue is the way the top main menu shows across different desktop screen sizes. It looks different if my screen is on 1280x1024, 1600x1200, and 1920x1080. I have the header set to 100% wide Region style. Not sure if that matters. I have the menu aligned center, but that only takes care of the horizontal position. For the vertical position, I've tried using padding but I still can't seem to consistently get it to align properly on different screen resolutions. Is there a way for me to get the menu in a 'fixed' position? And have the header image occupy the whole top screen.

    Thanks again for all your help!

  • Adam Czajczyk

    Hello Naz,

    I hope you're well today and don't mind me jumping in!

    If that message shows up, that means that the flash file was not loaded successfully. This can be caused by a number of reasons: a broken file, a file name that prevents server from serving it (on some servers a file name cannot contain spaces and special/national characters) or that the file is blocked.

    The latter usually is the case of:
    - server configuration that doesn't allow serving this files directly (extremely rare case)
    - some firewall tool on server or plugin on your WP
    - some security/optimization settings/plugin that e.g. prevent direct access to files

    However, I'm not quite sure to which of your sites/pages are you referring to. I found two URL's that you posted earlier in this thread and on this one:

    http://sterlingamerican.com/acquisitions.php?id=61

    flash is working for me fine (it asks first to enable Flash and then shows an interactive map)

    while on this one

    https://031557a.netsolhost.com/sterlingamerican/acquisitions/assets-by-state/

    I'm not given any option to see flash content and there's no "Fallback" message for me.

    Is this the page I should check? Could you also please re-grant support access to the site with the page in question so I could take yet another closer look?

    As for the layout on different screen sizes, I've checked out the Responsive layout and all I could see was the Default, Tablet and Mobile. I haven't even really ventured on how it would look on mobile devices yet. My current issue is the way the top main menu shows across different desktop screen sizes. It looks different if my screen is on 1280x1024, 1600x1200, and 1920x1080.

    Upfront includes three "breakpoints": mobile, tablet and desktop. In case of resolutions that you mentioned here, a "desktop" layout is the one that's used. Please note however that while Upfront is responsive, it's also based on the grid where the maximum container width is set to 1080px so for any horizontal resolution higher than this it will use 1080px width and center container on the screen. That is, except regions that are set to "full width" - their background will be applied to full width but still, modules inside (e.g. Text, Image etc) will be enclosed within that maximum width.

    I have the menu aligned center, but that only takes care of the horizontal position. For the vertical position, I've tried using padding but I still can't seem to consistently get it to align properly on different screen resolutions.

    That's actually more of a HTML/CSS/browser issue rather than Upfront. In CSS "align" attribute centers horizontally. Usually, the vertical position can be adjusted using padding but please note that while you can set different padding for "mobile", "tablet" and "desktop" mode, for resolutions that you mention in your post, the "desktop" settings will be applied.

    You could further adjust those paddings for your resolutions with some custom CSS by using media queries. Take a look here please:

    https://www.w3schools.com/cssref/css3_pr_mediaquery.asp

    Is there a way for me to get the menu in a 'fixed' position? And have the header image occupy the whole top screen.

    Yes, when editing a region (the one that you use for header, holding a menu) set it to "sticky" and it will "stick" to the top of the site.

    Kind regards,
    Adam

  • Naz

    Hi Adam Czajczyk

    My apologies for not responding back sooner. I didn't realize there was an update on this post and it's been really hectic at the office so I haven't been doing much on the site. I don't mind at all you jumping in! I appreciate all the help.

    The pages I'm referring to are the ones below...
    The current site with the flash working is --> http://sterlingamerican.com/acquisitions.php?id=61

    The one I'm currently working on where the flash is not loading properly -> https://031557a.netsolhost.com/sterlingamerican/acquisitions/assets-by-state/

    I've uploaded the script with the flash files @ Dropbox -> https://www.dropbox.com/s/683uc8lupqevrc3/MapGui.zip?dl=0

    You probably didn't see the Fallback message because I've accidentally deleted the code when I was in between trying different plugins to see if any would help. I've just re-added it back in the same way that Sajid has recommended. I'm pretty sure I'm just doing something wrong...:slight_frown:

    I've also re-enabled the Support Access. Please feel free to check it out whenever you have some availability. Thanks in advance!

    As for the layout screens...I finally got it all sorted. I had the header image set to auto resize so it kept changing how it looks, and that's why the menu looks like it kept moving. Once I changed the image to a fixed position, the menus looks correct regardless of the screen resolution. I can't believe the 'fix' was that simple. It seems more of a novice-user-mistake. :sweat_smile:

    If you don't mind me asking here instead of creating a new ticket....is there a way to remove the little arrow icon on menus with sub-menus? And making the sub-menus appear directly below without having to click on it first?

    Like for example, the image below is how the menu on our current site is...

    On the site I'm working on, it shows up as this...

    If I wanted to recreate how that behaves, is there a way through CSS to enable that?

    Thanks for all the help!

  • Sajid

    Hello Naz,
    Hope you are doing good today :slight_smile:

    Thanks for enabling support staff access. I tried to upload the demo .swf file on your site but I got following error while uploading it.

    “Matrix.swf” has failed to upload.
    Sorry, this file type is not permitted for security reasons.

    That means, the swf files are blocked on your server or in WordPress.

    If it is WordPress level then we can enable SWF files by adding following code in functions.php file of your theme or use it as mu-plugin.

    /* allow upload flash */
    add_filter('upload_mimes', 'pixert_upload_swf');
    function pixert_upload_swf($existing_mimes){
    $existing_mimes['swf'] = 'text/swf'; //allow swf files
    return $existing_mimes;
    }
    /* allow upload flash */

    If you go with mu-plugin route then, go to your /wp-content/ folder via FTP, and find the folder called "mu-plugins". If there is no folder with that name, then you'll want to create one. Then, create a file inside that folder, and give the file any name you like and paste the code in there.

    You don't need to activate that plugin, as it will be always be automatically activated. Please be sure to add a PHP start tag at the beginning of the code if you insert this code as a mu-plugin, like this:

    <?php

    In addition to above, the file you are trying to use seems to be broken to me. I could not use it on my own site. So please see following screenshot for comparison.

    So after adding the code above to allow uploading SWF files. Make sure the file you are using is not corrupt.

    Regarding the other issues, I would strongly recommend you starting new thread for further assistance. Most chances are you will get this resolved quickly on live chat (yeah - our new support system that is going pretty great so far). Since we have already came so far on this ticket that is making it difficult to understand the real issue we dealing with.

    Best Regards,
    Sajid - WPMU DEV Support

  • Naz

    Hi Sajid

    Thanks for checking this for me! The "reading data..." message is exactly what I get as well when I try to load the SWF file as well. I thought I was just doing something wrong and that's why I couldn't get it to work. There's another page in the site that has another SWF file and that one works fine. It's this page -> Elements of Success. The only difference between them is the one working doesn't have a script. The SWF file with the script seems to be working perfectly in the current site though. Maybe I just missed something when I copied over the files? I'll take another look tomorrow just to make sure.

    And sure, will create a separate thread regarding the other issue. Sorry about that. I'll definitely try the live chat tomorrow if possible.

    Thanks again for all your time and help!

  • Naz

    Hi Sajid

    Hope you're doing well. I just re-uploaded the SWF file and script for the map that I got off the current site. It looks to be loading fine for me now if I go to the direct link but still not working on the webpage where I need it to go. I've tried using the two methods you suggested before.

    The first one is using the coding below...

    <object id="flashcontent" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="850px" height="600px">
      <param name="movie" value="https://031557a.netsolhost.com/sterlingamerican/wp-content/swf/MapGUI_Lite_v1.3_USA_sans.swf">
    
      <!--[if !IE]>-->
      <object type="application/x-shockwave-flash" data="https://031557a.netsolhost.com/sterlingamerican/wp-content/swf/MapGUI_Lite_v1.3_USA_sans.swf" width="850px" height="600px">
      <!--<![endif]-->
    
        <p>
          Fallback or 'alternate' content goes here.
          This content will only be visible if the SWF fails to load.
        </p>
    
      <!--[if !IE]>-->
      </object>
      <!--<![endif]-->
    
    </object>

    The second method I've tried is the Kimili Flash Embed. This is how it looks...

    [kml_flashembed publishmethod="static" fversion="8.0.0" movie="https://031557a.netsolhost.com/sterlingamerican/wp-content/swf/MapGUI_Lite_v1.3_USA_sans.swf" width="850" height="600" targetclass="flashmovie" play="true" wmode="direct" allowscriptaccess="always"/]

    I realized that I forgot to grab the script before :tired_face: I've re-uploaded the script + SWF file on Dropbox if you'd like to take a look.

    https://www.dropbox.com/s/n43kswdnqtmgpto/MapGuiNew.zip?dl=0

    Thanks!

  • Adam Czajczyk

    Hello Naz!

    Thank you for your replay.

    I have downloaded both your code and your theme (from your site) in order to test it and I noticed that on my end it worked "out of the box". Then I realized that it does work but in Firefox browser only and not in Chrome (so probably in Safari the case would be similar). I was experimenting with Kimili Flash Embed and I found out that under Chrome for some reason it doesn't show "Activate Flash" prompt (which is pretty standard for Chrome).

    I then used the other method which is quite simple and is actually "core WP" and put this code on your site:

    <embed type="application/x-shockwave-flash" width="900px" height="550px" src="https://031557a.netsolhost.com/sterlingamerican/wp-content/swf/se_success.swf" wmode="transparent"></embed>

    That worked on your site "out of the box" and on Chrome it asked me - as expected - if I want to activate flash. Once I agreed, it worked.

    I have removed that code for now but if you replace your Kimili shortcode on the page with that code, update the page, clear browser cache and check it, it should show Flash content in Firefox and in Chrome it should ask you to "Activate Flash" and would work fine after that.

    Give it a try please and let me know if it helped :slight_smile:

    Best regards,
    Adam

  • Naz

    Hi Adam Czajczyk

    I think you may have gotten the two .SWF files I have on my site confused :upside_down:. The one you mentioned above is for this page -> Elements of Success. That's been working okay. The one I'm having problems with is the one with the map on this page -> Assets by State. The .SWF file for that is -> https://031557a.netsolhost.com/sterlingamerican/wp-content/swf/MapGUI_Lite_v1.3_USA_sans.swf. There's an .xml and .php file that goes with it. I've uploaded it on Dropbox if you want to check it out -> https://www.dropbox.com/s/n43kswdnqtmgpto/MapGuiNew.zip?dl=0.

    Sorry for the confusion. This thing has me baffled. :confused:

    P.S. I've contacted Live Support the other day for help regarding this issue and Ken made a support thread when he couldn't make heads or tails of it too. Here's a link to the new thread. Not sure if it's better to consolidate these two threads or something...Hope I'm not causing unnecessary work for a lot of people.

  • Adam Czajczyk

    Hello, Naz!

    It seems I might have gotten confused indeed, I'm sorry about that. I visited the Assets by State page and I see it's not loading. I see some errors in the console there too.

    I tried to access your site again to check it but it looks like support access that you granted has already expired. Could you please grant it again for me?

    If "WPMU DEV -> Support" page says that it's still granted, please revoke it and enable again. Let me know here when it's done :slight_smile:

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Naz!

    Thanks for enabling access again. I see that you're using this code in page content to fetch the SWF file:

    <embed src="https://031557a.netsolhost.com/sterlingamerican/wp-content/swf/MapGUI_Lite_v1.3_USA_sans.swf" type="application/x-shockwave-flash" width="900px" height="550px"></embed>

    This seems to be working but in a browser console, I see that there's an attempt to load that associated XML file and it fails. I have performed some tests on my end and I made it work there.

    The issue is that the SWF file is looking for two XML files but it's trying to fetch them from an exact URL of where the SWF file is located. In this case, that means the URL of the page it's on. That is, of course, impossible so it fails and the animation (that interactive map) is not executed.

    The solution is a bit tricky but it works on my end:

    1. The SWF file used on this page is located in "/wp-content/swf/" folder, so please upload also following files associated with this map to the same folder:

    mapgui_lite_usa_constants.xml
    mapgui_lite_usa_data.xml

    2. Edit .htaccess file of your site and you should seethese lines there:

    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    replace them with these:

    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    
    Redirect 301 /acquisitions/assets-by-state/mapgui_lite_usa_constants.xml /wp-content/swf/mapgui_lite_usa_constants.xml
    Redirect 301 /acquisitions/assets-by-state/mapgui_lite_usa_data.xml /wp-content/swf/mapgui_lite_usa_data.xml 
    
    </IfModule>

    If I didn't make any mistake in paths above, that should solve the issue. In case it still didn't work, let me know and we'll try to correct these paths.

    Best regards,
    Adam

  • Naz

    Hi Adam Czajczyk

    Thanks for checking! Still doesn't seem to be working on my end though :slight_frown: This is how my .htaccess file looks like after I made the changes you suggested.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /sterlingamerican/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /sterlingamerican/index.php [L]
    
    Redirect 301 /acquisitions/assets-by-state/mapgui_lite_usa_constants.xml /wp-content/swf/mapgui_lite_usa_constants.xml
    Redirect 301 /acquisitions/assets-by-state/mapgui_lite_usa_data.xml /wp-content/swf/mapgui_lite_usa_data.xml 
    
    </IfModule>

    I've also double checked that both .xml file and .swf file are on the same folder.

    Did I miss anything?

    P.S. I've also tried adding "/sterlingamerican/" in front of the "wp-content/swf..." path but that didn't seem to work either.

  • Adam Czajczyk

    Hello Naz!

    I apologize for the delay. I must say I'm not sure why it doesn't work for you but I'd like to check it. A support access wouldn't be enough though and I would need to access your site directly.

    That said, please send in:

    send in:

    Subject: "Attn: Adam Czajczyk"

    - Mark to my attention, the subject line should contain only: ATTN: Adam Czajczyk
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - login URL and admin account login credentials (may be a temporary admin account) data
    - Include FTP log-in details (hostname, username & password)
    - Include hosting control panel access details (login address, username & password) - cPanel's usually the control panel used for this, but your provider may use something else; I'll need this for accessing your site's database, preferably via phpMyAdmin
    - Include any relevant URLs for your site

    Please use our contact form here https://premium.wpmudev.org/contact/#i-have-a-different-question

    Best regards,
    Adam

  • Adam Czajczyk

    Hello, Naz!

    I received your message and checked the site. It seems that on your server it's not enough that the "RewriteBase" rule is pointing to the /sterlingamerican/ sub-folder and those two 301 rules are "dropping it".

    I noticed that these lines weren't in the .htaccess file anyway so I added them with a small change:

    Redirect 301 /sterlingamerican/acquisitions/assets-by-state/mapgui_lite_usa_constants.xml /sterlingamerican/wp-content/swf/mapgui_lite_usa_constants.xml
    Redirect 301 /sterlingamerican/acquisitions/assets-by-state/mapgui_lite_usa_data.xml /sterlingamerican/wp-content/swf/mapgui_lite_usa_data.xml

    It seems to be working now. Can you please check and let me know?

    Best regards,
    Adam

  • Adam Czajczyk

    Hello again,

    just a quick update :slight_smile:

    After I wrote that post above, I checked again in Firefox and noticed that while in Chrome that solution works, in Firefox it "nearly" works: it finds those missing resources but doesn't load them because of SSL (mixed content).

    Therefore I tweaked aforementioned rules a bit more and now it seems to be working nicely in Chrome and Firefox so it should also be working in other browsers. Current rules are:

    Redirect 301 /sterlingamerican/acquisitions/assets-by-state/mapgui_lite_usa_constants.xml https://031557a.netsolhost.com/sterlingamerican/wp-content/swf/mapgui_lite_usa_constants.xml
    Redirect 301 /sterlingamerican/acquisitions/assets-by-state/mapgui_lite_usa_data.xml https://031557a.netsolhost.com/sterlingamerican/wp-content/swf/mapgui_lite_usa_data.xml

    As you see, the "redirected part" now includes the /sterlingamerican/ path part in front and "redirect target" includes entire URL of resource.

    Best regards,
    Adam

  • Naz

    Hi again Adam Czajczyk

    I forgot to ask...if I needed to edit the RewriteBase rule to point to a different URL, where would I do that? I checked the .htaccess file and didn't see it on there. I figured it's better if I ask instead of just randomly making changes. The site is now live so I have to change the path going to sterlingamerican.com. I believe the correct line would be...

    Redirect 301 /sterlingamerican/acquisitions/assets-by-state/mapgui_lite_usa_constants.xml http://sterlingamerican.com/wp-content/swf/mapgui_lite_usa_constants.xml
    Redirect 301 /sterlingamerican/acquisitions/assets-by-state/mapgui_lite_usa_data.xml http://sterlingamerican.com/wp-content/swf/mapgui_lite_usa_data.xml

    Thanks again!

  • Adam Czajczyk

    Hello Naz!

    Unless you make some changes the lines should be in .htaccess file in the root folder of you site (the same where "wp-admin" and "wp-content" folders are).

    Assuming that you did not make any changes except changing the domain, I think you're right. I mean: the "second part" of each line - an URL - would be correct. I'm not sure about the first part but just start with the change that you suggested and see if it works. If not, drop me a line and I'll check it again.

    Best regards,
    Adam

  • Naz

    Hi Adam!

    I just tried adding those two redirect lines to the .htaccess on my root folder but it didn't seem to do the trick :slight_frown:

    This is how I have it...

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    Redirect 301 /sterlingamerican/acquisitions/assets-by-state/mapgui_lite_usa_constants.xml http://sterlingamerican.com/wp-content/swf/mapgui_lite_usa_constants.xml
    Redirect 301 /sterlingamerican/acquisitions/assets-by-state/mapgui_lite_usa_data.xml http://sterlingamerican.com/wp-content/swf/mapgui_lite_usa_data.xml
    </IfModule>
    # END WordPress

    I've also tried removing the "/sterlingamerican" at the beginning of the first part and that didn't work either.

    The only changes I've made was update the WordPress and Site Address to http://sterlingamerican.com once I made the site live.

    I think I broke it :slight_frown:

  • Adam Czajczyk

    Helo Naz,

    thank you for your replay!

    I checked the site "from outside" again and I found out that there was one more change to be done. The .htaccess rules are fine but you didn't update the embed code in page content. It should be:

    <embed src="http://sterlingamerican.com/wp-content/swf/MapGUI_Lite_v1.3_USA_sans.swf" type="application/x-shockwave-flash" width="900px" height="550px"></embed>

    Notice that URL in "src" parameter now points to your new domain too. I have already changed that for you and it should be working fine :slight_smile:

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.