New User account access on Multisite

Concerning domain- http://blog.org.au/

I have activated Multisite. When I register as a user would the new site is created however I can not access my dashboard to use the new site.

Once user has registered site this email is sent & received by user

Dear User,

Your new Blog.org.au site has been successfully set up at:

http://blog.org.au/handfaster/

You can log in to the administrator account with the following information:

Username: handfaster

Password: willEmailToYouIfNeeded

Log in here: http://blog.org.au/handfaster/wp-login.php

We hope you enjoy your new site. Thanks!

–The Team @ Blog.org.au

However, when I follow link- http://blog.org.au/handfaster/wp-login.php

This message appears-

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Apache Server at blog.org.au Port 80

Odd to me that the site is actually created, it can be viewed here- http://blog.org.au/handfaster/

Forgive me I am using Godaddy unlimited hosting as it is what I can afford at the moment. My objective here is to simply Test Multisite, I am not concerned about a lot of users signing up.

Godaddy does not allow Subdomains on Multisite so it is set up as a path based directory, thus I have not activated * (wildcard) for what you see, however did a few days ago and * did not help with this issue.

Does anyone have the ability to help me though this, thank you in advance!