New user registration disabled but users have registered

We've decided to go in a different direction from our original plan and have decided to turn off new user registration. But somehow, a few people have managed to register as new users anyway!

I have clicked the "Registration is disabled" button. I have also listed several email domains in the banned list but this seems to do nothing as these users are also registering with one of the banned email domains.

I have clicked on all the links on the site that have to do with registering and I always get the "User registration is currently not allowed." message.

http://mySaveHereClub.com if you want to try.
Any ideas on how this could be happening?

  • aecnu
    • WP Unicorn

    Greetings TerryG,

    I have visited your site and tried to register very way I could think of and could not.

    I am wondering if you were/are using caching of your WordPress install?

    I went to Google and ran your domain - picked registration - then chose cached and it took me to a cached registration page. However, in this case registration did not complete even though it seemed like it was going to.

    Maybe this is how they were joining before you had it locked down.

    Please advise if using cache and/or registrations continue.

    Cheers, Joe

  • TerryG
    • Site Builder, Child of Zeus

    This is a multi-site. So in the main site Network Admin area > Settings > Network Settings. Scroll down a bit and you should see Banned Email Domains. I have put both domain names and IP addresses in but it doesn't seem to do anything because at least one of those domains are still able to register (somehow).

    This is too weird ...

  • aecnu
    • WP Unicorn

    Greetings TerryG,

    It does seem extremely weird and this section that is supposed to be blocking is part of the WordPress core - totally bizarre.

    In this section you would want to put the domain, IP will not help i.e. banneddomain.com

    Are these registrations happening on sub sites? Or just the main domain?

    It is almost time to call in the big guns and get our lead developers input in here.

    You have mentioned this is a MultiSite but also:

    WordPress 3.3.1?
    Buddy Press 1.5.5?

    Also is this on shared hosting, VPS, or Dedicated server?

    Please advise.

    Cheers, Joe

  • TerryG
    • Site Builder, Child of Zeus

    WordPress 3.3.1
    Buddy Press 1.5.5
    Not using bbpress other than what's built into Buddy Press.
    We are on a VPS.

    Haven't had any registrations in the last few days so maybe to cache clearing did the trick. It's just that along with the other things I mentioned, it was pretty weird.

    Thanks for the comments and confirmations. I'm gonna mark this as resolved for now.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.