New User Registrations Blocked by Password Setup Error

hello upon a long support request to upgrade to membership 2 which we successfully did since then new people who want to register as a new user and then purchase a membership are unable to register as a new user because it asks them to set and confirm a new password but the confirmation never works please advise asap thank you support access has been granted

  • Adam Czajczyk
    • Support Gorilla

    Hello Adrian,

    I hope you're well today and thank you for your question!

    I've checked your site and I can confirm the issue. The error message is given by JS validation script and I suppose that's the main culprit here. I tested this on my own sandbox with various plugins and themes active but unfortunately I do not have access to the same theme that you're using.

    That said, although the browser's console doesn't seem to throw any JS errors, it's very likely a JavaScript conflict issue or the theme (or other plugin) is somehow altering form markup, so validation script breaks.

    I understand that's the live site with a lot of active users but would it be possible for you to switch to Twenty Fifteen theme just for a moment, clear all possible caches (server, site, browser) and test the registration process in order to check if we can eliminate the theme itself?

    Or perhaps do you have any staging/dev site that's behaving the same way which I could access and safely run any necessary test (and/or implement changes)?

    Let me know please!

    Best regards,
    Adam

  • Adrian
    • The Crimson Coder

    OK ya you're right its a theme issue. Switching to 2016 wordpress theme fixed it. Is there a way for you to debug this issue, or do I just have to redesign the site on a new theme? Ill try using the updated Jupiter theme first, but if that doesnt work, are you able to debug and fix the problem?

  • Adrian
    • The Crimson Coder

    OK so we migrated latest version of live site to the dev server and updated Jupiter to latest version. Unfortunately, still having the password issue. I have granted support access - please advise if there is anything you can do. Not sure if related to jupiter or Membership 2 or something else.

  • Predrag Dubajic
    • Support

    Hi Adrian,

    I had a look at the Jupiter theme and the issues is within the login form that comes with the theme header, password field uses the same ID as membership and when membership form checks the field for correct password it also checks login form field thus causing the error.

    For now you can go to Theme Options > Header Toolbar and disable Show Login Form?
    field or check with the theme developers to change password field ID.
    I will see with our plugin developer if we can change the ID of the field in future so this doesn't happen again.

    Best regards,
    Predrag

  • Adam Czajczyk
    • Support Gorilla

    Hey Adrian,

    Thanks for letting us know that, it's great that you managed to make it work!

    I've already passed this information along with your solution to our developers and hopefully this will help them implement some kind of "patch" to the Membership 2 Pro that would eliminate the possibility of similar issues in future.

    Thanks for sharing this with us and Happy New Year!
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.