New Users Not Populating Correctly To Membersip Pro

Hello, I have recently had some issues with this site. I have updated many plugins and wordpress itself recently. Now it seems that newly created users in wordpress do show up in the membership list, but there is no option on the right hand side to add or drop their membership levels. I did not know if this was a setting that may have got lost in the updates or if there is a way to make the new users populate in both places and be editable.

I can grant access to the site if that would be easiest or I can provide screenshots if you prefer.

Thanks in advance,

Nick

  • Vinod Dalvi
    • WP Unicorn

    Hi Nick,

    Thanks for posting on the forum.

    I have tested it on my test site using latest version of Membership Pro plugin and WordPress, i could add & drop membership levels to them without any issue except for Super User which can see all protected content on the site.

    Could you please grant the support staff access on your site so that i can troubleshoot it?

    Kind Regards,

    Vinod Dalvi

  • Nick Simpson
    • The Incredible Code Injector

    Good morning @vinod Dalvi. Hope you are well and thank you for your response.

    I have granted access. If you look at page 6 of the members there is a handful of members that you cannot edit or change their membership status on the right side.

    It seems like any newly created account does not have this function. Feel free to create a new account to test or whatever you need to do there.

    Thanks for you help in advance,

    Nick

  • Vinod Dalvi
    • WP Unicorn

    Hi Nick,

    Thank you for granting the support staff access.

    I saw on your site that some users don't have options to add membership from admin area.

    I tried to troubleshoot it on your site by creating test user but i found you have not enabled registration and have not created any membership subscription on your site as displayed in the attached screenshots.

    Please advise.

    Regards,

    Vinod Dalvi

  • Nick Simpson
    • The Incredible Code Injector

    Hi Vinod, hope you are doing good and thank you for taking time to look into this for me.

    This site is being used as a company intranet. The employees are assigned a group level so they can access to the correct documents and information on the site. All accounts are being created by the site admin, not the users. So I have never turned on the public registration.

    In the past when Users were created on WordPress, they could be adjusted to the correct access level, but now the option to change their group is missing. This is only true of course of the newly added users.

    Is there a mechanism that creates member access as the WordpPress user account is created?

    It has been some time since I have used this as the client has been able to complete the updates on their end. I don’t know if there was another step involved, but they have not had issues doing so until recently.

  • Ash
    • WordPress Hacker

    Hello @nick Simpson

    I hope you are well today.

    I have logged in at your site and saw the issue. There is no option to add level for some users. The reason is you have selected those users as membership admin. If you go to Users > All Users, you will notice that those users have full membership access. As they have full membership access, they act as super admin. And to a super admin, you can’t add a level. I believe you have added the level first (or it’s auto assigned) and later you have granted them membership permission.

    Would you please revoke their permission and check if add link appears?

    Cheers

    Ash

  • Nick Simpson
    • The Incredible Code Injector

    Hello Ash, I think you are correct in some cases. However, the user called “delete” which was setup as a test does not have admin rights and I cannot add membership levels to this one either.

    If I create a new account, as a subscriber in wordpress, they show in the membership listing, but they populate without the ability to change their membership group.

  • Ash
    • WordPress Hacker

    Hello @nick Simpson

    I hope you are well today.

    In that case, you have to create subscription. For now, I have created one subscription “Employees” with “Employees” and then I could assign the subscription and level to the “delete” users. You can make all subscription private to hide from public users.

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers

    Ash

  • Patrick
    • Support Monkey

    Hey there @nick Simpson

    That’s excellent news!

    Thanks very much for confirming the issue resolved.

    I’m going to mark this thread resolved for now. But if you need more help on this issue, simply check the “Mark as not resolved” box below to re-open the ticket.

    Have a great day!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.