New WordPress users always receive the "admin" username

Hi, I have the WHMCS MU Provisioning plugin set up and everything works great except for one small thing. When a user is created in WordPress, the user's username is always "admin". On the plugin page, it says:

" If a user does not already exist on WordPress as determined by matching the WHMCS Clients email with the WordPress users email, a new user will be created using the WHMCS Client’s email address and the portion before the ‘@’ as the users name."

That means that the WordPress user's username should be taken from his/her email address correct? Is there some sort of configuration option I need to set for the plugin to set WordPress usernames up as the first part of the user's email address?

Thanks

  • PC
    • WPMU DEV Initiate

    Hello @dallas_bass4

    Greetings and thanks for posting on the forums.

    What is the default role of the user in the Module settings ?

    When a user is created in WordPress, the user's username is always "admin"

    I currently do not have a working test install of WHMCS so I am going to seek some support from our lead developer @Arnold on this one.

    Cheers, PC

  • Arnold
    • El Macho WP

    That's pretty weird because Wordpress itself should not allow duplicate User Names or email addresses. Which means it's probably for some reason assigning the existing admin.

    Try turning on the Module logging on WHMCS in Utilities > Logs > Module Log so we can get a look at what is being sent and received.

  • dallas_bass4
    • New Recruit

    Ok, I actually found out the problem and it was definitely my error. When I was testing the account creation I was using an email address that was already assigned the "admin" username and that's why I kept receiving the "admin" username. Thanks for the help though.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.