Newly added sub-domains are mapped to a blank page.

I am having an issue with adding new sites on a multisite install. I have numerous mapped sites to domains set up that are working but when I try to add a new site it goes to a blank page.
Wildcard subdomain is already created. HTACCESS have the correct rules. Not sure what I am missing?

  • Tyler Postle

    Hey JonA,

    I've been investigating this further and the issue does appear to be with the subdomain configuration. None of your subdomains work anymore. I do see that some of the mapped domains work but new ones aren't.

    I was unable to connect with your sFTP and passkey that you sent in too Luis, not sure if you changed anything there?

    With that said, having cPanel would be very helpful here anyway so we can look at your wildcard subdomain configuration. Would you be able to send in cPanel if you have it? or Plesk access? Depending which control panel your web host uses.

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    Send in:

    Subject: "Attn: Tyler Postle"
    -cPanel username
    -cPanel password
    -cPanel login url
    -link back to this thread for reference
    -any other relevant urls

    Look forward to hearing back and apologies for the delay on this one.

    Cheers,
    Tyler

  • JonA

    The sites are installed on Google Compute Engine and there is no cPanel or Plesk.
    I had installed the Wordpress Multisite instance using a Bitnami stack https://docs.bitnami.com/google/apps/wordpress-multisite/#how-to-add-several-wordpress-multisite-blogs-with-different-domains

    An additional step is needed to configure the different domains (when using SSL certificates) by adding a virtual host for each domain by editing the /opt/bitnami/apps/wordpress/conf/httpd-vhosts.conf file and adding a new virtual host for each new domain.

    <VirtualHost *:80>
    ServerName yourserverdomain.com
    ServerAlias *.yourserverdomain.com
    DocumentRoot "/opt/bitnami/apps/wordpress/htdocs"
    Include "/opt/bitnami/apps/wordpress/conf/httpd-app.conf"
    </VirtualHost>
    <VirtualHost *:443>
    ServerName yourserverdomain.com
    ServerAlias *.yourserverdomain.com
    DocumentRoot "/opt/bitnami/apps/wordpress/htdocs"
    SSLEngine on
    SSLCertificateFile "/opt/bitnami/apps/wordpress/conf/certs/new_server.crt"
    SSLCertificateKeyFile "/opt/bitnami/apps/wordpress/conf/certs/new_server.key"
    Include "/opt/bitnami/apps/wordpress/conf/httpd-app.conf"
    </VirtualHost>

    It worked before with setting up the individual sites but that was about 5 months ago and now that I am trying to add additional ones it does not seem to work the way it did in the past. Will dig into it further and see what I can figure out.