Newly installed Wordpress/marketpress: "Whoops, looks like you skipped a step!"

Hello,

I just installed WordPress and MarketPress to test out the store functions and I can't get past the order confirmation page. I get the error message:

"Whoops, looks like you skipped a step! Please go back and try again."

I am using Paypal express. The message appears after I login to paypal; then verify information; and enter my site's order confirmation page. Everything appears to be filled out properly.

This is newly installed WordPress site.
MarketPress in the only active plugin except WPMU DEV.
I've tried this on multipule machines (same error).
I've tried iexplorer and firefox
I am using the default theme "Twenty Eleven".
I've used both live and sandbox paypal accounts

All with the same error.

My site is http://www.white-elephants.com/
Please try it out and let me know your thoughts.

Thank you

  • aecnu
    • WP Unicorn

    Greetings Scosbo,

    Welcome to WPMU Dev!

    Thank you for this great question and a significant item to bring up.

    I am using Paypal express. The message appears after I login to paypal; then verify information; and enter my site's order confirmation page.

    Using PayPal live (PayPal sandbox is erratic at best), you got to your site, you pick the product and you are redirected to pay for the product.

    You pay for the product and then exactly what occurs please?

    Please advise.

    Cheers, Joe

  • Scosbo
    • WPMU DEV Initiate

    Ok. I entered a live paypal API.

    After clicking through they paypal payment pages, upon arriving back at my site to the "Confirm Your Purchase" page, below the shipping information is the pink box "Whoops, looks like you skipped a step! Please go back and try again."

    If I click the confirm button anyways (disregard the 'whoops'), I get a message,
    "There was a problem finalizing your purchase with PayPal. Please go back and try again."

    Your thoughts?

  • aecnu
    • WP Unicorn

    Greetings Scosbo,

    Thank you for the additional input, it is greatly appreciated.

    Have you set up PayPal IPN? It appears that when you returned to the site it had not received the paid IPN from PayPal.

    You can also see if the IPN was actually sent in the PayPal History.

    Please advise.

    Cheers, Joe

  • Scosbo
    • WPMU DEV Initiate

    Ah. I did not setup the IPN.

    What URL do I use?

    I tested a URL to test and tried to submit a payment again; got the same error message. I reviewed the IPN history at paypal, and there is 0 history. Thus, it doesn't appear that anything attempted to send. Is there something else I need to setup for paypal to send an IPN?

    I also spoke with paypal tech support and they said that the 3rd API call after payment was not occuring; thus, they thought the issue was my marketpress setup.

    Your thoughts?

  • aecnu
    • WP Unicorn

    Greetings Scosbo,

    Thank you for the update and additional info, every little bit helps when trying to troubleshoot from afar.

    Do you have the IPN enabled now?

    Use any URL, it is not important, just that one is set, so use the URL to your site :slight_smile:

    Please advise is IPN is now enabled.

    Cheers, Joe

  • Scosbo
    • WPMU DEV Initiate

    Hey Joe,

    I enabled IPN; it's on now, the URL is also set.

    I attempted another payment: same error message.

    I also attempted to disable IPN and again enable it: same result.

    Still not history in my IPN log on paypal, either.

    Your thoughts?

  • Scosbo
    • WPMU DEV Initiate

    pcm,

    I tried the setup explained in the 2nd to last post in the link, but I still received the same error message.

    Attached is my my php.ini.

    After I attempted to process a payment, I noticed the token in the php_sessions folder (which the links instructed to setup) with the shipment info.

    Still no IPNs in the paypal history

    Your thoughts?

  • Scosbo
    • WPMU DEV Initiate

    Joe,

    Thank you for your efforts.

    I updated the IPN URL in paypal (copied your link and pasted directly into the text box).

    I ran a test transaction and again the same error message came up. See attached.

    Paypal still shows 0 ipn history.

    Your thoughts?

  • aecnu
    • WP Unicorn

    Greetings Scosbo,

    Thank you for the additional input.

    It appears to me no PayPal IPN or anything because you are not making it to PayPal.

    You never see the screen for PayPal to take your money?

    At this point without getting log in information to your installation, I would say that there is something wrong with the PayPal credentials. Most likely a space at the end of them.

    If you cannot spot anything and you are sure that you have indeed triple checked the credentials, please send all relative super admin log in information to include URL and the URL to this ticket to me at: aecnu (at) incsub.com

    Please do not forget to put the URL to this ticket in the email as well:
    https://premium.wpmudev.org/forums/topic/newly-installed-wordpressmarketpress-whoops-looks-like-you-skipped-a-step

    Please advise.

    Cheers, Joe

  • Scosbo
    • WPMU DEV Initiate

    Joe,

    I sent you the login info.

    The paypal API credentials appear to be correct. I spoke with paypal support and they said that the first 2 API calls work. It's the 3rd call that has the issue.

    When I run through a test purchase, I am routed through the paypal express pages; then back to my website to process the final confirmation. The error shows on this final page.

    Let me know what you find.

    Thanks for the continued support.

  • aecnu
    • WP Unicorn

    Greetings Scosbo,

    Thank you for the log in information, but this site has much bigger problems then this.

    When I tried the admin right now it just went into an endless loop and the front end is slower then molasses on a cold winter day.

    In addition, when I seen how slow it was I ran a trace route and found that once again BlueHost is the one causing the issue or minimum they are responsible for the issue:

    http://www.google.com/#q=site:wpmudev.org+bluehost+PayPal+IPN&hl=en

    If you just Google Bluehost and PayPal IPN you will see a whole list of people complaining.

    https://www.google.com/#hl=en&sugexp=eesh&gs_nf=1&cp=19&gs_id=6&xhr=t&q=bluehost+paypal+ipn

    There is nothing I can do at this point. You may want to call BlueHost on this but I think you will be wasting your time as Dean Roberts eventually did:
    https://premium.wpmudev.org/forums/topic/ipn-settings#post-240151

    If you have a PC I can prove in bout 10 minutes that it is indeed them, once you get the redirect loop fixed of course.

    Please advise.

    Cheers, Joe

  • Scosbo
    • WPMU DEV Initiate

    Thanks Joe.

    I figured it out with the Host. The endless loop and the paypal issue are resolved now.

    Here's the message form the host support: your .htaccess has something in it that's conflicting with the ability to log in. I renamed it to '.htaccess.bak' for now, so if you need something in there you can get it back. But you'll need to take a look at what's in there.

  • aecnu
    • WP Unicorn

    Greetings Scosbo,

    Thank you for letting us know, it is indeed greatly appreciated.

    But what did they modify in the htaccess file which would be obviously useful for others hosting with them to know.

    Not the looping but the PayPal IPN problem seems to be common.

    Any chance I can get you to post both the old htaccess file and the new one?

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Scosbo,

    Thank you so very much for that information and the attaching of the htaccess files.

    They are certainly a mess and unlike any htaccess files I have ever seen before.

    However, the significant part that I found between the two is the forcing of php 5.

    Which in turn tells me that php 4 must be on the servers as well.

    This is great to help other members facing similar issues.

    Previously I think the php calls were being made to php 4 and that is why all the trouble.

    A regular htaccess file looks like this:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress

    Anyway if it works it works and thank you for letting us know.

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.