Newly signed up users via Membership plugin not displaying on Activity Stream

I am working on implementing a Membership install (currently have a few active support threads on similar, but different issues).

I have gotten the signup process MOSTLY working, but there is one pesky wrinkle in the process.

When a free OR paid user registers, our Buddypress activity stream is not posting the customary "User became a registered member"

I cannot seem to pinpoint why Buddypress is not being notified of the new registrations and posting the status update accordingly. It's not a GAME ENDING bug... But I know that our community members typically enjoy giving greetings and well wishes to new users who join. Plus it helps drive community interaction when people see a steady influx of "new blood" joining.

Help fixing this would be immensely appreciated.

  • Kimberly

    Middleearth

    Hello and glad to see you are using Membership :slight_smile:

    Buddypress activity stream is not posting the customary "User became a registered member"

    This is probably because they are registering through Membership and not Buddypress. They do integrate but use different registration processes, buddypress has it's own while membership uses the wp one.

    We are currently trying to create a better relationship between membership and buddypress in a future update (coming soon hopefully!), and I will be sure to notify the developer of this as a feature request to ensure that it is on his radar as I agree with you, this is a great aspect of Buddypress and important for any Membership community.

    Thank You for bringing this to our attention!

    Best,

    Kimberly

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.